gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / printers.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages printers)
21 #:use-module (guix packages)
22 #:use-module (guix git-download)
23 #:use-module (guix build-system gnu)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (gnu packages libusb)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages qt))
28
29 ;; This is a module for packages related to printer-like devices, but not
30 ;; related to CUPS.
31
32 (define-public robocut
33 (package
34 (name "robocut")
35 (version "1.0.11")
36 (source
37 (origin
38 (method git-fetch)
39 (uri (git-reference
40 (url "https://github.com/Timmmm/robocut")
41 (commit (string-append "v" version))))
42 (file-name (git-file-name name version))
43 (sha256
44 (base32 "0dp9cssyik63yvkk35s51v94a873x751iqg93qzd8dpqkmz5z8gn"))))
45 (build-system gnu-build-system)
46 (arguments
47 '(#:phases (modify-phases %standard-phases
48 (replace 'configure
49 (lambda* (#:key outputs #:allow-other-keys)
50 (let ((out (assoc-ref outputs "out")))
51 (substitute* "Robocut.pro"
52 (("/usr/")
53 (string-append out "/")))
54
55 (invoke "qmake"
56 (string-append "PREFIX=" out))
57 #t))))))
58 (inputs
59 `(("libusb" ,libusb)
60 ("qt" ,qtbase)
61 ("qtsvg" ,qtsvg)))
62 (native-inputs
63 `(("pkg-config" ,pkg-config)
64 ("qmake" ,qtbase)))
65 (synopsis "Graphical program to drive plotting cutters")
66 (description
67 "Robocut is a simple graphical program that allows you to cut graphics
68 with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
69 (home-page "http://robocut.org")
70 (license license:gpl3+)))