gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / moreutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
3 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016–2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages moreutils)
22 #:use-module ((guix licenses) #:prefix l:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages xml)
28 #:use-module (gnu packages docbook))
29
30 (define-public moreutils
31 (package
32 (name "moreutils")
33 (version "0.65")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (list
38 (string-append
39 "https://git.joeyh.name/index.cgi/moreutils.git/snapshot/"
40 name "-" version ".tar.gz")
41 (string-append
42 "http://drabczyk.org/"
43 name "-" version ".tar.gz")))
44 (sha256
45 (base32 "10c8b4bwnli4gxwvgmgkc5kin1ksrxsnxmigs7y4rrh4aaszdjb0"))))
46 (build-system gnu-build-system)
47 ;; For building the manual pages.
48 (native-inputs
49 `(("docbook-xml" ,docbook-xml-4.4)
50 ("docbook-xsl" ,docbook-xsl)
51 ("libxml2" ,libxml2)
52 ("libxslt" ,libxslt)))
53 (inputs
54 `(("perl" ,perl)
55 ("perl-timedate" ,perl-timedate)
56 ("perl-time-duration" ,perl-time-duration)))
57 (arguments
58 `(#:phases
59 (modify-phases %standard-phases
60 (add-after 'install 'wrap-program
61 (lambda* (#:key outputs #:allow-other-keys)
62 (let* ((out (assoc-ref outputs "out")))
63 (wrap-program
64 (string-append out "/bin/ts")
65 `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
66 #t))
67 (delete 'configure)) ; no configure script
68 #:make-flags
69 (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
70 (string-append "DOCBOOKXSL="
71 (assoc-ref %build-inputs "docbook-xsl") "/xml/xsl/"
72 ,(package-name docbook-xsl) "-"
73 ,(package-version docbook-xsl))
74 "CC=gcc")))
75 (home-page "https://joeyh.name/code/moreutils/")
76 (synopsis "Miscellaneous general-purpose command-line tools")
77 (description
78 "Moreutils is a collection of general-purpose command-line tools to
79 augment the traditional Unix toolbox.")
80 (license l:gpl2+)))