gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / marst.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages marst)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (gnu packages compression)
24 #:use-module (guix build-system gnu))
25
26 (define-public marst
27 (package
28 (name "marst")
29 (version "2.7")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append
34 "mirror://gnu/" name "/" name "-" version
35 ".tar.gz"))
36 (sha256
37 (base32 "0l6swjy8fjrqw89ghc1vvakg21jmpfkpsw92yssrzkg3rg8vkrry"))))
38 (build-system gnu-build-system)
39 (home-page "https://www.gnu.org/software/marst/")
40 (synopsis "Algol-to-C translator")
41 (description
42 "GNU MARST is an Algol-to-C translator. The package consists of the
43 translator itself, a library that contains the necessary Algol 60 procedures,
44 and a converter that converts existing Algol 60 programs from other
45 representations to the MARST representation.")
46 (license gpl3+)))