gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / libftdi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libftdi)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix packages)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages libusb)
26 #:use-module (guix build-system cmake))
27
28 (define-public libftdi
29 (package
30 (name "libftdi")
31 (version "1.4")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append
35 "http://www.intra2net.com/en/developer/libftdi/download/libftdi1-"
36 version ".tar.bz2"))
37 (sha256
38 (base32
39 "0x0vncf6i92slgrn0h7ghkskqbglbs534220qa84d0qg114zndpc"))))
40 (build-system cmake-build-system)
41 (propagated-inputs
42 `(("libusb" ,libusb))) ; required by libftdi1.pc
43 (home-page "https://www.intra2net.com/en/developer/libftdi/")
44 (synopsis "FTDI USB driver with bitbang mode")
45 (description
46 "libFTDI is a library to talk to FTDI chips: FT232BM,
47 FT245BM, FT2232C, FT2232D, FT245R and FT232H including the popular
48 bitbangmode.")
49 (license lgpl2.1)))