gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / libffcall.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Joshua S. Grant <jgrant@parenthetical.io>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages libffcall)
23 #:use-module ((guix licenses) #:prefix l:)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public libffcall
29 (package
30 (name "libffcall")
31 (version "2.2")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append
36 "mirror://gnu/libffcall/libffcall-" version ".tar.gz"))
37 (sha256
38 (base32
39 "0ixp7kbr7y8s34nsrsdfh77ig5c2zkwr6cfg9v1gm53cggwkgypb"))))
40 (build-system gnu-build-system)
41 (arguments
42 '(#:parallel-build? #f
43 #:configure-flags '("--disable-static")))
44 (synopsis "Foreign function calls from interpreters")
45 (description
46 "GNU Libffcall is a collection of libraries that can be used to build
47 foreign function call interfaces in embedded interpreters.")
48 (home-page "https://www.gnu.org/software/libffcall/")
49 (license l:gpl2+)))