gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / figlet.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages figlet)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public figlet
26 (package
27 (name "figlet")
28 (version "2.2.5")
29 (source
30 (origin
31 (method url-fetch)
32 (uri (string-append "ftp://ftp.figlet.org/pub/figlet/program"
33 "/unix/figlet-" version ".tar.gz"))
34 (sha256
35 (base32 "0za1ax15x7myjl8jz271ybly8ln9kb9zhm1gf6rdlxzhs07w925z"))))
36 (build-system gnu-build-system)
37 (arguments
38 `(#:phases
39 (modify-phases %standard-phases (delete 'configure))
40 #:make-flags
41 (list (string-append "prefix=" %output))))
42 (home-page "http://www.figlet.org/")
43 (synopsis "Make large letterforms out of ordinary screen characters")
44 (description "FIGlet is a program for making large ASCII art letterforms
45 out of ordinary screen characters.")
46 (license license:bsd-3)))