gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / cyrus-sasl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages cyrus-sasl)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages autotools)
25 #:use-module (gnu packages dbm)
26 #:use-module (gnu packages kerberos)
27 #:use-module (gnu packages tls)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (guix packages)
30 #:use-module (guix download)
31 #:use-module (guix build-system gnu))
32
33 (define-public cyrus-sasl
34 (package
35 (name "cyrus-sasl")
36 (version "2.1.27")
37 (source (origin
38 (method url-fetch)
39 (uri (list (string-append
40 "https://cyrusimap.org/releases/cyrus-sasl-"
41 version ".tar.gz")
42 (string-append
43 "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
44 version ".tar.gz")))
45 (sha256 (base32
46 "1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))
47 (patches (search-patches "cyrus-sasl-ac-try-run-fix.patch"))))
48 (replacement cyrus-sasl/fixed)
49 (build-system gnu-build-system)
50 (native-inputs
51 `(("autoconf" ,autoconf)
52 ("automake" ,automake)
53 ("libtool" ,libtool)))
54 (inputs `(("gdbm" ,gdbm)
55 ("openssl" ,openssl)))
56 (propagated-inputs
57 `(;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
58 ("mit-krb5" ,mit-krb5)))
59 (arguments
60 '(#:configure-flags (list (string-append "--with-plugindir="
61 (assoc-ref %outputs "out")
62 "/lib/sasl2"))
63
64 ;; The 'plugins' directory has shared source files, such as
65 ;; 'plugin_common.c'. When building the shared libraries there, libtool
66 ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
67 ;; fail with EEXIST when building things in parallel.
68 #:parallel-build? #f
69
70 #:phases
71 (modify-phases %standard-phases
72 (add-after 'unpack 'autogen
73 (lambda _
74 (invoke "autoreconf" "-vif"))))))
75 (synopsis "Simple Authentication Security Layer implementation")
76 (description
77 "SASL (Simple Authentication Security Layer) is an Internet
78 standards-track method for remote computers to authenticate. The Cyrus SASL
79 library makes supporting various SASL mechanisms easy for both client and
80 server writers.")
81 (license (license:non-copyleft "file://COPYING"
82 "See COPYING in the distribution."))
83 (home-page "https://cyrusimap.org/sasl/")))
84
85 (define cyrus-sasl/fixed
86 (package
87 (inherit cyrus-sasl)
88 (version "2.1.27")
89 (source (origin
90 (method url-fetch)
91 (uri (list (string-append
92 "https://cyrusimap.org/releases/cyrus-sasl-"
93 version ".tar.gz")
94 (string-append
95 "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
96 version ".tar.gz")))
97 (sha256 (base32
98 "1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))
99 (patches (search-patches "cyrus-sasl-ac-try-run-fix.patch"
100 "cyrus-sasl-CVE-2019-19906.patch"))))))