gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / convmv.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages convmv)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages perl)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public convmv
28 (package
29 (name "convmv")
30 (version "2.05")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "https://www.j3e.de/linux/convmv/convmv-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "19hwv197p7c23f43vvav5bs19z9b72jzca2npkjsxgprwj5ardjk"))))
38 (build-system gnu-build-system)
39 (arguments
40 `(#:test-target "test"
41 #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out")))
42 #:phases
43 (modify-phases %standard-phases
44 (delete 'bootstrap)
45 (delete 'configure)
46 (add-before 'check 'unpack-testsuite
47 (lambda _
48 (invoke "tar" "xf" "testsuite.tar")
49 (patch-shebang "suite/dotests.sh")
50 (patch-shebang "suite/parsable_tester.pl")
51 #t)))))
52 (inputs
53 `(("perl" ,perl)))
54 (synopsis "Convert filenames between character sets")
55 (description
56 "convmv is a file renamer, that converts between different encodings,
57 e.g. from ISO-8859-1 to UTF-8. It is particularly usefuls for files with
58 names, that display incorrectly.")
59 (license (list gpl2 gpl3))
60 (home-page "https://www.j3e.de/")))