gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / antivirus.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
3 ;;; Copyright © 2018 Christopher Baines <mail@cbaines.net>
4 ;;; Copyright © 2019–2021 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages antivirus)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix utils)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages autotools)
29 #:use-module (gnu packages bison)
30 #:use-module (gnu packages check)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages curl)
33 #:use-module (gnu packages cyrus-sasl)
34 #:use-module (gnu packages flex)
35 #:use-module (gnu packages llvm)
36 #:use-module (gnu packages multiprecision)
37 #:use-module (gnu packages ncurses)
38 #:use-module (gnu packages pcre)
39 #:use-module (gnu packages pkg-config)
40 #:use-module (gnu packages tls)
41 #:use-module (gnu packages web)
42 #:use-module (gnu packages xml))
43
44 (define-public clamav
45 (package
46 (name "clamav")
47 (version "0.103.2")
48 (source (origin
49 (method url-fetch)
50 (uri (string-append "https://www.clamav.net/downloads/production/"
51 "clamav-" version ".tar.gz"))
52 (sha256
53 (base32
54 "1lhv4xw89sszi519agvc9mi6jz5aiivm9yr6lciy8qk2csnd1dfl"))
55 (modules '((guix build utils)))
56 (snippet
57 '(begin
58 (for-each delete-file-recursively
59 '("win32" ; unnecessary
60 "libclamav/c++/llvm" ; use system llvm
61 "libclamav/tomsfastmath" ; use system tomsfastmath
62 "libclamunrar")) ; non-free license
63 #t))
64 (patches
65 (search-patches "clamav-system-tomsfastmath.patch"
66 "clamav-config-llvm-libs.patch"))))
67 (build-system gnu-build-system)
68 (native-inputs
69 `(("autoconf" ,autoconf)
70 ("automake" ,automake)
71 ("check" ,check) ; for tests
72 ("libtool" ,libtool)
73 ("pkg-config" ,pkg-config)))
74 (inputs
75 `(("bzip2" ,bzip2)
76 ("libcurl" ,curl)
77 ("libjson" ,json-c)
78 ("libltdl" ,libltdl)
79 ("libmspack" ,libmspack)
80 ("llvm" ,llvm-3.6) ; requires <3.7, for JIT/verifier
81 ("ncurses" ,ncurses)
82 ("openssl" ,libressl)
83 ("pcre2" ,pcre2)
84 ("sasl" ,cyrus-sasl) ; for linking curl with libtool
85 ("tomsfastmath" ,tomsfastmath)
86 ("xml" ,libxml2)
87 ("zlib" ,zlib)))
88 (arguments
89 `(#:configure-flags
90 (let-syntax ((with (syntax-rules ()
91 ((_ name)
92 (string-append "--with-" name "="
93 (assoc-ref %build-inputs name))))))
94 (list "--disable-unrar"
95 "--enable-llvm"
96 "--with-system-llvm"
97 "--with-system-libmspack"
98 "--without-included-ltdl"
99 (with "xml")
100 (with "openssl")
101 (with "libjson")
102 (with "pcre2")
103 (with "zlib")
104 (with "libcurl")
105 ;; For sanity, specifying --enable-* flags turns
106 ;; "support unavailable" warnings into errors.
107 "--enable-bzip2"
108 "--enable-check"
109 "--sysconfdir=/etc/clamav"
110 ;; Default database directory needs to be writeable
111 "--with-dbdir=/var/db/clamav"))
112 ;; install sample .conf files to %output/etc rather than /etc/clamav
113 #:make-flags (list (string-append "sysconfdir=" %output "/etc"))
114 #:phases (modify-phases %standard-phases
115 ;; Regenerate configure script. Without this we don't get
116 ;; the correct value for LLVM linker variables.
117 (add-after 'unpack 'reconf
118 (lambda _ (invoke "autoreconf" "-vfi")))
119 (add-before 'configure 'patch-llvm-config
120 (lambda _
121 (substitute* '("libclamav/c++/detect.cpp"
122 "libclamav/c++/ClamBCRTChecks.cpp"
123 "libclamav/c++/bytecode2llvm.cpp")
124 (("llvm/Config/config.h") "llvm/Config/llvm-config.h"))
125 ;; `llvm-config --libfiles` inappropriately lists lib*.a
126 ;; libraries, rather than the lib*.so's that our llvm
127 ;; contains. They're used only for listing extra build
128 ;; dependencies, so ignore them until that's fixed.
129 (substitute* "libclamav/c++/Makefile.in"
130 (("@LLVMCONFIG_LIBFILES@") ""))
131 #t))
132 (add-before 'check 'skip-clamd-tests
133 ;; XXX: The check?_clamd tests fail inside the build
134 ;; chroot, but pass outside.
135 (lambda _
136 (substitute* "unit_tests/Makefile"
137 (("check2_clamd.sh.*check4_clamd.sh") ""))
138 #t)))))
139 (home-page "https://www.clamav.net")
140 (synopsis "Antivirus engine")
141 (description
142 "Clam AntiVirus is an anti-virus toolkit, designed especially for e-mail
143 scanning on mail gateways. It provides a number of utilities including a
144 flexible and scalable multi-threaded daemon, a command line scanner, and
145 advanced tool for automatic database updates. The core of the package is an
146 anti-virus engine available in the form of a shared library.")
147 (license (list license:gpl2+ ;ClamAV itself
148 license:lgpl2.1 ;libclamav/mspack.[ch]
149 license:public-domain ;libclamav/7z/*, libclamav/rijndael.[ch], etc...
150 (package-license bzip2) ;modified bzip2 source in libclamav/nsis
151 license:bsd-2 ;several files in libclamav
152 license:bsd-3 ;libclamav/{regex,qsort.c,swf.[ch]
153 license:ncsa ;libclamav/c++/PointerTracking.cpp
154 license:zlib ;libclamav/inf*.h
155 license:x11 ;libclamav/lzw
156 (license:non-copyleft "libclamav/strlcat.c") ;"OpenBSD" license
157 license:asl2.0 ;libclamav/yara*
158 license:expat)))) ;shared/getopt.[ch]