gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / abiword.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
3 ;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
6 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages abiword)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu)
29 #:use-module (guix build-system glib-or-gtk)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages autotools)
32 #:use-module (gnu packages boost)
33 #:use-module (gnu packages compression)
34 #:use-module (gnu packages enchant)
35 #:use-module (gnu packages fribidi)
36 #:use-module (gnu packages fontutils)
37 #:use-module (gnu packages glib)
38 #:use-module (gnu packages gnome)
39 #:use-module (gnu packages gtk)
40 #:use-module (gnu packages image)
41 #:use-module (gnu packages ots)
42 #:use-module (gnu packages popt)
43 #:use-module (gnu packages pkg-config)
44 #:use-module (gnu packages readline)
45 #:use-module (gnu packages wv)
46 #:use-module (gnu packages xml))
47
48 (define-public abiword
49 (package
50 (name "abiword")
51 (version "3.0.4")
52 (source
53 (origin
54 (method url-fetch)
55 (uri
56 (string-append "https://www.abisource.com/downloads/abiword/" version
57 "/source/abiword-" version ".tar.gz"))
58 (sha256
59 (base32 "1mx5l716n0z5788i19qmad30cck4v9ggr071cafw2nrf375rcc79"))
60 (patches
61 (search-patches "abiword-explictly-cast-bools.patch"))))
62
63 (build-system glib-or-gtk-build-system)
64 (arguments ;; NOTE: rsvg is disabled, since Abiword
65 `(#:configure-flags ;; supports it directly, and its BS is broken.
66 (list ;; wmf was removed from Guix for security.
67 "--enable-clipart" ;; TODO: The following plugins have unresolved
68 "--enable-templates" ;; dependencies: aiksaurus, grammar, wpg, gda,
69 (string-append ;; wordperfect, psion, mathview.
70 "--enable-plugins="
71 "applix " "babelfish " "bmp " "clarisworks " "collab " "command "
72 "docbook " "eml " "epub " "freetranslation " "garble " "gdict "
73 "gimp " "goffice " "google " "hancom " "hrtext " "iscii " "kword "
74 "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
75 "openwriter " "openxml " "opml " "ots " "paint " "passepartout "
76 "pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
77 "wikipedia " "wml " "xslfo"))
78 ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
79 ;; assertion 'GDK_IS_SCREEN (screen)' failed
80 ;; GLib-GObject-CRITICAL **: g_object_get_qdata:
81 ;; assertion 'G_IS_OBJECT (object)' failed
82 ;; Manually starting the X server before the test phase did not help
83 ;; the tests to pass.
84 #:tests? #f
85 #:make-flags
86 (list "gtk_update_icon_cache=true")))
87 (inputs
88 `(("boost" ,boost)
89 ("enchant" ,enchant)
90 ("fontconfig" ,fontconfig)
91 ("fribidi" ,fribidi)
92 ("glib" ,glib)
93 ("goffice" ,goffice)
94 ("gtk+" ,gtk+)
95 ("libchamplain" ,libchamplain)
96 ("libglade" ,libglade)
97 ("libgsf" ,libgsf)
98 ("libjpeg" ,libjpeg-turbo)
99 ("libpng" ,libpng)
100 ("librsvg" ,librsvg)
101 ("libxml2" ,libxml2)
102 ("libxslt" ,libxslt)
103 ("ots" ,ots)
104 ("popt" ,popt)
105 ("readline" ,readline)
106 ("telepathy" ,telepathy-glib)
107 ("wv" ,wv)
108 ("zlib" ,zlib)))
109 (native-inputs
110 `(("intltool" ,intltool)
111 ("glib:bin" ,glib "bin")
112 ("libtool" ,libtool)
113 ("pkg-config" ,pkg-config)))
114 (home-page "https://www.abisource.com/")
115 (synopsis "Word processing program")
116
117 ;; HACKERS: The comment below is here so that it shows up early in the
118 ;; .pot file.
119
120 ;; TRANSLATORS: Dear translator, We would like to inform you that package
121 ;; descriptions may occasionally include Texinfo markup. Texinfo markup
122 ;; looks like "@code{rm -rf}", "@emph{important}", etc. When translating,
123 ;; please leave markup as is.
124 (description "AbiWord is a word processing program. It is rapidly
125 becoming a state of the art word processor, with lots of features useful for
126 your daily work, personal needs, or for just some good old typing fun.")
127 (license license:gpl2+)))