gnu: gnupg: Upgrade support libraries.
[jackhill/guix/guix.git] / gnu / packages / gdbm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gdbm)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public gdbm
26 (package
27 (name "gdbm")
28 (version "1.10")
29 (source
30 (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/gdbm/gdbm-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "0h9lfzdjc2yl849y0byg51h6xfjg0y7vg9jnsw3gpfwlbd617y13"))))
37 (arguments `(#:configure-flags '("--enable-libgdbm-compat")))
38 (build-system gnu-build-system)
39 (home-page "http://www.gnu.org/software/gdbm/")
40 (synopsis
41 "Hash library of database functions compatible with traditional dbm")
42 (description
43 "GNU dbm (or GDBM, for short) is a library of database functions
44 that use extensible hashing and work similar to the standard UNIX dbm.
45 These routines are provided to a programmer needing to create and
46 manipulate a hashed database.
47
48 The basic use of GDBM is to store key/data pairs in a data file. Each
49 key must be unique and each key is paired with only one data item.
50
51 The library provides primitives for storing key/data pairs, searching
52 and retrieving the data by its key and deleting a key along with its
53 data. It also support sequential iteration over all key/data pairs in a
54 database.
55
56 For compatibility with programs using old UNIX dbm function, the package
57 also provides traditional dbm and ndbm interfaces.")
58 (license gpl3+)))