Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / gcc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014, 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
6 ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages gcc)
25 #:use-module ((guix licenses)
26 #:select (gpl3+ gpl2+ lgpl2.1+ lgpl2.0+ fdl1.3+))
27 #:use-module (gnu packages)
28 #:use-module (gnu packages bootstrap)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages multiprecision)
31 #:use-module (gnu packages texinfo)
32 #:use-module (gnu packages dejagnu)
33 #:use-module (gnu packages documentation)
34 #:use-module (gnu packages xml)
35 #:use-module (gnu packages docbook)
36 #:use-module (gnu packages graphviz)
37 #:use-module (gnu packages elf)
38 #:use-module (gnu packages perl)
39 #:use-module (guix packages)
40 #:use-module (guix download)
41 #:use-module (guix build-system gnu)
42 #:use-module (guix build-system trivial)
43 #:use-module (guix utils)
44 #:use-module (srfi srfi-1)
45 #:use-module (ice-9 regex))
46
47 (define %gcc-infrastructure
48 ;; Base URL for GCC's infrastructure.
49 "mirror://gcc/infrastructure/")
50
51 (define (gcc-configure-flags-for-triplet target)
52 "Return a list of additional GCC `configure' flags for TARGET, a GNU triplet.
53
54 The purpose of this procedure is to translate extended GNU triplets---e.g.,
55 where the OS part is overloaded to denote a specific ABI---into GCC
56 `configure' options. We take extended GNU triplets that glibc recognizes."
57 (cond ((string-match "^mips64el.*gnuabin?64$" target)
58 ;; Triplets recognized by glibc as denoting the N64 ABI; see
59 ;; ports/sysdeps/mips/preconfigure.
60 '("--with-abi=64"))
61
62 ((string-match "^arm.*-gnueabihf$" target)
63 '("--with-arch=armv7-a"
64 "--with-float=hard"
65 "--with-mode=thumb"
66 "--with-fpu=neon"))
67
68 (else
69 ;; TODO: Add `arm.*-gnueabi', etc.
70 '())))
71
72 (define-public gcc-4.7
73 (let* ((stripped? #t) ;whether to strip the compiler, not the libraries
74 (maybe-target-tools
75 (lambda ()
76 ;; Return the `_FOR_TARGET' variables that are needed when
77 ;; cross-compiling GCC.
78 (let ((target (%current-target-system)))
79 (if target
80 (map (lambda (var tool)
81 (string-append (string-append var "_FOR_TARGET")
82 "=" target "-" tool))
83 '("CC" "CXX" "LD" "AR" "NM" "RANLIB" "STRIP")
84 '("gcc" "g++" "ld" "ar" "nm" "ranlib" "strip"))
85 '()))))
86 (libdir
87 (let ((base '(or (assoc-ref outputs "lib")
88 (assoc-ref outputs "out"))))
89 (lambda ()
90 ;; Return the directory that contains lib/libgcc_s.so et al.
91 (if (%current-target-system)
92 `(string-append ,base "/" ,(%current-target-system))
93 base))))
94 (configure-flags
95 (lambda ()
96 ;; This is terrible. Since we have two levels of quasiquotation,
97 ;; we have to do this convoluted thing just so we can insert the
98 ;; contents of (maybe-target-tools).
99 (list 'quasiquote
100 (append
101 '("--enable-plugin"
102 "--enable-languages=c,c++"
103 "--disable-multilib"
104 "--with-system-zlib"
105
106 ;; No pre-compiled libstdc++ headers, to save space.
107 "--disable-libstdcxx-pch"
108
109 "--with-local-prefix=/no-gcc-local-prefix"
110
111 ;; With a separate "lib" output, the build system
112 ;; incorrectly guesses GPLUSPLUS_INCLUDE_DIR, so force
113 ;; it. (Don't use a versioned sub-directory, that's
114 ;; unnecessary.)
115 ,(string-append "--with-gxx-include-dir="
116 (assoc-ref %outputs "out")
117 "/include/c++")
118
119 ,(let ((libc (assoc-ref %build-inputs "libc")))
120 (if libc
121 (string-append "--with-native-system-header-dir=" libc
122 "/include")
123 "--without-headers")))
124
125 ;; Pass the right options for the target triplet.
126 (let ((triplet
127 (or (%current-target-system)
128 (nix-system->gnu-triplet (%current-system)))))
129 (gcc-configure-flags-for-triplet triplet))
130
131 (maybe-target-tools))))))
132 (package
133 (name "gcc")
134 (version "4.7.4")
135 (source (origin
136 (method url-fetch)
137 (uri (string-append "mirror://gnu/gcc/gcc-"
138 version "/gcc-" version ".tar.bz2"))
139 (sha256
140 (base32
141 "10k2k71kxgay283ylbbhhs51cl55zn2q38vj5pk4k950qdnirrlj"))))
142 (build-system gnu-build-system)
143
144 ;; Separate out the run-time support libraries because all the
145 ;; dynamic-linked objects depend on it.
146 (outputs '("out" ;commands, etc. (60+ MiB)
147 "lib" ;libgcc_s, libgomp, etc. (15+ MiB)
148 "debug")) ;debug symbols of run-time libraries
149
150 (inputs `(("gmp" ,gmp)
151 ("mpfr" ,mpfr)
152 ("mpc" ,mpc)
153 ("isl" ,isl)
154 ("cloog" ,cloog)
155 ("libelf" ,libelf)
156 ("zlib" ,zlib)))
157
158 ;; GCC < 5 is one of the few packages that doesn't ship .info files.
159 ;; Newer texinfos fail to build the manual, so we use an older one.
160 (native-inputs `(("texinfo" ,texinfo-5)))
161
162 (arguments
163 `(#:out-of-source? #t
164 #:configure-flags ,(configure-flags)
165 #:make-flags
166 ;; None of the flags below are needed when doing a Canadian cross.
167 ;; TODO: Simplify this.
168 ,(if (%current-target-system)
169 (if stripped?
170 ''("CFLAGS=-g0 -O2")
171 ''())
172 `(let* ((libc (assoc-ref %build-inputs "libc"))
173 (libc-native (or (assoc-ref %build-inputs "libc-native")
174 libc)))
175 `(,@(if libc
176 (list (string-append "LDFLAGS_FOR_TARGET="
177 "-B" libc "/lib "
178 "-Wl,-dynamic-linker "
179 "-Wl," libc
180 ,(glibc-dynamic-linker)))
181 '())
182
183 ;; Native programs like 'genhooks' also need that right.
184 ,(string-append "LDFLAGS="
185 "-Wl,-rpath=" libc-native "/lib "
186 "-Wl,-dynamic-linker "
187 "-Wl," libc-native ,(glibc-dynamic-linker))
188 ,(string-append "BOOT_CFLAGS=-O2 "
189 ,(if stripped? "-g0" "-g")))))
190
191 #:tests? #f
192
193 #:phases
194 (alist-cons-before
195 'configure 'pre-configure
196 (lambda* (#:key inputs outputs #:allow-other-keys)
197 (let ((libdir ,(libdir))
198 (libc (assoc-ref inputs "libc")))
199 (when libc
200 ;; The following is not performed for `--without-headers'
201 ;; cross-compiler builds.
202
203 ;; Join multi-line definitions of GLIBC_DYNAMIC_LINKER* into a
204 ;; single line, to allow the next step to work properly.
205 (for-each
206 (lambda (x)
207 (substitute* (find-files "gcc/config"
208 "^(linux|gnu|sysv4)(64|-elf|-eabi)?\\.h$")
209 (("(#define (GLIBC|GNU_USER)_DYNAMIC_LINKER.*)\\\\\n$" _ line)
210 line)))
211 '(1 2 3))
212
213 ;; Fix the dynamic linker's file name.
214 (substitute* (find-files "gcc/config"
215 "^(linux|gnu|sysv4)(64|-elf|-eabi)?\\.h$")
216 (("#define (GLIBC|GNU_USER)_DYNAMIC_LINKER([^ \t]*).*$"
217 _ gnu-user suffix)
218 (format #f "#define ~a_DYNAMIC_LINKER~a \"~a\"~%"
219 gnu-user suffix
220 (string-append libc ,(glibc-dynamic-linker)))))
221
222 ;; Tell where to find libstdc++, libc, and `?crt*.o', except
223 ;; `crt{begin,end}.o', which come with GCC.
224 (substitute* (find-files "gcc/config"
225 "^gnu-user.*\\.h$")
226 (("#define GNU_USER_TARGET_LIB_SPEC (.*)$" _ suffix)
227 ;; Help libgcc_s.so be found (see also below.) Always use
228 ;; '-lgcc_s' so that libgcc_s.so is always found by those
229 ;; programs that use 'pthread_cancel' (glibc dlopens
230 ;; libgcc_s.so when pthread_cancel support is needed, but
231 ;; having it in the application's RUNPATH isn't enough; see
232 ;; <http://sourceware.org/ml/libc-help/2013-11/msg00023.html>.)
233 ;;
234 ;; NOTE: The '-lgcc_s' added below needs to be removed in a
235 ;; later phase of %gcc-static. If you change the string
236 ;; below, make sure to update the relevant code in
237 ;; %gcc-static package as needed.
238 (format #f "#define GNU_USER_TARGET_LIB_SPEC \
239 \"-L~a/lib %{!static:-rpath=~a/lib %{!static-libgcc:-rpath=~a/lib -lgcc_s}} \" ~a"
240 libc libc libdir suffix))
241 (("#define GNU_USER_TARGET_STARTFILE_SPEC.*$" line)
242 (format #f "#define STANDARD_STARTFILE_PREFIX_1 \"~a/lib\"
243 #define STANDARD_STARTFILE_PREFIX_2 \"\"
244 ~a"
245 libc line)))
246
247 ;; The rs6000 (a.k.a. powerpc) config in GCC does not use
248 ;; GNU_USER_* defines. Do the above for this case.
249 (substitute*
250 "gcc/config/rs6000/sysv4.h"
251 (("#define LIB_LINUX_SPEC (.*)$" _ suffix)
252 (format #f "#define LIB_LINUX_SPEC \
253 \"-L~a/lib %{!static:-rpath=~a/lib %{!static-libgcc:-rpath=~a/lib -lgcc_s}} \" ~a"
254 libc libc libdir suffix))
255 (("#define STARTFILE_LINUX_SPEC.*$" line)
256 (format #f "#define STANDARD_STARTFILE_PREFIX_1 \"~a/lib\"
257 #define STANDARD_STARTFILE_PREFIX_2 \"\"
258 ~a"
259 libc line))))
260
261 ;; Don't retain a dependency on the build-time sed.
262 (substitute* "fixincludes/fixincl.x"
263 (("static char const sed_cmd_z\\[\\] =.*;")
264 "static char const sed_cmd_z[] = \"sed\";"))
265
266 ;; Aarch64 support didn't land in GCC until the 4.8 series.
267 (when (file-exists? "gcc/config/aarch64")
268 ;; Force Aarch64 libdir to be /lib and not /lib64
269 (substitute* "gcc/config/aarch64/t-aarch64-linux"
270 (("lib64") "lib")))
271
272 (when (file-exists? "libbacktrace")
273 ;; GCC 4.8+ comes with libbacktrace. By default it builds
274 ;; with -Werror, which fails with a -Wcast-qual error in glibc
275 ;; 2.21's stdlib-bsearch.h. Remove -Werror.
276 (substitute* "libbacktrace/configure"
277 (("WARN_FLAGS=(.*)-Werror" _ flags)
278 (string-append "WARN_FLAGS=" flags)))
279
280 (when (file-exists? "libsanitizer/libbacktrace")
281 ;; Same in libsanitizer's bundled copy (!) found in 4.9+.
282 (substitute* "libsanitizer/libbacktrace/Makefile.in"
283 (("-Werror")
284 ""))))
285
286 ;; Add a RUNPATH to libstdc++.so so that it finds libgcc_s.
287 ;; See <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=32354>
288 ;; and <http://bugs.gnu.org/20358>.
289 (substitute* "libstdc++-v3/src/Makefile.in"
290 (("^OPT_LDFLAGS = ")
291 "OPT_LDFLAGS = -Wl,-rpath=$(libdir) "))
292
293 ;; Move libstdc++*-gdb.py to the "lib" output to avoid a
294 ;; circularity between "out" and "lib". (Note:
295 ;; --with-python-dir is useless because it imposes $(prefix) as
296 ;; the parent directory.)
297 (substitute* "libstdc++-v3/python/Makefile.in"
298 (("pythondir = .*$")
299 (string-append "pythondir = " libdir "/share"
300 "/gcc-$(gcc_version)/python\n")))
301
302 ;; Avoid another circularity between the outputs: this #define
303 ;; ends up in auto-host.h in the "lib" output, referring to
304 ;; "out". (This variable is used to augment cpp's search path,
305 ;; but there's nothing useful to look for here.)
306 (substitute* "gcc/config.in"
307 (("PREFIX_INCLUDE_DIR")
308 "PREFIX_INCLUDE_DIR_isnt_necessary_here"))))
309
310 (alist-cons-after
311 'configure 'post-configure
312 (lambda _
313 ;; Don't store configure flags, to avoid retaining references to
314 ;; build-time dependencies---e.g., `--with-ppl=/gnu/store/xxx'.
315 (substitute* "Makefile"
316 (("^TOPLEVEL_CONFIGURE_ARGUMENTS=(.*)$" _ rest)
317 "TOPLEVEL_CONFIGURE_ARGUMENTS=\n")))
318 %standard-phases))))
319
320 (native-search-paths
321 ;; Use the language-specific variables rather than 'CPATH' because they
322 ;; are equivalent to '-isystem' whereas 'CPATH' is equivalent to '-I'.
323 ;; The intent is to allow headers that are in the search path to be
324 ;; treated as "system headers" (headers exempt from warnings) just like
325 ;; the typical /usr/include headers on an FHS system.
326 (list (search-path-specification
327 (variable "C_INCLUDE_PATH")
328 (files '("include")))
329 (search-path-specification
330 (variable "CPLUS_INCLUDE_PATH")
331 (files '("include")))
332 (search-path-specification
333 (variable "LIBRARY_PATH")
334 (files '("lib" "lib64")))))
335
336 (properties `((gcc-libc . ,(assoc-ref inputs "libc"))))
337 (synopsis "GNU Compiler Collection")
338 (description
339 "GCC is the GNU Compiler Collection. It provides compiler front-ends
340 for several languages, including C, C++, Objective-C, Fortran, Java, Ada, and
341 Go. It also includes runtime support libraries for these languages.")
342 (license gpl3+)
343 (home-page "https://gcc.gnu.org/"))))
344
345 (define-public gcc-4.8
346 (package (inherit gcc-4.7)
347 (version "4.8.5")
348 (source (origin
349 (method url-fetch)
350 (uri (string-append "mirror://gnu/gcc/gcc-"
351 version "/gcc-" version ".tar.bz2"))
352 (sha256
353 (base32
354 "08yggr18v373a1ihj0rg2vd6psnic42b518xcgp3r9k81xz1xyr2"))
355 (patches (search-patches "gcc-arm-link-spec-fix.patch"))))))
356
357 (define-public gcc-4.9
358 (package (inherit gcc-4.7)
359 (version "4.9.4")
360 (source (origin
361 (method url-fetch)
362 (uri (string-append "mirror://gnu/gcc/gcc-"
363 version "/gcc-" version ".tar.bz2"))
364 (sha256
365 (base32
366 "14l06m7nvcvb0igkbip58x59w3nq6315k6jcz3wr9ch1rn9d44bc"))
367 (patches (search-patches "gcc-arm-bug-71399.patch"
368 "gcc-libvtv-runpath.patch"))))
369 (native-inputs `(("texinfo" ,texinfo)))))
370
371 (define-public gcc-5
372 ;; Note: GCC >= 5 ships with .info files but 'make install' fails to install
373 ;; them in a VPATH build.
374 (package (inherit gcc-4.9)
375 (version "5.4.0")
376 (source (origin
377 (method url-fetch)
378 (uri (string-append "mirror://gnu/gcc/gcc-"
379 version "/gcc-" version ".tar.bz2"))
380 (sha256
381 (base32
382 "0fihlcy5hnksdxk0sn6bvgnyq8gfrgs8m794b1jxwd1dxinzg3b0"))
383 (patches (search-patches "gcc-arm-bug-71399.patch"
384 "gcc-strmov-store-file-names.patch"
385 "gcc-asan-powerpc-missing-include.patch"
386 "gcc-5.0-libvtv-runpath.patch"
387 "gcc-5-source-date-epoch-1.patch"
388 "gcc-5-source-date-epoch-2.patch"))))))
389
390 (define-public gcc-6
391 (package
392 (inherit gcc-5)
393 (version "6.4.0")
394 (source (origin
395 (method url-fetch)
396 (uri (string-append "mirror://gnu/gcc/gcc-"
397 version "/gcc-" version ".tar.xz"))
398 (sha256
399 (base32
400 "1m0lr7938lw5d773dkvwld90hjlcq2282517d1gwvrfzmwgg42w5"))
401 (patches (search-patches "gcc-strmov-store-file-names.patch"
402 "gcc-5.0-libvtv-runpath.patch"))))))
403 (define-public gcc-7
404 (package
405 (inherit gcc-6)
406 (version "7.1.0")
407 (source (origin
408 (method url-fetch)
409 (uri (string-append "mirror://gnu/gcc/gcc-"
410 version "/gcc-" version ".tar.bz2"))
411 (sha256
412 (base32
413 "05xwps0ci7wgxh50askpa2r9p8518qxdgh6ad7pnyk7n6p13d0ca"))
414 (patches (search-patches "gcc-strmov-store-file-names.patch"
415 "gcc-5.0-libvtv-runpath.patch"))))))
416
417 ;; Note: When changing the default gcc version, update
418 ;; the gcc-toolchain-* definitions and the gfortran definition
419 ;; accordingly.
420 (define-public gcc gcc-5)
421
422 (define-public (make-libstdc++ gcc)
423 "Return a libstdc++ package based on GCC. The primary use case is when
424 using compilers other than GCC."
425 (package
426 (inherit gcc)
427 (name "libstdc++")
428 (arguments
429 `(#:out-of-source? #t
430 #:phases (alist-cons-before
431 'configure 'chdir
432 (lambda _
433 (chdir "libstdc++-v3"))
434 %standard-phases)
435 #:configure-flags `("--disable-libstdcxx-pch"
436 ,(string-append "--with-gxx-include-dir="
437 (assoc-ref %outputs "out")
438 "/include"))))
439 (outputs '("out" "debug"))
440 (inputs '())
441 (native-inputs '())
442 (propagated-inputs '())
443 (synopsis "GNU C++ standard library")))
444
445 (define-public libstdc++-4.9
446 (make-libstdc++ gcc-4.9))
447
448 (define (make-libiberty gcc)
449 "Return a libiberty package based on GCC."
450 (package
451 (inherit gcc)
452 (name "libiberty")
453 (arguments
454 `(#:out-of-source? #t
455 #:phases
456 (modify-phases %standard-phases
457 (add-before 'configure 'chdir
458 (lambda _
459 (chdir "libiberty")
460 #t))
461 (replace
462 'install
463 (lambda* (#:key outputs #:allow-other-keys)
464 (let* ((out (assoc-ref outputs "out"))
465 (lib (string-append out "/lib/"))
466 (include (string-append out "/include/")))
467 (mkdir-p lib)
468 (mkdir-p include)
469 (copy-file "libiberty.a"
470 (string-append lib "libiberty.a"))
471 (copy-file "../include/libiberty.h"
472 (string-append include "libiberty.h"))
473 #t))))))
474 (inputs '())
475 (outputs '("out"))
476 (native-inputs '())
477 (propagated-inputs '())
478 (synopsis "Collection of subroutines used by various GNU programs")))
479
480 (define-public libiberty
481 (make-libiberty gcc))
482
483 (define* (custom-gcc gcc name languages
484 #:optional
485 (search-paths (package-native-search-paths gcc))
486 #:key (separate-lib-output? #t))
487 "Return a custom version of GCC that supports LANGUAGES. Use SEARCH-PATHS
488 as the 'native-search-paths' field."
489 (package (inherit gcc)
490 (name name)
491 (outputs (if separate-lib-output?
492 (package-outputs gcc)
493 (delete "lib" (package-outputs gcc))))
494 (native-search-paths search-paths)
495 (arguments
496 (substitute-keyword-arguments `(#:modules ((guix build gnu-build-system)
497 (guix build utils)
498 (ice-9 regex)
499 (srfi srfi-1)
500 (srfi srfi-26))
501 ,@(package-arguments gcc))
502 ((#:configure-flags flags)
503 `(cons (string-append "--enable-languages="
504 ,(string-join languages ","))
505 (remove (cut string-match "--enable-languages.*" <>)
506 ,flags)))
507 ((#:phases phases)
508 `(modify-phases ,phases
509 (add-after 'install 'remove-broken-or-conflicting-files
510 (lambda* (#:key outputs #:allow-other-keys)
511 (for-each delete-file
512 (find-files (string-append (assoc-ref outputs "out") "/bin")
513 ".*(c\\+\\+|cpp|g\\+\\+|gcov|gcc.*)"))
514 #t))))))))
515
516 (define %generic-search-paths
517 ;; This is the language-neutral search path for GCC. Entries in $CPATH are
518 ;; not considered "system headers", which means GCC can raise warnings for
519 ;; issues in those headers. 'CPATH' is the only one that works for
520 ;; front-ends not in the C family.
521 (list (search-path-specification
522 (variable "CPATH")
523 (files '("include")))
524 (search-path-specification
525 (variable "LIBRARY_PATH")
526 (files '("lib" "lib64")))))
527
528 (define-public gfortran-4.8
529 (custom-gcc gcc-4.8 "gfortran" '("fortran")
530 %generic-search-paths))
531
532 (define-public gfortran-4.9
533 (custom-gcc gcc-4.9 "gfortran" '("fortran")
534 %generic-search-paths))
535
536 (define-public gfortran-5
537 (custom-gcc gcc-5 "gfortran" '("fortran")
538 %generic-search-paths))
539
540 (define-public gfortran-6
541 (custom-gcc gcc-6 "gfortran" '("fortran")
542 %generic-search-paths))
543
544 (define-public gfortran-7
545 (custom-gcc gcc-7 "gfortran" '("fortran")
546 %generic-search-paths))
547
548 (define-public gfortran
549 ;; Note: Update this when GCC changes! We cannot use
550 ;; (custom-gcc gcc "fortran" …) because that would lead to a package object
551 ;; that is not 'eq?' with GFORTRAN-5, and thus 'fold-packages' would
552 ;; report two gfortran@5 that are in fact identical.
553 gfortran-5)
554
555 (define-public gccgo-4.9
556 (custom-gcc gcc-4.9 "gccgo" '("go")
557 %generic-search-paths
558 ;; Suppress the separate "lib" output, because otherwise the
559 ;; "lib" and "out" outputs would refer to each other, creating
560 ;; a cyclic dependency. <http://debbugs.gnu.org/18101>
561 #:separate-lib-output? #f))
562
563 (define-public gcc-objc-4.8
564 (custom-gcc gcc-4.8 "gcc-objc" '("objc")
565 (list (search-path-specification
566 (variable "OBJC_INCLUDE_PATH")
567 (files '("include")))
568 (search-path-specification
569 (variable "LIBRARY_PATH")
570 (files '("lib" "lib64"))))))
571
572 (define-public gcc-objc-4.9
573 (custom-gcc gcc-4.9 "gcc-objc" '("objc")
574 (list (search-path-specification
575 (variable "OBJC_INCLUDE_PATH")
576 (files '("include")))
577 (search-path-specification
578 (variable "LIBRARY_PATH")
579 (files '("lib" "lib64"))))))
580
581 (define-public gcc-objc gcc-objc-4.9)
582
583 (define-public gcc-objc++-4.8
584 (custom-gcc gcc-4.8 "gcc-objc++" '("obj-c++")
585 (list (search-path-specification
586 (variable "OBJCPLUS_INCLUDE_PATH")
587 (files '("include")))
588 (search-path-specification
589 (variable "LIBRARY_PATH")
590 (files '("lib" "lib64"))))))
591
592 (define-public gcc-objc++-4.9
593 (custom-gcc gcc-4.9 "gcc-objc++" '("obj-c++")
594 (list (search-path-specification
595 (variable "OBJCPLUS_INCLUDE_PATH")
596 (files '("include")))
597 (search-path-specification
598 (variable "LIBRARY_PATH")
599 (files '("lib" "lib64"))))))
600
601 (define-public gcc-objc++ gcc-objc++-4.9)
602
603 (define (make-libstdc++-doc gcc)
604 "Return a package with the libstdc++ documentation for GCC."
605 (package
606 (inherit gcc)
607 (name "libstdc++-doc")
608 (version (package-version gcc))
609 (synopsis "GNU libstdc++ documentation")
610 (outputs '("out"))
611 (native-inputs `(("doxygen" ,doxygen)
612 ("texinfo" ,texinfo)
613 ("libxml2" ,libxml2)
614 ("libxslt" ,libxslt)
615 ("docbook-xml" ,docbook-xml)
616 ("docbook-xsl" ,docbook-xsl)
617 ("graphviz" ,graphviz))) ;for 'dot', invoked by 'doxygen'
618 (inputs '())
619 (propagated-inputs '())
620 (arguments
621 '(#:out-of-source? #t
622 #:tests? #f ;it's just documentation
623 #:phases (modify-phases %standard-phases
624 (add-before 'configure 'chdir
625 (lambda _
626 (chdir "libstdc++-v3")))
627 (add-before 'configure 'set-xsl-directory
628 (lambda* (#:key inputs #:allow-other-keys)
629 (let ((docbook (assoc-ref inputs "docbook-xsl")))
630 (substitute* (find-files "doc"
631 "^Makefile\\.in$")
632 (("@XSL_STYLE_DIR@")
633 (string-append
634 docbook "/xml/xsl/"
635 (strip-store-file-name docbook)))))))
636 (replace 'build
637 (lambda _
638 ;; XXX: There's also a 'doc-info' target, but it
639 ;; relies on docbook2X, which itself relies on
640 ;; DocBook 4.1.2, which is not really usable
641 ;; (lacks a catalog.xml.)
642 (zero? (system* "make"
643 "doc-html"
644 "doc-man"))))
645 (replace 'install
646 (lambda* (#:key outputs #:allow-other-keys)
647 (let ((out (assoc-ref outputs "out")))
648 (zero? (system* "make"
649 "doc-install-html"
650 "doc-install-man"))))))))))
651
652 (define-public libstdc++-doc-4.9
653 (make-libstdc++-doc gcc-4.9))
654
655 (define-public libstdc++-doc-5
656 (make-libstdc++-doc gcc-5))
657
658 (define-public isl
659 (package
660 (name "isl")
661 (version "0.11.1")
662 (source (origin
663 (method url-fetch)
664 (uri (list (string-append
665 "http://isl.gforge.inria.fr/isl-"
666 version
667 ".tar.bz2")
668 (string-append %gcc-infrastructure
669 name "-" version ".tar.gz")))
670 (sha256
671 (base32
672 "13d9cqa5rzhbjq0xf0b2dyxag7pqa72xj9dhsa03m8ccr1a4npq9"))
673 (patches (search-patches "isl-0.11.1-aarch64-support.patch"))))
674 (build-system gnu-build-system)
675 (inputs `(("gmp" ,gmp)))
676 (home-page "http://isl.gforge.inria.fr/")
677 (synopsis
678 "Manipulating sets and relations of integer points \
679 bounded by linear constraints")
680 (description
681 "isl is a library for manipulating sets and relations of integer points
682 bounded by linear constraints. Supported operations on sets include
683 intersection, union, set difference, emptiness check, convex hull, (integer)
684 affine hull, integer projection, computing the lexicographic minimum using
685 parametric integer programming, coalescing and parametric vertex
686 enumeration. It also includes an ILP solver based on generalized basis
687 reduction, transitive closures on maps (which may encode infinite graphs),
688 dependence analysis and bounds on piecewise step-polynomials.")
689 (license lgpl2.1+)))
690
691 (define-public cloog
692 (package
693 (name "cloog")
694 (version "0.18.0")
695 (source
696 (origin
697 (method url-fetch)
698 (uri (list (string-append
699 "http://www.bastoul.net/cloog/pages/download/count.php3?url=cloog-"
700 version
701 ".tar.gz")
702 (string-append %gcc-infrastructure
703 name "-" version ".tar.gz")))
704 (sha256
705 (base32
706 "0a12rwfwp22zd0nlld0xyql11cj390rrq1prw35yjsw8wzfshjhw"))
707 (file-name (string-append name "-" version ".tar.gz"))))
708 (build-system gnu-build-system)
709 (inputs `(("gmp" ,gmp)
710 ("isl" ,isl)))
711 (arguments '(#:configure-flags '("--with-isl=system")))
712 (home-page "http://www.cloog.org/")
713 (synopsis "Library to generate code for scanning Z-polyhedra")
714 (description
715 "CLooG is a free software library to generate code for scanning
716 Z-polyhedra. That is, it finds a code (e.g., in C, FORTRAN...) that
717 reaches each integral point of one or more parameterized polyhedra.
718 CLooG has been originally written to solve the code generation problem
719 for optimizing compilers based on the polytope model. Nevertheless it
720 is used now in various area e.g., to build control automata for
721 high-level synthesis or to find the best polynomial approximation of a
722 function. CLooG may help in any situation where scanning polyhedra
723 matters. While the user has full control on generated code quality,
724 CLooG is designed to avoid control overhead and to produce a very
725 effective code.")
726 (license gpl2+)))
727
728 (define-public gnu-c-manual
729 (package
730 (name "gnu-c-manual")
731 (version "0.2.5")
732 (source (origin
733 (method url-fetch)
734 (uri (string-append "mirror://gnu/gnu-c-manual/gnu-c-manual-"
735 version ".tar.gz"))
736 (sha256
737 (base32
738 "1sfsj9256w18qzylgag2h5h377aq8in8929svblfnj9svfriqcys"))))
739 (build-system gnu-build-system)
740 (native-inputs `(("texinfo" ,texinfo)))
741 (arguments
742 '(#:phases (modify-phases %standard-phases
743 (delete 'configure)
744 (delete 'check)
745 (replace 'build
746 (lambda _
747 (zero? (system* "make"
748 "gnu-c-manual.info"
749 "gnu-c-manual.html"))))
750 (replace 'install
751 (lambda* (#:key outputs #:allow-other-keys)
752 (let* ((out (assoc-ref outputs "out"))
753 (info (string-append out "/share/info"))
754 (html (string-append
755 out "/share/doc/gnu-c-manual")))
756 (mkdir-p info)
757 (mkdir-p html)
758
759 (for-each (lambda (file)
760 (copy-file file
761 (string-append info "/"
762 file)))
763 (find-files "." "\\.info(-[0-9])?$"))
764 (for-each (lambda (file)
765 (copy-file file
766 (string-append html "/"
767 file)))
768 (find-files "." "\\.html$"))
769 #t))))))
770 (synopsis "Reference manual for the C programming language")
771 (description
772 "This is a reference manual for the C programming language, as
773 implemented by the GNU C Compiler (gcc). As a reference, it is not intended
774 to be a tutorial of the language. Rather, it outlines all of the constructs
775 of the language. Library functions are not included.")
776 (home-page "https://www.gnu.org/software/gnu-c-manual/")
777 (license fdl1.3+)))