gnu: Add CPAN-Meta.
[jackhill/guix/guix.git] / gnu / packages / perl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages perl)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system perl))
29
30 ;;;
31 ;;; Please: Try to add new module packages in alphabetic order.
32 ;;;
33
34 \f
35 (define-public perl
36 ;; Yeah, Perl... It is required early in the bootstrap process by Linux.
37 (package
38 (name "perl")
39 (version "5.16.1")
40 (source (origin
41 (method url-fetch)
42 (uri (string-append "http://www.cpan.org/src/5.0/perl-"
43 version ".tar.gz"))
44 (sha256
45 (base32
46 "15qxzba3a50c9nik5ydgyfp62x7h9vxxn12yd1jgl93hb1wj96km"))
47 (patches (list (search-patch "perl-no-sys-dirs.patch")))))
48 (build-system gnu-build-system)
49 (arguments
50 '(#:tests? #f
51 #:phases
52 (alist-replace
53 'configure
54 (lambda* (#:key inputs outputs #:allow-other-keys)
55 (let ((out (assoc-ref outputs "out"))
56 (libc (assoc-ref inputs "libc")))
57 ;; Use the right path for `pwd'.
58 (substitute* "dist/Cwd/Cwd.pm"
59 (("/bin/pwd")
60 (which "pwd")))
61
62 (zero?
63 (system* "./Configure"
64 (string-append "-Dprefix=" out)
65 (string-append "-Dman1dir=" out "/share/man/man1")
66 (string-append "-Dman3dir=" out "/share/man/man3")
67 "-de" "-Dcc=gcc"
68 "-Uinstallusrbinperl"
69 "-Dinstallstyle=lib/perl5"
70 "-Duseshrplib"
71 (string-append "-Dlocincpth=" libc "/include")
72 (string-append "-Dloclibpth=" libc "/lib")))))
73 %standard-phases)))
74 (native-search-paths (list (search-path-specification
75 (variable "PERL5LIB")
76 (files '("lib/perl5/site_perl")))))
77 (synopsis "Implementation of the Perl programming language")
78 (description
79 "Perl 5 is a highly capable, feature-rich programming language with over
80 24 years of development.")
81 (home-page "http://www.perl.org/")
82 (license gpl1+))) ; or "Artistic"
83
84 (define-public perl-archive-zip
85 (package
86 (name "perl-archive-zip")
87 (version "1.30")
88 (source
89 (origin
90 (method url-fetch)
91 (uri (string-append
92 "mirror://cpan/authors/id/A/AD/ADAMK/Archive-Zip-"
93 version ".tar.gz"))
94 (sha256
95 (base32
96 "0633zah5z9njiqnvy3vh42fjymncmil1jdfb7d18w8xpfzzp5d7q"))))
97 (build-system perl-build-system)
98 (synopsis "Perl API to zip files")
99 (description "The Archive::Zip module allows a Perl program to create,
100 manipulate, read, and write Zip archive files.")
101 (home-page "http://search.cpan.org/~phred/Archive-Zip-1.37/lib/Archive/Zip.pm")
102 (license (package-license perl))))
103
104 (define-public perl-benchmark-timer
105 (package
106 (name "perl-benchmark-timer")
107 (version "0.7102")
108 (source (origin
109 (method url-fetch)
110 (uri (string-append "mirror://cpan/authors/id/D/DC/DCOPPIT/"
111 "Benchmark-Timer-" version ".tar.gz"))
112 (sha256
113 (base32
114 "1gl9ybm9hgia3ld5s11b7bv2p2hmx5rss5hxcfy6rmbzrjcnci01"))))
115 (build-system perl-build-system)
116 ;; The optional input module Statistics::PointEstimation (from
117 ;; Statistics-TTest) lists no license.
118 (synopsis "Benchmarking with statistical confidence")
119 (description
120 "The Benchmark::Timer class allows you to time portions of code
121 conveniently, as well as benchmark code by allowing timings of repeated
122 trials. It is perfect for when you need more precise information about the
123 running time of portions of your code than the Benchmark module will give you,
124 but don't want to go all out and profile your code.")
125 (home-page (string-append "http://search.cpan.org/~dcoppit/"
126 "Benchmark-Timer-" version))
127 (license gpl2)))
128
129 (define-public perl-capture-tiny
130 (package
131 (name "perl-capture-tiny")
132 (version "0.28")
133 (source
134 (origin
135 (method url-fetch)
136 (uri (string-append
137 "mirror://cpan/authors/id/D/DA/DAGOLDEN/Capture-Tiny-"
138 version ".tar.gz"))
139 (sha256
140 (base32
141 "117gmwipql1y5xnw9jil3lhdsrf2wsm9wjdzqj66x971n3fwm573"))))
142 (build-system perl-build-system)
143 (home-page "http://search.cpan.org/dist/Capture-Tiny")
144 (synopsis "Capture STDOUT and STDERR from Perl, XS or external programs")
145 (description
146 "Capture::Tiny provides a simple, portable way to capture almost anything
147 sent to STDOUT or STDERR, regardless of whether it comes from Perl, from XS
148 code or from an external program. Optionally, output can be teed so that it
149 is captured while being passed through to the original file handles.")
150 (license asl2.0)))
151
152 (define-public perl-clone
153 (package
154 (name "perl-clone")
155 (version "0.37")
156 (source (origin
157 (method url-fetch)
158 (uri (string-append "mirror://cpan/authors/id/G/GA/GARU/"
159 "Clone-" version ".tar.gz"))
160 (sha256
161 (base32
162 "17fdhxpzrq2nwim3zkcrz4m9gjixp0i886yz54ysrshxy3k53wnr"))))
163 (build-system perl-build-system)
164 (synopsis "Recursively copy Perl datatypes")
165 (description
166 "This module provides a clone() method which makes recursive copies of
167 nested hash, array, scalar and reference types, including tied variables and
168 objects.")
169 (home-page (string-append "http://search.cpan.org/~garu/"
170 "Clone-" version))
171 (license (package-license perl))))
172
173 (define-public perl-data-optlist
174 (package
175 (name "perl-data-optlist")
176 (version "0.109")
177 (source
178 (origin
179 (method url-fetch)
180 (uri (string-append
181 "mirror://cpan/authors/id/R/RJ/RJBS/Data-OptList-"
182 version ".tar.gz"))
183 (sha256
184 (base32
185 "1j44rm2spprlq3bc80cxni3dzs3gfjiqv1qc9q7820n1qj0wgmqw"))))
186 (build-system perl-build-system)
187 (propagated-inputs
188 `(("perl-sub-install" ,perl-sub-install)
189 ("perl-params-util" ,perl-params-util)))
190 (home-page "http://search.cpan.org/dist/Data-OptList")
191 (synopsis "Parse and validate simple name/value option pairs")
192 (description
193 "Data::OptList provides a simple syntax for name/value option pairs.")
194 (license (package-license perl))))
195
196 (define-public perl-digest-sha1
197 (package
198 (name "perl-digest-sha1")
199 (version "2.13")
200 (source (origin
201 (method url-fetch)
202 (uri (string-append "mirror://cpan/authors/id/G/GA/GAAS/"
203 "Digest-SHA1-" version ".tar.gz"))
204 (sha256
205 (base32
206 "1k23p5pjk42vvzg8xcn4iwdii47i0qm4awdzgbmz08bl331dmhb8"))))
207 (build-system perl-build-system)
208 (synopsis "Perl implementation of the SHA-1 message digest algorithm")
209 (description
210 "This package provides 'Digest::SHA1', an implementation of the NIST
211 SHA-1 message digest algorithm for use by Perl programs.")
212 (home-page (string-append "http://search.cpan.org/~gaas/Digest-SHA1-"
213 version "/SHA1.pm"))
214 (license (package-license perl))))
215
216 (define-public perl-exporter-lite
217 (package
218 (name "perl-exporter-lite")
219 (version "0.06")
220 (source (origin
221 (method url-fetch)
222 (uri (string-append "mirror://cpan/authors/id/N/NE/NEILB/"
223 "Exporter-Lite-" version ".tar.gz"))
224 (sha256
225 (base32
226 "0k4gkvid4fr8yvwj0axdx5111mzfw2iipls3qllxr364fqhmclpj"))))
227 (build-system perl-build-system)
228 (synopsis "Lightweight exporting of functions and variables")
229 (description
230 "Exporter::Lite is an alternative to Exporter, intended to provide a
231 lightweight subset of the most commonly-used functionality. It supports
232 import(), @EXPORT and @EXPORT_OK and not a whole lot else.")
233 (home-page (string-append "http://search.cpan.org/~neilb/"
234 "Exporter-Lite-" version))
235 (license (package-license perl))))
236
237 (define-public perl-file-list
238 (package
239 (name "perl-file-list")
240 (version "0.3.1")
241 (source (origin
242 (method url-fetch)
243 (uri (string-append
244 "mirror://cpan/authors/id/D/DO/DOPACKI/File-List-"
245 version ".tar.gz"))
246 (sha256
247 (base32
248 "00m5ax4aq59hdvav6yc4g63vhx3a57006rglyypagvrzfxjvm8s8"))))
249 (build-system perl-build-system)
250 (arguments
251 `(#:phases
252 (alist-cons-after
253 'unpack 'cd
254 (lambda* _
255 (chdir "List"))
256 %standard-phases)))
257 (license (package-license perl))
258 (synopsis "Perl extension for crawling directory trees and compiling
259 lists of files")
260 (description
261 "The File::List module crawls the directory tree starting at the
262 provided base directory and can return files (and/or directories if desired)
263 matching a regular expression.")
264 (home-page "http://search.cpan.org/~dopacki/File-List/")))
265
266 (define-public perl-file-which
267 (package
268 (name "perl-file-which")
269 (version "1.09")
270 (source (origin
271 (method url-fetch)
272 (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
273 "File-Which-" version ".tar.gz"))
274 (sha256
275 (base32
276 "1hxjyh9yrv32f3g8vrnr8iylzprajsac14vjm75kf1qnj1jyqbxp"))))
277 (build-system perl-build-system)
278 (native-inputs `(("test-script" ,perl-test-script)))
279 (synopsis "Portable implementation of the `which' utility")
280 (description
281 "File::Which was created to be able to get the paths to executable
282 programs on systems under which the `which' program wasn't implemented in the
283 shell.")
284 (home-page (string-append "http://search.cpan.org/~adamk/"
285 "File-Which-" version))
286 (license (package-license perl))))
287
288 (define-public perl-getopt-tabular
289 (package
290 (name "perl-getopt-tabular")
291 (version "0.3")
292 (source (origin
293 (method url-fetch)
294 (uri (string-append "mirror://cpan/authors/id/G/GW/GWARD/"
295 "Getopt-Tabular-" version ".tar.gz"))
296 (sha256
297 (base32
298 "0xskl9lcj07sdfx5dkma5wvhhgf5xlsq0khgh8kk34dm6dv0dpwv"))))
299 (build-system perl-build-system)
300 (synopsis "Table-driven argument parsing for Perl")
301 (description
302 "Getopt::Tabular is a Perl 5 module for table-driven argument parsing,
303 vaguely inspired by John Ousterhout's Tk_ParseArgv.")
304 (home-page (string-append "http://search.cpan.org/~gward/"
305 "Getopt-Tabular-" version))
306 (license (package-license perl))))
307
308 (define-public perl-io-tty
309 (package
310 (name "perl-io-tty")
311 (version "1.11")
312 (source (origin
313 (method url-fetch)
314 (uri (string-append "mirror://cpan/authors/id/T/TO/TODDR/IO-Tty-"
315 version ".tar.gz"))
316 (sha256
317 (base32
318 "0lgd9xcbi4gf4gw1ka6fj94my3w1f3k1zamb4pfln0qxz45zlxx4"))))
319 (build-system perl-build-system)
320 (home-page "http://search.cpan.org/~toddr/IO-Tty/")
321 (synopsis "Perl interface to pseudo ttys")
322 (description
323 "This package provides the 'IO::Pty' and 'IO::Tty' Perl interfaces to
324 pseudo ttys.")
325 (license (package-license perl))))
326
327 (define-public perl-ipc-run3
328 (package
329 (name "perl-ipc-run3")
330 (version "0.048")
331 (source (origin
332 (method url-fetch)
333 (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
334 "IPC-Run3-" version ".tar.gz"))
335 (sha256
336 (base32
337 "0r9m8q78bg7yycpixd7738jm40yz71p2q7inm766kzsw3g6c709x"))))
338 (build-system perl-build-system)
339 (synopsis "Run a subprocess with input/ouput redirection")
340 (description
341 "The IPC::Run3 module allows you to run a subprocess and redirect stdin,
342 stdout, and/or stderr to files and perl data structures. It aims to satisfy
343 99% of the need for using system, qx, and open3 with a simple, extremely
344 Perlish API and none of the bloat and rarely used features of IPC::Run.")
345 (home-page (string-append "http://search.cpan.org/~rjbs/"
346 "IPC-Run3-" version))
347 ;; "You may use this module under the terms of the BSD, Artistic, or GPL
348 ;; licenses, any version."
349 (license (list bsd-3 gpl3+))))
350
351 (define-public perl-params-util
352 (package
353 (name "perl-params-util")
354 (version "1.07")
355 (source
356 (origin
357 (method url-fetch)
358 (uri (string-append
359 "mirror://cpan/authors/id/A/AD/ADAMK/Params-Util-"
360 version ".tar.gz"))
361 (sha256
362 (base32
363 "0v67sx93yhn7xa0nh9mnbf8mixf54czk6wzrjsp6dzzr5hzyrw9h"))))
364 (build-system perl-build-system)
365 (home-page "http://search.cpan.org/dist/Params-Util")
366 (synopsis "Simple, compact and correct param-checking functions")
367 (description
368 "Params::Util provides a basic set of importable functions that makes
369 checking parameters easier.")
370 (license (package-license perl))))
371
372 (define-public perl-probe-perl
373 (package
374 (name "perl-probe-perl")
375 (version "0.03")
376 (source (origin
377 (method url-fetch)
378 (uri (string-append "mirror://cpan/authors/id/K/KW/KWILLIAMS/"
379 "Probe-Perl-" version ".tar.gz"))
380 (sha256
381 (base32
382 "0c9wiaz0mqqknafr4jdr0g2gdzxnn539182z0icqaqvp5qgd5r6r"))))
383 (build-system perl-build-system)
384 (synopsis "Information about the currently running perl")
385 (description
386 "Probe::Perl provides methods for obtaining information about the
387 currently running perl interpreter. It originally began life as code in the
388 Module::Build project, but has been externalized here for general use.")
389 (home-page (string-append "http://search.cpan.org/~kwilliams/"
390 "Probe-Perl-" version))
391 (license (package-license perl))))
392
393 (define-public perl-regexp-common
394 (package
395 (name "perl-regexp-common")
396 (version "2013031301")
397 (source (origin
398 (method url-fetch)
399 (uri (string-append "mirror://cpan/authors/id/A/AB/ABIGAIL/"
400 "Regexp-Common-" version ".tar.gz"))
401 (sha256
402 (base32
403 "112wybsm0vr8yfannx6sdfvgp5vza28gjgr3pgn69ak4sac836kj"))))
404 (build-system perl-build-system)
405 (synopsis "Provide commonly requested regular expressions")
406 (description
407 "This module exports a single hash (`%RE') that stores or generates
408 commonly needed regular expressions. Patterns currently provided include:
409 balanced parentheses and brackets, delimited text (with escapes), integers and
410 floating-point numbers in any base (up to 36), comments in 44 languages,
411 offensive language, lists of any pattern, IPv4 addresses, URIs, and Zip
412 codes.")
413 (home-page (string-append "http://search.cpan.org/~abigail/"
414 "Regexp-Common-" version))
415 ;; Quad-licensed: Perl Artistic, Perl Artistic 2.0, X11, and BSD.
416 (license (list (package-license perl) x11 bsd-3))))
417
418 (define-public perl-sub-exporter
419 (package
420 (name "perl-sub-exporter")
421 (version "0.987")
422 (source
423 (origin
424 (method url-fetch)
425 (uri (string-append
426 "mirror://cpan/authors/id/R/RJ/RJBS/Sub-Exporter-"
427 version ".tar.gz"))
428 (sha256
429 (base32
430 "1ml3n1ck4ln9qjm2mcgkczj1jb5n1fkscz9c4x23v4db0glb4g2l"))))
431 (build-system perl-build-system)
432 (propagated-inputs
433 `(("perl-data-optlist" ,perl-data-optlist)
434 ("perl-params-util" ,perl-params-util)))
435 (home-page "http://search.cpan.org/dist/Sub-Exporter")
436 (synopsis "Sophisticated exporter for custom-built routines")
437 (description
438 "Sub::Exporter provides a sophisticated alternative to Exporter.pm for
439 custom-built routines.")
440 (license (package-license perl))))
441
442 (define-public perl-sub-install
443 (package
444 (name "perl-sub-install")
445 (version "0.928")
446 (source
447 (origin
448 (method url-fetch)
449 (uri (string-append
450 "mirror://cpan/authors/id/R/RJ/RJBS/Sub-Install-"
451 version ".tar.gz"))
452 (sha256
453 (base32
454 "03zgk1yh128gciyx3q77zxzxg9kf8yy2gm46gdxqi24mcykngrb1"))))
455 (build-system perl-build-system)
456 (home-page "http://search.cpan.org/dist/Sub-Install")
457 (synopsis "Install subroutines into packages easily")
458 (description
459 "Sub::Install makes it easy to install subroutines into packages without
460 the unsightly mess of C<no strict> or typeglobs lying about where just anyone
461 can see them.")
462 (license (package-license perl))))
463
464 (define-public perl-sys-cpu
465 (package
466 (name "perl-sys-cpu")
467 (version "0.61")
468 (source (origin
469 (method url-fetch)
470 (uri (string-append "mirror://cpan/authors/id/M/MZ/MZSANFORD/"
471 "Sys-CPU-" version ".tar.gz"))
472 (sha256
473 (base32
474 "1r6976bs86j7zp51m5vh42xlyah951jgdlkimv202413kjvqc2i5"))))
475 (build-system perl-build-system)
476 (synopsis "Perl extension for getting CPU information")
477 (description
478 "In responce to a post on perlmonks.org, a module for counting the number
479 of CPU's on a system. Support has now also been added for type of CPU and
480 clock speed.")
481 (home-page (string-append "http://search.cpan.org/~mzsanford/"
482 "Sys-CPU-" version))
483 (license (package-license perl))))
484
485 (define-public perl-test-deep
486 (package
487 (name "perl-test-deep")
488 (version "0.114")
489 (source (origin
490 (method url-fetch)
491 (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
492 "Test-Deep-" version ".tar.gz"))
493 (sha256
494 (base32
495 "09yr47vw7vj27sdik312x08938higcij8ybyq8k67mlccx8cpqf0"))))
496 (build-system perl-build-system)
497 (inputs `(("perl-test-tester" ,perl-test-tester)
498 ("perl-test-nowarnings" ,perl-test-nowarnings)))
499 (synopsis "Flexible deep comparison for the Test::Builder framework")
500 (description
501 "Test::Deep compares two structures by going through each level, ensuring
502 that the values match, that arrays and hashes have the same elements and that
503 references are blessed into the correct class. It also handles circular data
504 structures without getting caught in an infinite loop.")
505 (home-page (string-append "http://search.cpan.org/~rjbs/"
506 "Test-Deep-" version))
507 (license gpl1+))) ; or "Artistic License"
508
509 (define-public perl-test-nowarnings
510 (package
511 (name "perl-test-nowarnings")
512 (version "1.04")
513 (source (origin
514 (method url-fetch)
515 (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
516 "Test-NoWarnings-" version ".tar.gz"))
517 (sha256
518 (base32
519 "0v385ch0hzz9naqwdw2az3zdqi15gka76pmiwlgsy6diiijmg2k3"))))
520 (build-system perl-build-system)
521 (inputs `(("perl-test-tester" ,perl-test-tester)))
522 (synopsis "Ensure no warnings are produced while testing")
523 (description
524 "This modules causes any warnings during testing to be captured and
525 stored. It automatically adds an extra test that will run when your script
526 ends to check that there were no warnings. If there were any warings, the
527 test will fail and output diagnostics of where, when and what the warning was,
528 including a stack trace of what was going on when it occurred.")
529 (home-page (string-append "http://search.cpan.org/~adamk/"
530 "Test-NoWarnings-" version))
531 (license lgpl2.1)))
532
533 (define-public perl-test-output
534 (package
535 (name "perl-test-output")
536 (version "1.03")
537 (source (origin
538 (method url-fetch)
539 (uri (string-append "mirror://cpan/authors/id/B/BD/BDFOY/"
540 "Test-Output-" version ".tar.gz"))
541 (sha256
542 (base32
543 "12991jnzj4cbw9whhprmqvnzd1ayii84g2mh8vxbjngwqrjsy41i"))))
544 (build-system perl-build-system)
545 (propagated-inputs
546 `(("perl-capture-tiny" ,perl-capture-tiny)
547 ("perl-test-tester" ,perl-test-tester)
548 ("perl-sub-exporter" ,perl-sub-exporter)))
549 (synopsis "Utilities to test STDOUT and STDERR messages")
550 (description
551 "Test::Output provides a simple interface for testing output sent to
552 STDOUT or STDERR. A number of different utilities are included to try and be
553 as flexible as possible to the tester.")
554 (home-page (string-append "http://search.cpan.org/~bdfoy/"
555 "Test-Output-" version))
556 (license (package-license perl))))
557
558 (define-public perl-test-script
559 (package
560 (name "perl-test-script")
561 (version "1.07")
562 (source (origin
563 (method url-fetch)
564 (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
565 "Test-Script-" version ".tar.gz"))
566 (sha256
567 (base32
568 "15pb4zzsnm33msc1syhig2bk05xqc0pckmfyahdwbd177bj5w7p2"))))
569 (build-system perl-build-system)
570 (propagated-inputs
571 `(("probe-perl" ,perl-probe-perl)
572 ("ipc-run3" ,perl-ipc-run3)))
573 (synopsis "Basic cross-platform tests for scripts")
574 (description
575 "The intent of the Test::Script module is to provide a series of basic
576 tests for 80% of the testing you will need to do for scripts in the script (or
577 bin as is also commonly used) paths of your Perl distribution.")
578 (home-page (string-append "http://search.cpan.org/~adamk/"
579 "Test-Script-" version))
580 (license (package-license perl))))
581
582 (define-public perl-test-simple
583 (package
584 (name "perl-test-simple")
585 (version "1.001014")
586 (source (origin
587 (method url-fetch)
588 (uri (string-append "mirror://cpan/authors/id/E/EX/EXODIST/"
589 "Test-Simple-" version ".tar.gz"))
590 (sha256
591 (base32
592 "0szi95shwwdvc4nqykzgx05g2m1001mjhvqqhjg5wypbi771992m"))))
593 (build-system perl-build-system)
594 (synopsis "Basic utilities for writing tests")
595 (description
596 "Test::Simple contains basic utilities for writing tests.")
597 (home-page (string-append "http://search.cpan.org/~exodist/"
598 "Test-Simple-" version))
599 (license (package-license perl))))
600
601 (define-public perl-test-tester
602 (package
603 (name "perl-test-tester")
604 (version "0.109")
605 (source (origin
606 (method url-fetch)
607 (uri (string-append "mirror://cpan/authors/id/F/FD/FDALY/"
608 "Test-Tester-" version ".tar.gz"))
609 (sha256
610 (base32
611 "0m9n28z09kq455r5nydj1bnr85lvmbfpcbjdkjfbpmfb5xgciiyk"))))
612 (build-system perl-build-system)
613 (synopsis "Simplify running Test::Builder tests")
614 (description
615 "Test::Tester allows testing of test modules based on Test::Builder with
616 a minimum of effort.")
617 (home-page (string-append "http://search.cpan.org/~fdaly/"
618 "Test-Tester-" version))
619 ;; "Under the same license as Perl itself"
620 (license (package-license perl))))
621
622 \f
623 ;;; Some packaged modules need versions of core modules that are newer than
624 ;;; those in our perl 5.16.1.
625
626 (define-public perl-cpan-meta
627 (package
628 (name "perl-cpan-meta")
629 (version "2.143240")
630 (source
631 (origin
632 (method url-fetch)
633 (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
634 "CPAN-Meta-" version ".tar.gz"))
635 (sha256
636 (base32
637 "1d80bxphpp5dq7fx5ipxszn7j8q9d85w6fnapdrbym21k1vsmlf6"))))
638 (build-system perl-build-system)
639 (propagated-inputs
640 `(("perl-cpan-meta-requirements" ,perl-cpan-meta-requirements)
641 ("perl-cpan-meta-yaml" ,perl-cpan-meta-yaml)
642 ("perl-parse-cpan-meta" ,perl-parse-cpan-meta)))
643 (home-page "http://search.cpan.org/dist/CPAN-Meta")
644 (synopsis "Distribution metadata for a CPAN dist")
645 (description "Software distributions released to the CPAN include a
646 META.json or, for older distributions, META.yml, which describes the
647 distribution, its contents, and the requirements for building and installing
648 the distribution. The data structure stored in the META.json file is
649 described in CPAN::Meta::Spec. CPAN::Meta provides a simple class to
650 represent this distribution metadata (or distmeta), along with some helpful
651 methods for interrogating that data.")
652 (license (package-license perl))))
653
654 (define-public perl-cpan-meta-requirements
655 (package
656 (name "perl-cpan-meta-requirements")
657 (version "2.131")
658 (source
659 (origin
660 (method url-fetch)
661 (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
662 "CPAN-Meta-Requirements-" version ".tar.gz"))
663 (sha256
664 (base32
665 "12p5s7w3cwcrbpcrxzanvpr0syswhwlqzbaki6m044c45jix2fss"))))
666 (build-system perl-build-system)
667 (home-page "http://search.cpan.org/dist/CPAN-Meta-Requirements")
668 (synopsis "Set of version requirements for a CPAN dist")
669 (description "A CPAN::Meta::Requirements object models a set of version
670 constraints like those specified in the META.yml or META.json files in CPAN
671 distributions, and as defined by CPAN::Meta::Spec. It can be built up by
672 adding more and more constraints, and will reduce them to the simplest
673 representation.")
674 (license (package-license perl))))
675
676 (define-public perl-cpan-meta-yaml
677 (package
678 (name "perl-cpan-meta-yaml")
679 (version "0.012")
680 (source
681 (origin
682 (method url-fetch)
683 (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
684 "CPAN-Meta-YAML-" version ".tar.gz"))
685 (sha256
686 (base32
687 "0a0d62w8d81kkas4j1h48znk0f0vrpibl31gvz9r8hm77dbqqwkw"))))
688 (build-system perl-build-system)
689 (arguments
690 `(#:tests? #f)) ;Tests require Test::More >= 0.99
691 (home-page "http://search.cpan.org/dist/CPAN-Meta-YAML")
692 (synopsis "Read and write a subset of YAML for CPAN Meta files")
693 (description "This module implements a subset of the YAML specification
694 for use in reading and writing CPAN metadata files like META.yml and
695 MYMETA.yml.")
696 (license (package-license perl))))
697
698 (define-public perl-parse-cpan-meta
699 (package
700 (name "perl-parse-cpan-meta")
701 (version "1.4414")
702 (source
703 (origin
704 (method url-fetch)
705 (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
706 "Parse-CPAN-Meta-" version ".tar.gz"))
707 (sha256
708 (base32
709 "06ya2rg599qanqb1fxiyrd489mvmdgzbw4ph23hwjwpv9lahhxnd"))))
710 (build-system perl-build-system)
711 (propagated-inputs
712 `(("perl-cpan-meta-yaml" ,perl-cpan-meta-yaml)))
713 (home-page "http://search.cpan.org/dist/Parse-CPAN-Meta")
714 (synopsis "Parse META.yml and META.json CPAN metadata files")
715 (description "Parse::CPAN::Meta is a parser for META.json and META.yml
716 files, using JSON::PP and/or CPAN::Meta::YAML.")
717 (license (package-license perl))))
718
719 ;;; END: Core module overrides