Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / messaging.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages messaging)
20 #:use-module ((guix licenses)
21 #:select (gpl2+ gpl2 lgpl2.1 bsd-2))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages gnupg)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages glib)
29 #:use-module (gnu packages gnutls)
30 #:use-module (gnu packages python)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages compression)
33 #:use-module (gnu packages check))
34
35 (define-public libotr
36 (package
37 (name "libotr")
38 (version "4.0.0")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append "https://otr.cypherpunks.ca/libotr-"
42 version ".tar.gz"))
43 (sha256
44 (base32 "1d4k0b7v4d3scwm858cmqr9c6xgd6ppla1vk4x2yg64q82a1k49z"))))
45 (build-system gnu-build-system)
46 (propagated-inputs
47 `(("libgcrypt" ,libgcrypt))) ; libotr headers include gcrypt.h
48 (inputs `(("libgpg-error" ,libgpg-error)))
49 (arguments
50 `(#:configure-flags '("--with-pic")))
51 (synopsis "Off-the-Record (OTR) Messaging Library and Toolkit")
52 (description
53 "OTR allows you to have private conversations over instant messaging by
54 providing:
55 * Encryption: No one else can read your instant messages.
56 * Authentication: You are assured the correspondent is who you think it is.
57 * Deniability: The messages you send do not have digital signatures that are
58 checkable by a third party. Anyone can forge messages after a conversation
59 to make them look like they came from you. However, during a conversation,
60 your correspondent is assured the messages he sees are authentic and
61 unmodified.
62 * Perfect forward secrecy: If you lose control of your private keys, no
63 previous conversation is compromised.")
64 (home-page "https://otr.cypherpunks.ca/")
65 (license (list lgpl2.1 gpl2))))
66
67 (define-public libotr-3
68 (package (inherit libotr)
69 (version "3.2.1")
70 (source (origin
71 (method url-fetch)
72 (uri (string-append "https://otr.cypherpunks.ca/libotr-"
73 version ".tar.gz"))
74 (sha256
75 (base32 "1x6dd4rh499hdraiqfhz81igrj0a5rs0gjhc8l4sljwqhjjyla6l"))))))
76
77 (define-public bitlbee
78 (package
79 (name "bitlbee")
80 (version "3.2.1")
81 (source (origin
82 (method url-fetch)
83 (uri (string-append "http://get.bitlbee.org/src/bitlbee-"
84 version ".tar.gz"))
85 (sha256
86 (base32 "0n8g5452i5qap43zxb83gxp01d48psf6rr3k1q7z6a3dgpfi3x00"))
87 (patches (list (search-patch "bitlbee-memset-fix.patch")
88 (search-patch "bitlbee-fix-tests.patch")))))
89 (build-system gnu-build-system)
90 (native-inputs `(("pkg-config" ,pkg-config)
91 ("check" ,check)))
92 (inputs `(("glib" ,glib)
93 ("libotr" ,libotr-3)
94 ("gnutls" ,gnutls)
95 ("zlib" ,zlib) ; Needed to satisfy "pkg-config --exists gnutls"
96 ("python" ,python-2)
97 ("perl" ,perl)))
98 (arguments
99 `(#:phases (alist-cons-after
100 'install 'install-etc
101 (lambda* (#:key (make-flags '()) #:allow-other-keys)
102 (zero? (apply system* "make" "install-etc" make-flags)))
103 (alist-replace
104 'configure
105 ;; bitlbee's configure script does not tolerate many of the
106 ;; variable settings that Guix would pass to it.
107 (lambda* (#:key outputs #:allow-other-keys)
108 (zero? (system* "./configure"
109 (string-append "--prefix="
110 (assoc-ref outputs "out"))
111 "--otr=1")))
112 %standard-phases))))
113 (synopsis "IRC to instant messaging gateway")
114 (description "BitlBee brings IM (instant messaging) to IRC clients, for
115 people who have an IRC client running all the time and don't want to run an
116 additional IM client. BitlBee currently supports XMPP/Jabber (including
117 Google Talk), MSN Messenger, Yahoo! Messenger, AIM and ICQ, and the Twitter
118 microblogging network (plus all other Twitter API compatible services like
119 identi.ca and status.net).")
120 (home-page "http://www.bitlbee.org/")
121 (license (list gpl2+ bsd-2))))
122
123 ;;; messaging.scm ends here