gnu: python-pysam: Delete bundled htslib.
[jackhill/guix/guix.git] / gnu / packages / xfce.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
5 ;;; Copyright © 2016 Florian Paul Schmidt <mista.tapas@gmx.net>
6 ;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages xfce)
24 #:use-module ((guix licenses) #:hide (freetype))
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix utils)
28 #:use-module (guix build-system gnu)
29 #:use-module (guix build-system trivial)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages calendar)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages glib)
34 #:use-module (gnu packages gtk)
35 #:use-module (gnu packages xorg)
36 #:use-module (gnu packages xdisorg)
37 #:use-module (gnu packages web)
38 #:use-module (gnu packages fontutils)
39 #:use-module (gnu packages image)
40 #:use-module (gnu packages gnome)
41 #:use-module (gnu packages pdf)
42 #:use-module (gnu packages polkit)
43 #:use-module (gnu packages gstreamer)
44 #:use-module (gnu packages linux)
45 #:use-module (gnu packages photo)
46 #:use-module (gnu packages pcre)
47 #:use-module (gnu packages popt)
48 #:use-module (gnu packages pulseaudio))
49
50 (define-public gtk-xfce-engine
51 (package
52 (name "gtk-xfce-engine")
53 (version "2.10.1")
54 (source (origin
55 (method url-fetch)
56 (uri (string-append "http://archive.xfce.org/src/xfce/"
57 name "/" (version-major+minor version) "/"
58 name "-" version ".tar.bz2"))
59 (sha256
60 (base32
61 "0g86ywkx0ghzhhn96k88p67bbzlm1aqckly85izp07w80l1934ja"))))
62 (build-system gnu-build-system)
63 (native-inputs
64 `(("pkg-config" ,pkg-config)
65 ("intltool" ,intltool)))
66 (inputs `(("gtk+" ,gtk+-2)))
67 (home-page "http://www.xfce.org/")
68 (synopsis "GTK+ theme engine for Xfce")
69 (description
70 "Default GTK+ engine and themes for Xfce Desktop Environment.")
71 (license gpl2+)))
72
73 (define-public libxfce4util
74 (package
75 (name "libxfce4util")
76 (version "4.12.1")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append "http://archive.xfce.org/xfce/"
80 (version-major+minor version)
81 "/src/" name "-" version ".tar.bz2"))
82 (sha256
83 (base32
84 "07c8r3xwx5is298zk77m3r784gmr5y4mh8bbca5zdjqk5vxdwsw7"))))
85 (build-system gnu-build-system)
86 (native-inputs
87 `(("pkg-config" ,pkg-config)
88 ("intltool" ,intltool)))
89 (propagated-inputs `(("glib" ,glib))) ; required by libxfce4util-1.0.pc
90 (home-page "http://www.xfce.org/")
91 (synopsis "Basic utility library for Xfce")
92 (description
93 "A general-purpose utility library with core application support for the
94 Xfce Desktop Environment.")
95 (license lgpl2.0+)))
96
97 (define-public xfconf
98 (package
99 (name "xfconf")
100 (version "4.12.0")
101 (source (origin
102 (method url-fetch)
103 (uri (string-append "http://archive.xfce.org/xfce/"
104 (version-major+minor version)
105 "/src/" name "-" version ".tar.bz2"))
106 (sha256
107 (base32
108 "0mmi0g30aln3x98y5p507g17pipq0dj0bwypshan8cq5hkmfl44r"))))
109 (build-system gnu-build-system)
110 (arguments
111 '(#:phases
112 ;; Run check after install phase to test dbus activation.
113 (alist-cons-after
114 'install 'check
115 (lambda _
116 (setenv "HOME" (getenv "TMPDIR")) ; xfconfd requires a writable HOME
117 ;; Run test-suite under a dbus session.
118 (setenv "XDG_DATA_DIRS" ; for finding org.xfce.Xfconf.service
119 (string-append %output "/share"))
120 ;; For the missing '/etc/machine-id'.
121 (setenv "DBUS_FATAL_WARNINGS" "0");
122 (zero? (system* "dbus-launch" "make" "check")))
123 (alist-delete 'check %standard-phases))))
124 (native-inputs
125 `(("pkg-config" ,pkg-config)
126 ("intltool" ,intltool)))
127 (propagated-inputs
128 ;; libxfconf-0.pc refers to all these.
129 `(("glib" ,glib)
130 ("dbus" ,dbus)
131 ("dbus-glib" ,dbus-glib)))
132 (inputs
133 `(("libxfce4util" ,libxfce4util)))
134 (home-page "http://www.xfce.org/")
135 (synopsis "Configuration storage and query system for Xfce")
136 (description
137 "Settings daemon for Xfce, implemented as a D-Bus-based configuration
138 storage system.")
139 (license lgpl2.0+)))
140
141 (define-public libxfce4ui
142 (package
143 (name "libxfce4ui")
144 (version "4.12.0")
145 (source (origin
146 (method url-fetch)
147 (uri (string-append "http://archive.xfce.org/xfce/"
148 (version-major+minor version)
149 "/src/" name "-" version ".tar.bz2"))
150 (sha256
151 (base32
152 "11rrhqxnfwx5jls3nlg9s2x8saag9f2zqk9cdm6hr3bs6cr9a781"))))
153 (build-system gnu-build-system)
154 (native-inputs
155 `(("pkg-config" ,pkg-config)
156 ("intltool" ,intltool)))
157 (propagated-inputs
158 `(("gtk+-2" ,gtk+-2) ; required by libxfce4ui-1.pc
159 ("gtk+-3" ,gtk+) ; required by libxfce4ui-2.pc
160 ;; libxfce4kbd-private-2.pc refers to all these.
161 ("libxfce4util" ,libxfce4util)
162 ("xfconf" ,xfconf)))
163 (inputs `(("libsm" ,libsm)
164 ("libice" ,libice)
165 ("startup-notification" ,startup-notification)))
166 (home-page "http://www.xfce.org/")
167 (synopsis "Widgets library for Xfce")
168 (description
169 "Libxfce4ui is the replacement of the old libxfcegui4 library. It is used
170 to share commonly used Xfce widgets among the Xfce applications.")
171 (license lgpl2.0+)))
172
173 (define-public exo
174 (package
175 (name "exo")
176 (version "0.10.3")
177 (source (origin
178 (method url-fetch)
179 (uri (string-append "http://archive.xfce.org/xfce/4.12/src/"
180 name "-" version ".tar.bz2"))
181 (sha256
182 (base32
183 "1g9651ra395v2fmzb943l68b9pg0rfxc19x97a62crchxwa4nw4m"))))
184 (build-system gnu-build-system)
185 (native-inputs
186 `(("pkg-config" ,pkg-config)
187 ("intltool" ,intltool)))
188 (propagated-inputs
189 ;; exo-1.pc refers to all these.
190 `(("gtk+" ,gtk+-2)
191 ("libxfce4util" ,libxfce4util)))
192 (inputs
193 `(("libxfce4ui" ,libxfce4ui)
194 ("perl-uri" ,perl-uri)))
195 (home-page "http://www.xfce.org/")
196 (synopsis "Extension library for Xfce")
197 (description
198 "An extension library to Xfce. While Xfce comes with quite a few libraries
199 that are targeted at desktop development, libexo is targeted at application
200 development.")
201 ;; Libraries are under LGPLv2+, and programs under GPLv2+.
202 (license (list gpl2+ lgpl2.1+))))
203
204 (define-public garcon
205 (package
206 (name "garcon")
207 (version "0.4.0")
208 (source (origin
209 (method url-fetch)
210 (uri (string-append "http://archive.xfce.org/xfce/4.12/src/"
211 name "-" version ".tar.bz2"))
212 (sha256
213 (base32
214 "0wm9pjbwq53s3n3nwvsyf0q8lbmhiy2ln3bn5ncihr9vf5cwhzbq"))))
215 (build-system gnu-build-system)
216 (native-inputs
217 `(("pkg-config" ,pkg-config)
218 ("intltool" ,intltool)
219 ("glib:bin" ,glib "bin")))
220 (propagated-inputs
221 `(("libxfce4ui" ,libxfce4ui))) ; required by garcon-gtk2-1.pc
222 (home-page "http://www.xfce.org/")
223 (synopsis "Implementation of the freedesktop.org menu specification")
224 (description
225 "Garcon is a freedesktop.org compliant menu implementation based on
226 GLib and GIO. It was started as a complete rewrite of the former Xfce menu
227 library called libxfce4menu, which, in contrast to garcon, was lacking menu
228 merging features essential for loading menus modified with menu editors.")
229 (license lgpl2.0+)))
230
231 (define-public tumbler
232 (package
233 (name "tumbler")
234 (version "0.1.31")
235 (source (origin
236 (method url-fetch)
237 (uri (string-append "http://archive.xfce.org/src/xfce/tumbler/0.1/"
238 name "-" version ".tar.bz2"))
239 (sha256
240 (base32
241 "0wvip28gm2w061hn84zp2q4dv947ihylrppahn4cjspzff935zfh"))))
242 (build-system gnu-build-system)
243 (native-inputs
244 `(("pkg-config" ,pkg-config)
245 ("intltool" ,intltool)
246 ("glib:bin" ,glib "bin") ; need glib-genmarshal
247 ("dbus-glib" ,dbus-glib))) ; need dbus-binding-tool
248 (propagated-inputs
249 `(("glib" ,glib))) ; required by tumbler-1.pc
250 (inputs
251 `(("dbus" ,dbus)
252 ("gdk-pixbuf" ,gdk-pixbuf)
253 ("freetype" ,freetype)
254 ("libjpeg" ,libjpeg)
255 ("libgsf" ,libgsf)
256 ("poppler" ,poppler)
257 ("gstreamer" ,gstreamer)))
258 (home-page "http://www.xfce.org/")
259 (synopsis "D-Bus service for applications to request thumbnails")
260 (description
261 "Tumbler is a D-Bus service for applications to request thumbnails for
262 various URI schemes and MIME types. It is an implementation of the thumbnail
263 management D-Bus specification.")
264 (license gpl2+)))
265
266 (define-public xfce4-panel
267 (package
268 (name "xfce4-panel")
269 (version "4.12.0")
270 (source (origin
271 (method url-fetch)
272 (uri (string-append "http://archive.xfce.org/xfce/"
273 (version-major+minor version)
274 "/src/" name "-" version ".tar.bz2"))
275 (sha256
276 (base32
277 "1c4p3ckghvsad1sj5v8wmar5mh9cbhail9mmhad2f9pwwb10z4ih"))
278 (patches (search-patches "xfce4-panel-plugins.patch"))))
279 (build-system gnu-build-system)
280 (arguments
281 '(#:configure-flags '("--enable-gtk3")))
282 (native-inputs
283 `(("pkg-config" ,pkg-config)
284 ("intltool" ,intltool)))
285 (propagated-inputs
286 `(("libxfce4util" ,libxfce4util))) ; required by libxfce4panel-1.0.pc
287 (inputs
288 `(("exo" ,exo)
289 ("garcon" ,garcon)
290 ("libwnck" ,libwnck-2)
291 ("libxfce4ui" ,libxfce4ui)))
292 (native-search-paths
293 (list (search-path-specification
294 (variable "X_XFCE4_LIB_DIRS")
295 (files '("lib/xfce4")))))
296 (home-page "http://www.xfce.org/")
297 (synopsis "Xfce desktop panel")
298 (description
299 "Desktop panel for Xfce, which contains program launchers, window buttons,
300 applications menu, workspace switcher and more.")
301 ;; Libraries are under LGPLv2.1+, and programs under GPLv2+.
302 (license (list gpl2+ lgpl2.1+))))
303
304 (define-public xfce4-battery-plugin
305 (package
306 (name "xfce4-battery-plugin")
307 (version "1.0.5")
308 (source (origin
309 (method url-fetch)
310 (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
311 name "/" (version-major+minor version) "/"
312 name "-" version ".tar.bz2"))
313 (sha256
314 (base32
315 "04gbplcj8z4vg5xbks8cc2jjf62mmf9sdymg90scjwmb82pv2ngn"))))
316 (build-system gnu-build-system)
317 (native-inputs `(("pkg-config" ,pkg-config)
318 ("intltool" ,intltool)))
319 (inputs `(("glib" ,glib)
320 ("gtk+" ,gtk+-2)
321 ("libxfce4util" ,libxfce4util)
322 ("libxfce4ui" ,libxfce4ui)
323 ("xfce4-panel" ,xfce4-panel)))
324 (home-page
325 "http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin")
326 (synopsis "Battery monitor panel plugin for Xfce4")
327 (description
328 "A battery monitor panel plugin for Xfce4, compatible with APM and ACPI.")
329 ;; The main plugin code is covered by gpl2+, but the files containing code
330 ;; to read the battery state via ACPI or APM are covered by lgpl2.0+.
331 (license (list gpl2+ lgpl2.0+))))
332
333 (define-public xfce4-clipman-plugin
334 (package
335 (name "xfce4-clipman-plugin")
336 (version "1.2.6")
337 (source (origin
338 (method url-fetch)
339 (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
340 name "/" (version-major+minor version) "/"
341 name "-" version ".tar.bz2"))
342 (sha256
343 (base32
344 "19a8gwcqc0r5qqi8w28dc8arqip34m8yxdb87lgps9g5qfcky113"))))
345 (build-system gnu-build-system)
346 (native-inputs
347 `(("intltool" ,intltool)
348 ("pkg-config" ,pkg-config)))
349 (inputs
350 `(("exo" ,exo)
351 ("libxfce4ui" ,libxfce4ui)
352 ("libxtst" ,libxtst)
353 ("xfce4-panel" ,xfce4-panel)))
354 (home-page
355 "http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin")
356 (synopsis "Clipboard manager for Xfce")
357 (description
358 "Clipman is a clipboard manager for Xfce. It keeps the clipboard contents
359 around while it is usually lost when you close an application. It is able to
360 handle text and images, and has a feature to execute actions on specific text by
361 matching them against regular expressions.")
362 (license (list gpl2+))))
363
364 (define-public xfce4-pulseaudio-plugin
365 (package
366 (name "xfce4-pulseaudio-plugin")
367 (version "0.2.3")
368 (source (origin
369 (method url-fetch)
370 (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
371 name "/" (version-major+minor version) "/"
372 name "-" version ".tar.bz2"))
373 (sha256
374 (base32
375 "0crvb2gyxbnlf46712arg3m2vqx81dixqhqdwss0bngpijy3ca78"))))
376 (build-system gnu-build-system)
377 (native-inputs
378 `(("intltool" ,intltool)
379 ("pkg-config" ,pkg-config)))
380 (inputs
381 `(("exo" ,exo)
382 ("libnotify" ,libnotify)
383 ("libxfce4ui" ,libxfce4ui)
384 ("pulseaudio" ,pulseaudio)
385 ("xfce4-panel" ,xfce4-panel)))
386 (home-page "http://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/")
387 (synopsis "PulseAudio panel plugin for Xfce")
388 (description
389 "Xfce PulseAudio plugin is a plugin for the Xfce panel which provides a
390 convenient way to adjust the audio volume of the PulseAudio sound system and
391 to an auto mixer tool like pavucontrol. It can optionally handle multimedia
392 keys for controlling the audio volume.")
393 (license gpl2+)))
394
395 (define-public xfce4-xkb-plugin
396 (package
397 (name "xfce4-xkb-plugin")
398 (version "0.7.1")
399 (source (origin
400 (method url-fetch)
401 (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
402 name "/" (version-major+minor version) "/"
403 name "-" version ".tar.bz2"))
404 (sha256
405 (base32
406 "10g65j5ia389ahhn3b9hr52ghpp0817fk0m60rfrv4wrzqrjxzk1"))))
407 (build-system gnu-build-system)
408 (native-inputs
409 `(("intltool" ,intltool)
410 ("pkg-config" ,pkg-config)))
411 (inputs
412 `(("garcon" ,garcon)
413 ("librsvg" ,librsvg)
414 ("libwnck" ,libwnck-2)
415 ("libx11" ,libx11)
416 ("libxfce4ui" ,libxfce4ui)
417 ("libxklavier" ,libxklavier)
418 ("xfce4-panel" ,xfce4-panel)))
419 (home-page "http://git.xfce.org/panel-plugins/xfce4-xkb-plugin/")
420 (synopsis "XKB layout switching panel plug-in for Xfce")
421 (description
422 "Xfce XKB plugin makes it possible to set up and use multiple
423 keyboard layouts.
424
425 One can choose the keyboard model, what key combination to
426 use to switch between the layouts, the actual keyboard layouts,
427 the way in which the current layout is being displayed (country
428 flag image or text) and the layout policy, which is whether to
429 store the layout globally (for all windows), per application or
430 per window.")
431 (license bsd-2)))
432
433 (define-public xfce4-appfinder
434 (package
435 (name "xfce4-appfinder")
436 (version "4.12.0")
437 (source (origin
438 (method url-fetch)
439 (uri (string-append "http://archive.xfce.org/xfce/"
440 (version-major+minor version)
441 "/src/" name "-" version ".tar.bz2"))
442 (sha256
443 (base32
444 "0ry5hin8xhgnkmm9vs7jq8blk1cnbyr0s18nm1j6nsm7360abm1a"))))
445 (build-system gnu-build-system)
446 (native-inputs
447 `(("pkg-config" ,pkg-config)
448 ("intltool" ,intltool)))
449 (inputs
450 `(("garcon" ,garcon)
451 ("libxfce4ui" ,libxfce4ui)))
452 (home-page "http://www.xfce.org/")
453 (synopsis "Xfce application finder")
454 (description
455 "Application finder for Xfce, it will show the applications installed on
456 your system in categories, so you can quickly find and launch them.")
457 (license gpl2+)))
458
459 (define-public xfce4-session
460 (package
461 (name "xfce4-session")
462 (version "4.12.0")
463 (source (origin
464 (method url-fetch)
465 (uri (string-append "http://archive.xfce.org/xfce/"
466 (version-major+minor version)
467 "/src/" name "-" version ".tar.bz2"))
468 (sha256
469 (base32
470 "01kvbd09c06j20n155hracsgrq06rlmfgdywffjsvlwpn19m9j38"))
471 (patches
472 ;; See: https://bugzilla.xfce.org/show_bug.cgi?id=12282
473 (search-patches "xfce4-session-fix-xflock4.patch"))
474 (modules '((guix build utils)))
475 (snippet
476 '(begin
477 (substitute* "xfsm-shutdown-helper/main.c"
478 (("/sbin/shutdown -h now") "halt")
479 (("/sbin/shutdown -r now") "restart")
480 (("/usr/sbin/pm-suspend") "pm-suspend")
481 (("/usr/sbin/pm-hibernate") "pm-hibernate"))
482 #t))))
483 (build-system gnu-build-system)
484 (arguments
485 '(#:configure-flags
486 (list (string-append "--with-xsession-prefix=" %output))))
487 (native-inputs
488 `(("pkg-config" ,pkg-config)
489 ("intltool" ,intltool)))
490 (inputs
491 `(("iceauth" ,iceauth)
492 ("upower" ,upower)
493 ("polkit" ,polkit)
494 ("libsm" ,libsm)
495 ("libwnck" ,libwnck-2)
496 ("libxfce4ui" ,libxfce4ui)))
497 (home-page "http://www.xfce.org/")
498 (synopsis "Xfce session manager")
499 (description
500 "Session manager for Xfce, it will restore your session on startup and
501 allows you to shutdown the computer from Xfce.")
502 (license gpl2+)))
503
504 (define-public xfce4-settings
505 (package
506 (name "xfce4-settings")
507 (version "4.12.0")
508 (source (origin
509 (method url-fetch)
510 (uri (string-append "http://archive.xfce.org/xfce/"
511 (version-major+minor version)
512 "/src/" name "-" version ".tar.bz2"))
513 (sha256
514 (base32
515 "108za1cmjslwzkdl76x9kwxkq8z734kg9nz8rxk057f10pqwxgh4"))
516 (patches (search-patches "xfce4-settings-defaults.patch"))))
517 (build-system gnu-build-system)
518 (native-inputs
519 `(("pkg-config" ,pkg-config)
520 ("intltool" ,intltool)))
521 (inputs
522 `(("exo" ,exo)
523 ("garcon" ,garcon)
524 ("libnotify" ,libnotify)
525 ("libxcursor" ,libxcursor)
526 ("libxi" ,libxi)
527 ("libxklavier" ,libxklavier)
528 ("libxrandr" ,libxrandr)
529 ("libxfce4ui" ,libxfce4ui)
530 ("upower" ,upower)
531 ("xf86-input-libinput" ,xf86-input-libinput)))
532 (home-page "http://www.xfce.org/")
533 (synopsis "Xfce settings manager")
534 (description
535 "Settings manager for Xfce, it can control various aspects of the desktop
536 like appearance, display, keyboard and mouse settings.")
537 (license gpl2+)))
538
539 (define-public thunar
540 (package
541 (name "thunar")
542 (version "1.6.6")
543 (source (origin
544 (method url-fetch)
545 (uri (string-append "http://archive.xfce.org/xfce/4.12/src/"
546 "Thunar-" version ".tar.bz2"))
547 (sha256
548 (base32
549 "1cl9v3rdzipyyxml3pyrzspxfmmssz5h5snpj18irq4an42539dr"))))
550 (build-system gnu-build-system)
551 (native-inputs
552 `(("pkg-config" ,pkg-config)
553 ("intltool" ,intltool)))
554 (inputs
555 `(("exo" ,exo)
556 ("libexif" ,libexif)
557 ("libgudev" ,libgudev)
558 ("libnotify" ,libnotify)
559 ("libxfce4ui" ,libxfce4ui)
560 ("pcre" ,pcre)
561 ("xfce4-panel" ,xfce4-panel)
562 ("startup-notification" ,startup-notification)))
563 (home-page "http://www.xfce.org/")
564 (synopsis "Xfce file manager")
565 (description
566 "A modern file manager for graphical desktop, aiming to be easy-to-use and
567 fast.")
568 (license gpl2+)))
569
570 (define-public thunar-volman
571 (package
572 (name "thunar-volman")
573 (version "0.8.1")
574 (source (origin
575 (method url-fetch)
576 (uri (string-append "http://archive.xfce.org/xfce/4.12/src/"
577 name "-" version ".tar.bz2"))
578 (sha256
579 (base32
580 "1gf259n1v3y23n1zlkhyr6r0i8j59rnl1cmxvxj6la9cwdfbn22s"))))
581 (build-system gnu-build-system)
582 (native-inputs
583 `(("pkg-config" ,pkg-config)
584 ("intltool" ,intltool)))
585 (inputs
586 `(("exo" ,exo)
587 ("libgudev" ,libgudev)
588 ("libnotify" ,libnotify)
589 ("libxfce4ui" ,libxfce4ui)))
590 (home-page "http://www.xfce.org/")
591 (synopsis "Removable media manager for Thunar")
592 (description
593 "Thunar-volman is an extension for the Thunar File Manager, which enables
594 automatic management of removable drives and media. For example, if
595 thunar-volman is installed and configured properly, and you plug in your
596 digital camera, it will automatically spawn your preferred photo application
597 and import the new pictures from your camera.")
598 (license gpl2+)))
599
600 (define-public xfwm4
601 (package
602 (name "xfwm4")
603 (version "4.12.0")
604 (source (origin
605 (method url-fetch)
606 (uri (string-append "http://archive.xfce.org/xfce/"
607 (version-major+minor version)
608 "/src/" name "-" version ".tar.bz2"))
609 (sha256
610 (base32
611 "0fnc2ps4k733n9qfpxrz047h1myyqjzxczl7fmkjmqwshvicpx19"))))
612 (build-system gnu-build-system)
613 (native-inputs
614 `(("pkg-config" ,pkg-config)
615 ("intltool" ,intltool)))
616 (inputs
617 `(("libdrm" ,libdrm)
618 ("libwnck" ,libwnck-2)
619 ("libxcomposite" ,libxcomposite)
620 ("libxdamage" ,libxdamage)
621 ("libxfce4ui" ,libxfce4ui)
622 ("libxrandr" ,libxrandr)))
623 (home-page "http://www.xfce.org/")
624 (synopsis "Xfce window manager")
625 (description
626 "Window manager for Xfce, it handles the placement of windows
627 on the screen.")
628 (license gpl2+)))
629
630 (define-public xfdesktop
631 (package
632 (name "xfdesktop")
633 (version "4.12.0")
634 (source (origin
635 (method url-fetch)
636 (uri (string-append "http://archive.xfce.org/xfce/"
637 (version-major+minor version)
638 "/src/" name "-" version ".tar.bz2"))
639 (sha256
640 (base32
641 "1ivzgg4792nid6wcgd1nq5vc3z0y5ip6ymq7ci5j2qkp663qnykf"))))
642 (build-system gnu-build-system)
643 (native-inputs
644 `(("pkg-config" ,pkg-config)
645 ("intltool" ,intltool)))
646 (inputs
647 `(("exo" ,exo)
648 ("garcon" ,garcon)
649 ("libnotify" ,libnotify)
650 ("libwnck" ,libwnck-2)
651 ("libxfce4ui" ,libxfce4ui)
652 ("thunar" ,thunar)))
653 (home-page "http://www.xfce.org/")
654 (synopsis "Xfce desktop manager")
655 (description
656 "Desktop manager for Xfce, it sets the background color or image with
657 optional application menu or icons for minimized applications or launchers,
658 devices and folders.")
659 (license gpl2+)))
660
661 (define-public xfce4-terminal
662 (package
663 (name "xfce4-terminal")
664 (version "0.6.3")
665 (source (origin
666 (method url-fetch)
667 (uri (string-append "http://archive.xfce.org/src/apps/" name "/"
668 (version-major+minor version) "/"
669 name "-" version ".tar.bz2"))
670 (sha256
671 (base32
672 "023y0lkfijifh05yz8grimxadqpi98mrivr00sl18nirq8b4fbwi"))))
673 (build-system gnu-build-system)
674 (native-inputs
675 `(("pkg-config" ,pkg-config)
676 ("intltool" ,intltool)))
677 (inputs
678 `(("libxfce4ui" ,libxfce4ui)
679 ("vte" ,vte/gtk+-2)))
680 (home-page "http://www.xfce.org/")
681 (synopsis "Xfce terminal emulator")
682 (description
683 "A lightweight and easy to use terminal emulator for Xfce. Features
684 include a simple configuration interface, the ability to use multiple tabs
685 with terminals within a single window, the possibility to have a
686 pseudo-transparent terminal background, and a compact mode (where both the
687 menubar and the window decorations are hidden) that helps you to save space
688 on your desktop.")
689 (license gpl2+)))
690
691 (define-public xfce
692 (package
693 (name "xfce")
694 (version (package-version xfce4-session))
695 (source #f)
696 (build-system trivial-build-system)
697 (arguments '(#:builder (mkdir %output)))
698 (propagated-inputs
699 `(("exo" ,exo)
700 ("garcon" ,garcon)
701 ("gnome-icon-theme" ,gnome-icon-theme)
702 ("gtk-xfce-engine" ,gtk-xfce-engine)
703 ("hicolor-icon-theme" ,hicolor-icon-theme)
704 ("ristretto" ,ristretto)
705 ("shared-mime-info" ,shared-mime-info)
706 ("thunar" ,thunar)
707 ("thunar-volman" ,thunar-volman)
708 ("tumlber" ,tumbler)
709 ("xfce4-appfinder" ,xfce4-appfinder)
710 ("xfce4-panel" ,xfce4-panel)
711 ("xfce4-power-manager" ,xfce4-power-manager)
712 ("xfce4-session" ,xfce4-session)
713 ("xfce4-settings" ,xfce4-settings)
714 ("xfce4-terminal" ,xfce4-terminal)
715 ("xfconf" ,xfconf)
716 ("xfdesktop" ,xfdesktop)
717 ("xfwm4" ,xfwm4)
718 ;; Panel plugins.
719 ("xfce4-battery-plugin" ,xfce4-battery-plugin)
720 ("xfce4-clipman-plugin" ,xfce4-clipman-plugin)
721 ("xfce4-pulseaudio-plugin" ,xfce4-pulseaudio-plugin)
722 ("xfce4-xkb-plugin" ,xfce4-xkb-plugin)))
723 (home-page "http://www.xfce.org/")
724 (synopsis "Desktop environment (meta-package)")
725 (description
726 "Xfce is a lightweight desktop environment. It aims to be fast and low on
727 system resources, while still being visually appealing and user friendly.")
728 (license gpl2+)))
729
730 (define-public xfce4-power-manager
731 (package
732 (name "xfce4-power-manager")
733 (version "1.4.3")
734 (source (origin
735 (method url-fetch)
736 (uri (string-append "http://archive.xfce.org/xfce/4.12"
737 "/src/" name "-" version ".tar.bz2"))
738 (sha256
739 (base32
740 "04909sfc2nrj2wg9cw6y9y2r9yrp3l3vc201sy1gaiap67fi33h1"))))
741 (build-system gnu-build-system)
742 (arguments
743 '(#:configure-flags '("--enable-gtk3")))
744 (native-inputs
745 `(("pkg-config" ,pkg-config)
746 ("intltool" ,intltool)))
747 (inputs
748 `(("lbxrandr" ,libxrandr)
749 ("upower" ,upower)
750 ("libnotify" ,libnotify)
751 ("libxfce4ui" ,libxfce4ui)))
752 (home-page "http://www.xfce.org/")
753 (synopsis "Xfce Power Manager")
754 (description
755 "This is a power manager for the Xfce desktop. It manages the power
756 sources on the computer and the devices that can be controlled to reduce their
757 power consumption (such as LCD brightness level, monitor sleep, CPU frequency
758 scaling, etc). In addition, xfce4-power-manager provides a set of
759 freedesktop-compliant DBus interfaces to inform other applications about current
760 power level so that they can adjust their power consumption, and it provides the
761 inhibit interface which allows applications to prevent automatic sleep.")
762 (license gpl2+)))
763
764 (define-public ristretto
765 (package
766 (name "ristretto")
767 (version "0.8.0")
768 (source (origin
769 (method url-fetch)
770 (uri (string-append "http://archive.xfce.org/src/apps/ristretto/"
771 (version-major+minor version) "/"
772 name "-" version ".tar.bz2"))
773 (sha256
774 (base32
775 "0a7kwhx51fd2kqh7l7kp13wcn39d2fjkwnn9rfd1k9ydrqj56qki"))))
776 (build-system gnu-build-system)
777 (native-inputs
778 `(("intltool" ,intltool)
779 ("pkg-config" ,pkg-config)))
780 (inputs
781 `(("desktop-file-utils" ,desktop-file-utils)
782 ("libexif" ,libexif)
783 ("libxfce4ui" ,libxfce4ui)
784 ("librsvg" ,librsvg)
785 ("tumbler" ,tumbler)))
786 (home-page "http://docs.xfce.org/apps/ristretto/start")
787 (synopsis "Fast and lightweight picture-viewer")
788 (description
789 "The Ristretto Image Viewer is an application that can be used to view,
790 and scroll through images. It can be used to run a slideshow of images, open
791 images with other applications like an image-editor or configure an image as
792 the desktop wallpaper.")
793 (license gpl2+)))
794
795 (define-public xfce4-taskmanager
796 (package
797 (name "xfce4-taskmanager")
798 (version "1.1.0")
799 (source (origin
800 (method url-fetch)
801 (uri (string-append "http://archive.xfce.org/src/apps/"
802 name "/" (version-major+minor version) "/"
803 name "-" version ".tar.bz2"))
804 (sha256
805 (base32
806 "1jwywmkkkmz7406m1jq40w6apiav25cznafhigbgpjv6z5hv27if"))))
807 (build-system gnu-build-system)
808 (native-inputs
809 `(("intltool" ,intltool)
810 ("pkg-config" ,pkg-config)))
811 (inputs
812 `(("libwnck" ,libwnck-2)
813 ("gtk+" ,gtk+-2)))
814 (home-page "http://goodies.xfce.org/projects/applications/xfce4-taskmanager")
815 (synopsis "Easy to use task manager")
816 (description
817 "This is a task manager for the Xfce desktop. It displays the CPU and
818 memory usage graphically, and it can display processes as a tree.")
819 (license gpl2+)))
820
821 (define-public orage
822 (package
823 (name "orage")
824 (version "4.12.1")
825 (source (origin
826 (method url-fetch)
827 (uri (string-append "http://archive.xfce.org/src/apps/"
828 name "/" (version-major+minor version) "/"
829 name "-" version ".tar.bz2"))
830 (sha256
831 (base32
832 "0qlhvnl2m33vfxqlbkic2nmfpwyd4mq230jzhs48cg78392amy9w"))))
833 (build-system gnu-build-system)
834 (native-inputs
835 `(("intltool" ,intltool)
836 ("pkg-config" ,pkg-config)))
837 (inputs
838 `(("gtk+" ,gtk+-2)
839 ("libical" ,libical)
840 ("libnotify" ,libnotify)
841 ("popt" ,popt)
842 ("xfce4-panel" ,xfce4-panel)))
843 (home-page "http://www.xfce.org/projects/")
844 (synopsis "Simple calendar application with reminders")
845 (description
846 "This is a simple calendar application for the Xfce desktop. Orage has
847 alarms and uses the iCalendar format, making it compatible with many other
848 calendar applications. It also includes a panel clock plugin and an
849 international clock application capable of simultaneously showing clocks from
850 several different time zones.")
851 (license gpl2+)))