gnu: Add intervaltree.
[jackhill/guix/guix.git] / gnu / packages / fribidi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
3 ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages fribidi)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix licenses)
26 #:use-module (gnu packages))
27
28 (define-public fribidi
29 (package
30 (replacement fribidi/fixed)
31 (name "fribidi")
32 (version "1.0.5")
33 (source
34 (origin
35 (method url-fetch)
36 (uri
37 (string-append "https://github.com/fribidi/fribidi/releases"
38 "/download/v" version "/fribidi-" version
39 ".tar.bz2"))
40 (sha256
41 (base32 "1kp4b1hpx2ky20ixgy2xhj5iygfl7ps5k9kglh1z5i7mhykg4r3a"))))
42 (build-system gnu-build-system)
43 (synopsis "Implementation of the Unicode bidirectional algorithm")
44 (description
45 "GNU FriBidi is an implementation of the Unicode Bidirectional
46 Algorithm. This algorithm is used to properly display text in left-to-right
47 or right-to-left ordering as necessary.")
48 (home-page "https://github.com/fribidi/fribidi")
49 (license lgpl2.1+)))
50
51 (define fribidi/fixed
52 (package
53 (inherit fribidi)
54 (source
55 (origin (inherit (package-source fribidi))
56 (patches (search-patches "fribidi-CVE-2019-18397.patch"))))))