Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / package-management.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2017 Muriithi Frederick Muriuki <fredmanglis@gmail.com>
5 ;;; Copyright © 2017, 2018 Oleg Pykhalov <go.wigust@gmail.com>
6 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
7 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
9 ;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
10 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
11 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
12 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
13 ;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
14 ;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
15 ;;;
16 ;;; This file is part of GNU Guix.
17 ;;;
18 ;;; GNU Guix is free software; you can redistribute it and/or modify it
19 ;;; under the terms of the GNU General Public License as published by
20 ;;; the Free Software Foundation; either version 3 of the License, or (at
21 ;;; your option) any later version.
22 ;;;
23 ;;; GNU Guix is distributed in the hope that it will be useful, but
24 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
25 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
26 ;;; GNU General Public License for more details.
27 ;;;
28 ;;; You should have received a copy of the GNU General Public License
29 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
30
31 (define-module (gnu packages package-management)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages acl)
34 #:use-module (gnu packages attr)
35 #:use-module (gnu packages avahi)
36 #:use-module (gnu packages autotools)
37 #:use-module (gnu packages backup)
38 #:use-module (gnu packages base)
39 #:use-module (gnu packages bdw-gc)
40 #:use-module (gnu packages bison)
41 #:use-module (gnu packages bootstrap) ;for 'bootstrap-guile-origin'
42 #:use-module (gnu packages check)
43 #:use-module (gnu packages compression)
44 #:use-module (gnu packages cpio)
45 #:use-module (gnu packages crypto)
46 #:use-module (gnu packages curl)
47 #:use-module (gnu packages dbm)
48 #:use-module (gnu packages docbook)
49 #:use-module (gnu packages file)
50 #:use-module (gnu packages gettext)
51 #:use-module (gnu packages glib)
52 #:use-module (gnu packages gnome)
53 #:use-module (gnu packages gnupg)
54 #:use-module (gnu packages graphviz)
55 #:use-module (gnu packages gtk)
56 #:use-module (gnu packages guile)
57 #:use-module (gnu packages guile-xyz)
58 #:use-module (gnu packages linux)
59 #:use-module (gnu packages lisp)
60 #:use-module (gnu packages man)
61 #:use-module (gnu packages nettle)
62 #:use-module (gnu packages nss)
63 #:use-module (gnu packages patchutils)
64 #:use-module (gnu packages perl)
65 #:use-module (gnu packages perl-check)
66 #:use-module (gnu packages pkg-config)
67 #:use-module (gnu packages popt)
68 #:use-module (gnu packages python)
69 #:use-module (gnu packages python-web)
70 #:use-module (gnu packages python-xyz)
71 #:use-module (gnu packages serialization)
72 #:use-module (gnu packages sqlite)
73 #:use-module (gnu packages ssh)
74 #:use-module (gnu packages texinfo)
75 #:use-module (gnu packages time)
76 #:use-module (gnu packages tls)
77 #:use-module (gnu packages vim)
78 #:use-module (gnu packages virtualization)
79 #:use-module (gnu packages web)
80 #:use-module (gnu packages xml)
81 #:use-module (gnu packages xorg)
82 #:use-module (guix build-system glib-or-gtk)
83 #:use-module (guix build-system gnu)
84 #:use-module (guix build-system meson)
85 #:use-module (guix build-system python)
86 #:use-module (guix download)
87 #:use-module (guix gexp)
88 #:use-module (guix git-download)
89 #:use-module ((guix licenses) #:prefix license:)
90 #:use-module (guix packages)
91 #:use-module (guix utils)
92 #:use-module (ice-9 match)
93 #:use-module (srfi srfi-1))
94
95 (define (boot-guile-uri arch)
96 "Return the URI for the bootstrap Guile tarball for ARCH."
97 (cond ((string=? "armhf" arch)
98 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
99 arch "-linux"
100 "/20150101/guile-2.0.11.tar.xz"))
101 ((string=? "aarch64" arch)
102 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
103 arch "-linux/20170217/guile-2.0.14.tar.xz"))
104 (else
105 (string-append "http://alpha.gnu.org/gnu/guix/bootstrap/"
106 arch "-linux"
107 "/20131110/guile-2.0.9.tar.xz"))))
108
109 (define-public guix
110 ;; Latest version of Guix, which may or may not correspond to a release.
111 ;; Note: the 'update-guix-package.scm' script expects this definition to
112 ;; start precisely like this.
113 (let ((version "1.0.1")
114 (commit "820429517f9cc8333704a839b4346ac4b02468c4")
115 (revision 1))
116 (package
117 (name "guix")
118
119 (version (if (zero? revision)
120 version
121 (string-append version "-"
122 (number->string revision)
123 "." (string-take commit 7))))
124 (source (origin
125 (method git-fetch)
126 (uri (git-reference
127 (url "https://git.savannah.gnu.org/r/guix.git")
128 (commit commit)))
129 (sha256
130 (base32
131 "1vfp7ps1k1cwn8p0gsgarlxcy982hzyvb7zqnj66jqd258a1qfgh"))
132 (file-name (string-append "guix-" version "-checkout"))))
133 (build-system gnu-build-system)
134 (arguments
135 `(#:configure-flags (list
136 "--localstatedir=/var"
137 "--sysconfdir=/etc"
138 (string-append "--with-bash-completion-dir="
139 (assoc-ref %outputs "out")
140 "/etc/bash_completion.d")
141
142 ;; Set 'DOT_USER_PROGRAM' to the empty string so
143 ;; we don't keep a reference to Graphviz, whose
144 ;; closure is pretty big (too big for the Guix
145 ;; system installation image.)
146 "ac_cv_path_DOT_USER_PROGRAM=dot"
147
148 ;; To avoid problems with the length of shebangs,
149 ;; choose a fixed-width and short directory name
150 ;; for tests.
151 "ac_cv_guix_test_root=/tmp/guix-tests")
152 #:parallel-tests? #f ;work around <http://bugs.gnu.org/21097>
153
154 #:modules ((guix build gnu-build-system)
155 (guix build utils)
156 (srfi srfi-26)
157 (ice-9 popen)
158 (ice-9 rdelim))
159
160 #:phases (modify-phases %standard-phases
161 (replace 'bootstrap
162 (lambda _
163 ;; Make sure 'msgmerge' can modify the PO files.
164 (for-each (lambda (po)
165 (chmod po #o666))
166 (find-files "." "\\.po$"))
167
168 (patch-shebang "build-aux/git-version-gen")
169
170 (call-with-output-file ".tarball-version"
171 (lambda (port)
172 (display ,version port)))
173
174 (invoke "sh" "bootstrap")))
175 (add-before 'check 'copy-bootstrap-guile
176 (lambda* (#:key system inputs #:allow-other-keys)
177 ;; Copy the bootstrap guile tarball in the store used
178 ;; by the test suite.
179 (define (intern tarball)
180 (let ((base (strip-store-file-name tarball)))
181 (copy-file tarball base)
182 (invoke "./test-env" "guix" "download"
183 (string-append "file://" (getcwd)
184 "/" base))
185 (delete-file base)))
186
187
188 (intern (assoc-ref inputs "boot-guile"))
189
190 ;; On x86_64 some tests need the i686 Guile.
191 ,@(if (and (not (%current-target-system))
192 (string=? (%current-system)
193 "x86_64-linux"))
194 '((intern (assoc-ref inputs "boot-guile/i686")))
195 '())
196 #t))
197 (add-after 'unpack 'disable-failing-tests
198 ;; XXX FIXME: These tests fail within the build container.
199 (lambda _
200 (substitute* "tests/syscalls.scm"
201 (("^\\(test-(assert|equal) \"(clone|setns|pivot-root)\"" all)
202 (string-append "(test-skip 1)\n" all)))
203 (substitute* "tests/containers.scm"
204 (("^\\(test-(assert|equal)" all)
205 (string-append "(test-skip 1)\n" all)))
206 (when (file-exists? "tests/guix-environment-container.sh")
207 (substitute* "tests/guix-environment-container.sh"
208 (("guix environment --version")
209 "exit 77\n")))
210 #t))
211 (add-before 'check 'set-SHELL
212 (lambda _
213 ;; 'guix environment' tests rely on 'SHELL' having a
214 ;; correct value, so set it.
215 (setenv "SHELL" (which "sh"))
216 #t))
217 (add-after 'install 'wrap-program
218 (lambda* (#:key inputs outputs #:allow-other-keys)
219 ;; Make sure the 'guix' command finds GnuTLS,
220 ;; Guile-JSON, and Guile-Git automatically.
221 (let* ((out (assoc-ref outputs "out"))
222 (guile (assoc-ref inputs "guile"))
223 (gcrypt (assoc-ref inputs "guile-gcrypt"))
224 (json (assoc-ref inputs "guile-json"))
225 (sqlite (assoc-ref inputs "guile-sqlite3"))
226 (git (assoc-ref inputs "guile-git"))
227 (bs (assoc-ref inputs
228 "guile-bytestructures"))
229 (ssh (assoc-ref inputs "guile-ssh"))
230 (gnutls (assoc-ref inputs "gnutls"))
231 (locales (assoc-ref inputs "glibc-utf8-locales"))
232 (deps (list gcrypt json sqlite gnutls
233 git bs ssh))
234 (effective
235 (read-line
236 (open-pipe* OPEN_READ
237 (string-append guile "/bin/guile")
238 "-c" "(display (effective-version))")))
239 (path (string-join
240 (map (cut string-append <>
241 "/share/guile/site/"
242 effective)
243 (delete #f deps))
244 ":"))
245 (gopath (string-join
246 (map (cut string-append <>
247 "/lib/guile/" effective
248 "/site-ccache")
249 (delete #f deps))
250 ":"))
251 (locpath (string-append locales "/lib/locale")))
252
253 (wrap-program (string-append out "/bin/guix")
254 `("GUILE_LOAD_PATH" ":" prefix (,path))
255 `("GUILE_LOAD_COMPILED_PATH" ":" prefix (,gopath))
256 `("GUIX_LOCPATH" ":" suffix (,locpath)))
257
258 #t))))))
259 (native-inputs `(("pkg-config" ,pkg-config)
260
261 ;; XXX: Keep the development inputs here even though
262 ;; they're unnecessary, just so that 'guix environment
263 ;; guix' always contains them.
264 ("autoconf" ,autoconf-wrapper)
265 ("automake" ,automake)
266 ("gettext" ,gettext-minimal)
267 ("texinfo" ,texinfo)
268 ("graphviz" ,graphviz)
269 ("help2man" ,help2man)
270 ("po4a" ,po4a)))
271 (inputs
272 `(("bzip2" ,bzip2)
273 ("gzip" ,gzip)
274 ("zlib" ,zlib) ;for 'guix publish'
275
276 ("sqlite" ,sqlite)
277 ("libgcrypt" ,libgcrypt)
278
279 ("guile" ,guile-2.2)
280
281 ;; Many tests rely on the 'guile-bootstrap' package, which is why we
282 ;; have it here.
283 ("boot-guile" ,(bootstrap-guile-origin (%current-system)))
284 ;; Some of the tests use "unshare" when it is available.
285 ("util-linux" ,util-linux)
286 ,@(if (and (not (%current-target-system))
287 (string=? (%current-system) "x86_64-linux"))
288 `(("boot-guile/i686" ,(bootstrap-guile-origin "i686-linux")))
289 '())
290
291 ("glibc-utf8-locales" ,glibc-utf8-locales)))
292 (propagated-inputs
293 `(("gnutls" ,gnutls)
294 ("guile-gcrypt" ,guile-gcrypt)
295 ("guile-json" ,guile-json)
296 ("guile-sqlite3" ,guile-sqlite3)
297 ("guile-ssh" ,guile-ssh)
298 ("guile-git" ,guile-git)))
299
300 (home-page "https://www.gnu.org/software/guix/")
301 (synopsis "Functional package manager for installed software packages and versions")
302 (description
303 "GNU Guix is a functional package manager for the GNU system, and is
304 also a distribution thereof. It includes a virtual machine image. Besides
305 the usual package management features, it also supports transactional
306 upgrades and roll-backs, per-user profiles, and much more. It is based on
307 the Nix package manager.")
308 (license license:gpl3+)
309 (properties '((ftp-server . "alpha.gnu.org"))))))
310
311 (define-public guix-daemon
312 ;; This package is for internal consumption: it allows us to quickly build
313 ;; the 'guix-daemon' program and use that in (guix self), used by 'guix
314 ;; pull'.
315 (package
316 (inherit guix)
317 (properties `((hidden? . #t)))
318 (name "guix-daemon")
319
320 ;; Use a minimum set of dependencies.
321 (native-inputs
322 (fold alist-delete (package-native-inputs guix)
323 '("po4a" "graphviz" "help2man")))
324 (inputs
325 `(("gnutls" ,gnutls)
326 ("guile-git" ,guile-git)
327 ("guile-json" ,guile-json)
328 ("guile-gcrypt" ,guile-gcrypt)
329 ,@(fold alist-delete (package-inputs guix)
330 '("boot-guile" "boot-guile/i686" "util-linux"))))
331
332 (propagated-inputs '())
333
334 (arguments
335 (substitute-keyword-arguments (package-arguments guix)
336 ((#:configure-flags flags '())
337 ;; Pretend we have those libraries; we don't actually need them.
338 `(append ,flags
339 '("guix_cv_have_recent_guile_sqlite3=yes"
340 "guix_cv_have_recent_guile_ssh=yes")))
341 ((#:tests? #f #f)
342 #f)
343 ((#:phases phases '%standard-phases)
344 `(modify-phases ,phases
345 (replace 'build
346 (lambda _
347 (invoke "make" "nix/libstore/schema.sql.hh")
348 (invoke "make" "-j" (number->string
349 (parallel-job-count))
350 "guix-daemon")))
351 (delete 'copy-bootstrap-guile)
352 (replace 'install
353 (lambda* (#:key outputs #:allow-other-keys)
354 (invoke "make" "install-binPROGRAMS"
355 "install-nodist_pkglibexecSCRIPTS")
356
357 ;; We need to tell 'guix-daemon' which 'guix' command to use.
358 ;; Here we use a questionable hack where we hard-code root's
359 ;; current guix, which could be wrong (XXX). Note that scripts
360 ;; like 'guix perform-download' do not run as root so we assume
361 ;; that they have access to /var/guix/profiles/per-user/root.
362 (let ((out (assoc-ref outputs "out")))
363 (substitute* (find-files (string-append out "/libexec"))
364 (("exec \".*/bin/guix\"")
365 "exec \"${GUIX:-/var/guix/profiles/per-user/root/current-guix/bin/guix}\""))
366 #t)))
367 (delete 'wrap-program)))))))
368
369 (define-public guile2.0-guix
370 (deprecated-package "guile2.0-guix" guix))
371
372 (define-public guix-minimal
373 ;; A version of Guix which is built with the minimal set of dependencies, as
374 ;; outlined in the README "Requirements" section. Intended as a CI job, so
375 ;; marked as hidden.
376 (hidden-package
377 (package
378 (inherit guix)
379 (name "guix-minimal")
380 (inputs
381 `(("guile" ,guile-2.2)
382 ,@(alist-delete "guile" (package-inputs guix))))
383 (propagated-inputs
384 (fold alist-delete
385 (package-propagated-inputs guix)
386 '("guile-ssh"))))))
387
388 (define (source-file? file stat)
389 "Return true if FILE is likely a source file, false if it is a typical
390 generated file."
391 (define (wrong-extension? file)
392 (or (string-suffix? "~" file)
393 (member (file-extension file)
394 '("o" "a" "lo" "so" "go"))))
395
396 (match (basename file)
397 ((or ".git" "autom4te.cache" "configure" "Makefile" "Makefile.in" ".libs")
398 #f)
399 ((? wrong-extension?)
400 #f)
401 (_
402 #t)))
403
404 (define-public current-guix-package
405 ;; This parameter allows callers to override the package that 'current-guix'
406 ;; returns. This is useful when 'current-guix' cannot compute it by itself,
407 ;; for instance because it's not running from a source code checkout.
408 (make-parameter #f))
409
410 (define-public current-guix
411 (let* ((repository-root (delay (canonicalize-path
412 (string-append (current-source-directory)
413 "/../.."))))
414 (select? (delay (or (git-predicate (force repository-root))
415 source-file?))))
416 (lambda ()
417 "Return a package representing Guix built from the current source tree.
418 This works by adding the current source tree to the store (after filtering it
419 out) and returning a package that uses that as its 'source'."
420 (or (current-guix-package)
421 (package
422 (inherit guix)
423 (version (string-append (package-version guix) "+"))
424 (source (local-file (force repository-root) "guix-current"
425 #:recursive? #t
426 #:select? (force select?))))))))
427
428 \f
429 ;;;
430 ;;; Other tools.
431 ;;;
432
433 (define-public nix
434 (package
435 (name "nix")
436 (version "2.0.4")
437 (source (origin
438 (method url-fetch)
439 (uri (string-append "http://nixos.org/releases/nix/nix-"
440 version "/nix-" version ".tar.xz"))
441 (sha256
442 (base32
443 "0ss9svxlh1pvrdmnqjvjyqjmbqmrdbyfarvbb14i9d4bggzl0r8n"))))
444 (build-system gnu-build-system)
445 (native-inputs `(("pkg-config" ,pkg-config)))
446 (inputs `(("curl" ,curl)
447 ("bzip2" ,bzip2)
448 ("libgc" ,libgc)
449 ("libseccomp" ,libseccomp)
450 ("libsodium" ,libsodium)
451 ("openssl" ,openssl)
452 ("sqlite" ,sqlite)
453 ("xz" ,xz)))
454 (home-page "https://nixos.org/nix/")
455 (synopsis "The Nix package manager")
456 (description
457 "Nix is a purely functional package manager. This means that it treats
458 packages like values in purely functional programming languages such as
459 Haskell—they are built by functions that don't have side-effects, and they
460 never change after they have been built. Nix stores packages in the Nix
461 store, usually the directory /nix/store, where each package has its own unique
462 sub-directory.")
463 (license license:lgpl2.1+)))
464
465 (define-public stow
466 (package
467 (name "stow")
468 (version "2.2.2")
469 (source (origin
470 (method url-fetch)
471 (uri (string-append "mirror://gnu/stow/stow-"
472 version ".tar.gz"))
473 (sha256
474 (base32
475 "1pvky9fayms4r6fhns8jd0vavszd7d979w62vfd5n88v614pdxz2"))))
476 (build-system gnu-build-system)
477 (inputs
478 `(("perl" ,perl)))
479 (native-inputs
480 `(("perl-test-simple" ,perl-test-simple)
481 ("perl-test-output" ,perl-test-output)
482 ("perl-capture-tiny" ,perl-capture-tiny)
483 ("perl-io-stringy" ,perl-io-stringy)))
484 (home-page "https://www.gnu.org/software/stow/")
485 (synopsis "Managing installed software packages")
486 (description
487 "GNU Stow is a symlink manager. It generates symlinks to directories
488 of data and makes them appear to be merged into the same directory. It is
489 typically used for managing software packages installed from source, by
490 letting you install them apart in distinct directories and then create
491 symlinks to the files in a common directory such as /usr/local.")
492 (license license:gpl2+)))
493
494 (define-public rpm
495 (package
496 (name "rpm")
497 (version "4.14.2.1")
498 (source (origin
499 (method url-fetch)
500 (uri (string-append "http://ftp.rpm.org/releases/rpm-"
501 (version-major+minor version) ".x/rpm-"
502 version ".tar.bz2"))
503 (sha256
504 (base32
505 "1nmck2fq9h85fgs3zhh6w1avlw5y16cbz5khd459ry3jfd5w4f8i"))))
506 (build-system gnu-build-system)
507 (arguments
508 '(#:configure-flags '("--with-external-db" ;use the system's bdb
509 "--enable-python"
510 "--without-lua")
511 #:phases (modify-phases %standard-phases
512 (add-before 'configure 'set-nss-library-path
513 (lambda* (#:key inputs #:allow-other-keys)
514 (let ((nss (assoc-ref inputs "nss")))
515 (setenv "LIBRARY_PATH"
516 (string-append (getenv "LIBRARY_PATH") ":"
517 nss "/lib/nss"))
518 #t))))))
519 (native-inputs
520 `(("pkg-config" ,pkg-config)))
521 (inputs
522 `(("python" ,python)
523 ("xz" ,xz)
524 ("bdb" ,bdb)
525 ("popt" ,popt)
526 ("nss" ,nss)
527 ("nspr" ,nspr)
528 ("libarchive" ,libarchive)
529 ("nettle" ,nettle) ;XXX: actually a dependency of libarchive
530 ("file" ,file)
531 ("bzip2" ,bzip2)
532 ("zlib" ,zlib)
533 ("cpio" ,cpio)))
534 (home-page "https://rpm.org/")
535 (synopsis "The RPM Package Manager")
536 (description
537 "The RPM Package Manager (RPM) is a command-line driven package
538 management system capable of installing, uninstalling, verifying, querying,
539 and updating computer software packages. Each software package consists of an
540 archive of files along with information about the package like its version, a
541 description. There is also a library permitting developers to manage such
542 transactions from C or Python.")
543
544 ;; The whole is GPLv2+; librpm itself is dual-licensed LGPLv2+ | GPLv2+.
545 (license license:gpl2+)))
546
547 (define-public diffoscope
548 (package
549 (name "diffoscope")
550 (version "114")
551 (source (origin
552 (method url-fetch)
553 (uri (pypi-uri name version))
554 (sha256
555 (base32
556 "07sma4izcqxdv0zi1s5fnsybvkc47c3vbpm372sg83q8l7rhizzp"))))
557 (build-system python-build-system)
558 (arguments
559 `(#:phases (modify-phases %standard-phases
560 ;; setup.py mistakenly requires python-magic from PyPi, even
561 ;; though the Python bindings of `file` are sufficient.
562 ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815844
563 (add-after 'unpack 'dependency-on-python-magic
564 (lambda _
565 (substitute* "setup.py"
566 (("'python-magic',") ""))))
567 ;; This test is broken because our `file` package has a
568 ;; bug in berkeley-db file type detection.
569 (add-after 'unpack 'remove-berkeley-test
570 (lambda _
571 (delete-file "tests/comparators/test_berkeley_db.py")
572 #t))
573 (add-after 'unpack 'embed-tool-references
574 (lambda* (#:key inputs #:allow-other-keys)
575 (substitute* "diffoscope/comparators/utils/compare.py"
576 (("\\['xxd',")
577 (string-append "['" (which "xxd") "',")))
578 (substitute* "diffoscope/comparators/elf.py"
579 (("@tool_required\\('readelf'\\)") "")
580 (("get_tool_name\\('readelf'\\)")
581 (string-append "'" (which "readelf") "'")))
582 (substitute* "diffoscope/comparators/directory.py"
583 (("@tool_required\\('stat'\\)") "")
584 (("@tool_required\\('getfacl'\\)") "")
585 (("\\['stat',")
586 (string-append "['" (which "stat") "',"))
587 (("\\['getfacl',")
588 (string-append "['" (which "getfacl") "',")))
589 #t))
590 (add-before 'check 'delete-failing-test
591 (lambda _
592 (delete-file "tests/test_tools.py") ;this requires /sbin to be on the path
593 #t)))))
594 (inputs `(("rpm" ,rpm) ;for rpm-python
595 ("python-file" ,python-file)
596 ("python-debian" ,python-debian)
597 ("python-libarchive-c" ,python-libarchive-c)
598 ("python-tlsh" ,python-tlsh)
599 ("acl" ,acl) ;for getfacl
600 ("colordiff" ,colordiff)
601 ("xxd" ,xxd)
602
603 ;; Below are modules used for tests.
604 ("python-pytest" ,python-pytest)
605 ("python-chardet" ,python-chardet)))
606 (home-page "https://diffoscope.org/")
607 (synopsis "Compare files, archives, and directories in depth")
608 (description
609 "Diffoscope tries to get to the bottom of what makes files or directories
610 different. It recursively unpacks archives of many kinds and transforms
611 various binary formats into more human readable forms to compare them. It can
612 compare two tarballs, ISO images, or PDFs just as easily.")
613 (license license:gpl3+)))
614
615 (define-public trydiffoscope
616 (package
617 (name "trydiffoscope")
618 (version "67.0.1")
619 (source
620 (origin
621 (method git-fetch)
622 (uri (git-reference
623 (url "https://salsa.debian.org/reproducible-builds/trydiffoscope.git")
624 (commit version)))
625 (file-name (git-file-name name version))
626 (sha256
627 (base32
628 "03b66cjii7l2yiwffj6ym6mycd5drx7prfp4j2550281pias6mjh"))))
629 (arguments
630 `(#:phases
631 (modify-phases %standard-phases
632 (add-after 'install 'install-doc
633 (lambda* (#:key outputs #:allow-other-keys)
634 (let* ((share (string-append (assoc-ref outputs "out") "/share/")))
635 (mkdir-p (string-append share "/man/man1/" ))
636 (invoke "rst2man.py"
637 "trydiffoscope.1.rst"
638 (string-append share "/man/man1/trydiffoscope.1"))
639 (mkdir-p (string-append share "/doc/" ,name "-" ,version))
640 (install-file "./README.rst"
641 (string-append share "/doc/" ,name "-" ,version)))
642 #t)))))
643 (propagated-inputs
644 `(("python-requests" ,python-requests)))
645 (native-inputs
646 `(("gzip" ,gzip)
647 ("python-docutils" ,python-docutils)))
648 (build-system python-build-system)
649 (home-page "https://try.diffoscope.org")
650 (synopsis "Client for remote diffoscope service")
651 (description "This is a client for the @url{https://try.diffoscope.org,
652 remote diffoscope service}.
653
654 Diffoscope tries to get to the bottom of what makes files or directories
655 different. It recursively unpacks archives of many kinds and transforms
656 various binary formats into more human readable forms to compare them. It can
657 compare two tarballs, ISO images, or PDFs just as easily.
658
659 Results are displayed by default, stored as local text or html files, or made
660 available via a URL on @url{https://try.diffoscope.org}. Results stored on the
661 server are purged after 30 days.")
662 (license license:gpl3+)))
663
664 (define-public python-anaconda-client
665 (package
666 (name "python-anaconda-client")
667 (version "1.6.3")
668 (source
669 (origin
670 (method url-fetch)
671 (uri (string-append "https://github.com/Anaconda-Platform/"
672 "anaconda-client/archive/" version ".tar.gz"))
673 (file-name (string-append name "-" version ".tar.gz"))
674 (sha256
675 (base32
676 "1wv4wi6k5jz7rlwfgvgfdizv77x3cr1wa2aj0k1595g7fbhkjhz2"))))
677 (build-system python-build-system)
678 (propagated-inputs
679 `(("python-pyyaml" ,python-pyyaml)
680 ("python-requests" ,python-requests)
681 ("python-clyent" ,python-clyent)))
682 (native-inputs
683 `(("python-pytz" ,python-pytz)
684 ("python-dateutil" ,python-dateutil)
685 ("python-mock" ,python-mock)
686 ("python-coverage" ,python-coverage)
687 ("python-pillow" ,python-pillow)))
688 (arguments
689 `(#:phases
690 (modify-phases %standard-phases
691 ;; This is needed for some tests.
692 (add-before 'check 'set-up-home
693 (lambda* _ (setenv "HOME" "/tmp") #t))
694 (add-before 'check 'remove-network-tests
695 (lambda* _
696 ;; Remove tests requiring a network connection
697 (let ((network-tests '("tests/test_upload.py"
698 "tests/test_authorizations.py"
699 "tests/test_login.py"
700 "tests/test_whoami.py"
701 "utils/notebook/tests/test_data_uri.py"
702 "utils/notebook/tests/test_base.py"
703 "utils/notebook/tests/test_downloader.py"
704 "inspect_package/tests/test_conda.py")))
705 (with-directory-excursion "binstar_client"
706 (for-each delete-file network-tests)))
707 #t)))))
708 (home-page "https://github.com/Anaconda-Platform/anaconda-client")
709 (synopsis "Anaconda Cloud command line client library")
710 (description
711 "Anaconda Cloud command line client library provides an interface to
712 Anaconda Cloud. Anaconda Cloud is useful for sharing packages, notebooks and
713 environments.")
714 (license license:bsd-3)))
715
716 (define-public python2-anaconda-client
717 (package-with-python2 python-anaconda-client))
718
719 (define-public python-conda
720 (package
721 (name "python-conda")
722 (version "4.3.16")
723 (source
724 (origin
725 (method url-fetch)
726 (uri (string-append "https://github.com/conda/conda/archive/"
727 version ".tar.gz"))
728 (file-name (string-append name "-" version ".tar.gz"))
729 (sha256
730 (base32
731 "1jq8hyrc5npb5sf4vw6s6by4602yj8f79vzpbwdfgpkn02nfk1dv"))))
732 (build-system python-build-system)
733 (arguments
734 `(#:phases
735 (modify-phases %standard-phases
736 (add-before 'build 'create-version-file
737 (lambda _
738 (with-output-to-file "conda/.version"
739 (lambda () (display ,version)))
740 #t))
741 (add-before 'check 'remove-failing-tests
742 (lambda _
743 ;; These tests require internet/network access
744 (let ((network-tests '("test_cli.py"
745 "test_create.py"
746 "test_export.py"
747 "test_fetch.py"
748 "test_history.py"
749 "test_info.py"
750 "test_install.py"
751 "test_priority.py"
752 "conda_env/test_cli.py"
753 "conda_env/test_create.py"
754 "conda_env/specs/test_notebook.py"
755 "conda_env/utils/test_notebooks.py"
756 "core/test_index.py"
757 "core/test_repodata.py")))
758 (with-directory-excursion "tests"
759 (for-each delete-file network-tests)
760
761 ;; FIXME: This test creates a file, then deletes it and tests
762 ;; that the file was deleted. For some reason it fails when
763 ;; building with guix, but does not when you run it in the
764 ;; directory left when you build with the --keep-failed
765 ;; option
766 (delete-file "gateways/disk/test_delete.py")
767 #t))))
768 (replace 'check
769 (lambda _
770 (setenv "HOME" "/tmp")
771 (invoke "py.test"))))))
772 (native-inputs
773 `(("python-cytoolz" ,python-cytoolz)
774 ("python-ruamel.yaml" ,python-ruamel.yaml)
775 ("python-requests" ,python-requests)
776 ("python-pycosat" ,python-pycosat)
777 ("python-pytest" ,python-pytest)
778 ("python-responses" ,python-responses)
779 ("python-pyyaml" ,python-pyyaml)
780 ("python-anaconda-client" ,python-anaconda-client)))
781 (home-page "https://github.com/conda/conda")
782 (synopsis "Cross-platform, OS-agnostic, system-level binary package manager")
783 (description
784 "Conda is a cross-platform, Python-agnostic binary package manager. It
785 is the package manager used by Anaconda installations, but it may be used for
786 other systems as well. Conda makes environments first-class citizens, making
787 it easy to create independent environments even for C libraries. Conda is
788 written entirely in Python.
789
790 This package provides Conda as a library.")
791 (license license:bsd-3)))
792
793 (define-public python2-conda
794 (let ((base (package-with-python2
795 (strip-python2-variant python-conda))))
796 (package (inherit base)
797 (native-inputs
798 `(("python2-enum34" ,python2-enum34)
799 ,@(package-native-inputs base))))))
800
801 (define-public conda
802 (package (inherit python-conda)
803 (name "conda")
804 (arguments
805 (substitute-keyword-arguments (package-arguments python-conda)
806 ((#:phases phases)
807 `(modify-phases ,phases
808 (replace 'build
809 (lambda* (#:key outputs #:allow-other-keys)
810 ;; This test fails when run before installation.
811 (delete-file "tests/test_activate.py")
812
813 ;; Fix broken defaults
814 (substitute* "conda/base/context.py"
815 (("return sys.prefix")
816 (string-append "return \"" (assoc-ref outputs "out") "\""))
817 (("return (prefix_is_writable\\(self.root_prefix\\))" _ match)
818 (string-append "return False if self.root_prefix == self.conda_prefix else "
819 match)))
820
821 ;; The util/setup-testing.py is used to build conda in
822 ;; application form, rather than the default, library form.
823 ;; With this, we are able to run commands like `conda --help`
824 ;; directly on the command line
825 (invoke "python" "utils/setup-testing.py" "build_py")))
826 (replace 'install
827 (lambda* (#:key inputs outputs #:allow-other-keys)
828 (let* ((out (assoc-ref outputs "out"))
829 (target (string-append out "/lib/python"
830 ((@@ (guix build python-build-system)
831 get-python-version)
832 (assoc-ref inputs "python"))
833 "/site-packages/")))
834 ;; The installer aborts if the target directory is not on
835 ;; PYTHONPATH.
836 (setenv "PYTHONPATH"
837 (string-append target ":" (getenv "PYTHONPATH")))
838
839 ;; And it aborts if the directory doesn't exist.
840 (mkdir-p target)
841 (invoke "python" "utils/setup-testing.py" "install"
842 (string-append "--prefix=" out)))))
843 ;; The "activate" and "deactivate" scripts don't need wrapping.
844 ;; They also break when they are renamed.
845 (add-after 'wrap 'undo-wrap
846 (lambda* (#:key outputs #:allow-other-keys)
847 (with-directory-excursion (string-append (assoc-ref outputs "out") "/bin/")
848 (delete-file "deactivate")
849 (rename-file ".deactivate-real" "deactivate")
850 (delete-file "activate")
851 (rename-file ".activate-real" "activate")
852 #t)))))))
853 (description
854 "Conda is a cross-platform, Python-agnostic binary package manager. It
855 is the package manager used by Anaconda installations, but it may be used for
856 other systems as well. Conda makes environments first-class citizens, making
857 it easy to create independent environments even for C libraries. Conda is
858 written entirely in Python.")))
859
860 (define-public gwl
861 (package
862 (name "gwl")
863 (version "0.1.1")
864 (source (origin
865 (method url-fetch)
866 (uri (string-append "https://www.guixwl.org/releases/gwl-"
867 version ".tar.gz"))
868 (sha256
869 (base32
870 "06pm967mq1wyggx7l0nfapw5s0k5qc5r9lawk2v3db868br779a7"))))
871 (build-system gnu-build-system)
872 (native-inputs
873 `(("autoconf" ,autoconf)
874 ("automake" ,automake)
875 ("pkg-config" ,pkg-config)))
876 (inputs
877 `(("guile" ,guile-2.2)))
878 (propagated-inputs
879 `(("guix" ,guix)
880 ("guile-commonmark" ,guile-commonmark)))
881 (home-page "https://www.guixwl.org")
882 (synopsis "Workflow management extension for GNU Guix")
883 (description "This project provides two subcommands to GNU Guix and
884 introduces two record types that provide a workflow management extension built
885 on top of GNU Guix.")
886 ;; The Scheme modules in guix/ and gnu/ are licensed GPL3+,
887 ;; the web interface modules in gwl/ are licensed AGPL3+,
888 ;; and the fonts included in this package are licensed OFL1.1.
889 (license (list license:gpl3+ license:agpl3+ license:silofl1.1))))
890
891 (define-public gcab
892 (package
893 (name "gcab")
894 (version "1.2")
895 (source (origin
896 (method url-fetch)
897 (uri (string-append "mirror://gnome/sources/gcab/"
898 version "/gcab-" version ".tar.xz"))
899 (sha256
900 (base32
901 "038h5kk41si2hc9d9169rrlvp8xgsxq27kri7hv2vr39gvz9cbas"))))
902 (build-system meson-build-system)
903 (native-inputs
904 `(("glib:bin" ,glib "bin") ; for glib-mkenums
905 ("intltool" ,intltool)
906 ("pkg-config" ,pkg-config)
907 ("vala" ,vala)))
908 (inputs
909 `(("glib" ,glib)
910 ("zlib" ,zlib)))
911 (arguments
912 `(#:configure-flags
913 ;; XXX This ‘documentation’ is for developers, and fails informatively:
914 ;; Error in gtkdoc helper script: 'gtkdoc-mkhtml' failed with status 5
915 (list "-Ddocs=false"
916 "-Dintrospection=false")))
917 (home-page "https://wiki.gnome.org/msitools") ; no dedicated home page
918 (synopsis "Microsoft Cabinet file manipulation library")
919 (description
920 "The libgcab library provides GObject functions to read, write, and modify
921 Microsoft cabinet (.@dfn{CAB}) files.")
922 (license (list license:gpl2+ ; tests/testsuite.at
923 license:lgpl2.1+)))) ; the rest
924
925 (define-public msitools
926 (package
927 (name "msitools")
928 (version "0.99")
929 (source (origin
930 (method url-fetch)
931 (uri (string-append "mirror://gnome/sources/msitools/"
932 version "/msitools-" version ".tar.xz"))
933 (sha256
934 (base32
935 "0d9nidn5zc81bc30w119933rn2g87mrsqyqkndg20srkbsd96xfl"))))
936 (build-system gnu-build-system)
937 (native-inputs
938 `(("bison" ,bison)
939 ("pkg-config" ,pkg-config)))
940 (inputs
941 `(("gcab" ,gcab)
942 ("glib" ,glib)
943 ("libgsf" ,libgsf)
944 ("libxml2" ,libxml2)
945 ("uuid" ,util-linux)))
946 (home-page "https://wiki.gnome.org/msitools")
947 (synopsis "Windows Installer file manipulation tool")
948 (description
949 "msitools is a collection of command-line tools to inspect, extract, build,
950 and sign Windows@tie{}Installer (.@dfn{MSI}) files. It aims to be a solution
951 for packaging and deployment of cross-compiled Windows applications.")
952 (license license:lgpl2.1+)))
953
954 (define-public libostree
955 (package
956 (name "libostree")
957 (version "2018.9.1")
958 (source (origin
959 (method url-fetch)
960 (uri (string-append
961 "https://github.com/ostreedev/ostree/releases/download/v"
962 (version-major+minor version) "/libostree-" version ".tar.xz"))
963 (sha256
964 (base32
965 "01mygpkbl9sk2vr3hjbpih6qlg8lwx0q5lklm09f7jfwfpnwyqzj"))))
966 (build-system gnu-build-system)
967 (arguments
968 '(#:phases
969 (modify-phases %standard-phases
970 (add-before 'check 'pre-check
971 (lambda _
972 ;; Don't try to use the non-existing '/var/tmp' as test
973 ;; directory.
974 (setenv "TEST_TMPDIR" (getenv "TMPDIR"))
975 #t)))
976 ;; XXX: fails with:
977 ;; tap-driver.sh: internal error getting exit status
978 ;; tap-driver.sh: fatal: I/O or internal error
979 #:tests? #f))
980 (native-inputs
981 `(("attr" ,attr) ; for tests
982 ("bison" ,bison)
983 ("glib:bin" ,glib "bin") ; for 'glib-mkenums'
984 ("gobject-introspection" ,gobject-introspection)
985 ("pkg-config" ,pkg-config)
986 ("xsltproc" ,libxslt)))
987 (inputs
988 `(("avahi" ,avahi)
989 ("docbook-xml" ,docbook-xml-4.2)
990 ("docbook-xsl" ,docbook-xsl)
991 ("e2fsprogs" ,e2fsprogs)
992 ("fuse" ,fuse)
993 ("glib" ,glib)
994 ("gpgme" ,gpgme)
995 ("libarchive" ,libarchive)
996 ("libsoup" ,libsoup)
997 ("nettle" ,nettle) ; required by 'libarchive.la'
998 ("util-linux" ,util-linux)))
999 (home-page "https://ostree.readthedocs.io/en/latest/")
1000 (synopsis "Operating system and container binary deployment and upgrades")
1001 (description
1002 "@code{libostree} is both a shared library and suite of command line
1003 tools that combines a \"git-like\" model for committing and downloading
1004 bootable file system trees, along with a layer for deploying them and managing
1005 the boot loader configuration.")
1006 (license license:lgpl2.0+)))
1007
1008 (define-public flatpak
1009 (package
1010 (name "flatpak")
1011 (version "1.2.4")
1012 (source
1013 (origin
1014 (method url-fetch)
1015 (uri (string-append "https://github.com/flatpak/flatpak/releases/download/"
1016 version "/flatpak-" version ".tar.xz"))
1017 (sha256
1018 (base32
1019 "1qf3ys84fzv11z6f6li59rxjdjbyrv7cyi9539k73r9i9pckjr8v"))))
1020
1021 ;; Wrap 'flatpak' so that GIO_EXTRA_MODULES is set, thereby allowing GIO to
1022 ;; find the TLS backend in glib-networking.
1023 (build-system glib-or-gtk-build-system)
1024
1025 (arguments
1026 '(#:tests? #f ;; Tests fail due to trying to create files where it can't.
1027 #:configure-flags (list
1028 "--enable-documentation=no" ;; FIXME
1029 "--enable-system-helper=no"
1030 "--localstatedir=/var"
1031 (string-append "--with-system-bubblewrap="
1032 (assoc-ref %build-inputs "bubblewrap")
1033 "/bin/bwrap"))))
1034 (native-inputs `(("bison" ,bison)
1035 ("gettext" ,gnu-gettext)
1036 ("glib:bin" ,glib "bin") ; for glib-mkenums + gdbus-codegen
1037 ("gobject-introspection" ,gobject-introspection)
1038 ("libcap" ,libcap)
1039 ("pkg-config" ,pkg-config)))
1040 (propagated-inputs `(("glib-networking" ,glib-networking)
1041 ("gnupg" ,gnupg)
1042 ("gsettings-desktop-schemas"
1043 ,gsettings-desktop-schemas)))
1044 (inputs `(("appstream-glib" ,appstream-glib)
1045 ("bubblewrap" ,bubblewrap)
1046 ("dconf" ,dconf)
1047 ("gdk-pixbuf" ,gdk-pixbuf)
1048 ("gpgme" ,gpgme)
1049 ("json-glib" ,json-glib)
1050 ("libarchive" ,libarchive)
1051 ("libostree" ,libostree)
1052 ("libseccomp" ,libseccomp)
1053 ("libsoup" ,libsoup)
1054 ("libxau" ,libxau)
1055 ("libxml2" ,libxml2)
1056 ("nettle" ,nettle)
1057 ("util-linux" ,util-linux)))
1058 (home-page "https://flatpak.org")
1059 (synopsis "System for building, distributing, and running sandboxed desktop
1060 applications")
1061 (description "Flatpak is a system for building, distributing, and running
1062 sandboxed desktop applications on GNU/Linux.")
1063 (license license:lgpl2.1+)))