Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / mes.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017,2018 Jan Nieuwenhuizen <janneke@gnu.org>
3 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages mes)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages base)
24 #:use-module (gnu packages commencement)
25 #:use-module (gnu packages cross-base)
26 #:use-module (gnu packages gcc)
27 #:use-module (gnu packages graphviz)
28 #:use-module (gnu packages guile)
29 #:use-module (gnu packages man)
30 #:use-module (gnu packages package-management)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages texinfo)
33 #:use-module (guix build-system gnu)
34 #:use-module (guix download)
35 #:use-module (guix git-download)
36 #:use-module (guix licenses)
37 #:use-module (guix packages))
38
39 (define-public nyacc
40 (package
41 (name "nyacc")
42 (version "0.86.0")
43 (source (origin
44 (method url-fetch)
45 (uri (string-append "mirror://savannah/nyacc/"
46 name "-" version ".tar.gz"))
47 (patches (search-patches "nyacc-binary-literals.patch"))
48 (sha256
49 (base32
50 "0lkd9lyspvhxlfs0496gsllwinh62jk9wij6gpadvx9gwz6yavd9"))))
51 (build-system gnu-build-system)
52 (native-inputs
53 `(("guile" ,guile-2.2)))
54 (synopsis "LALR(1) Parser Generator in Guile")
55 (description
56 "NYACC is an LALR(1) parser generator implemented in Guile.
57 The syntax and nomenclature should be considered not stable. It comes with
58 extensive examples, including parsers for the Javascript and C99 languages.")
59 (home-page "https://savannah.nongnu.org/projects/nyacc")
60 (license (list gpl3+ lgpl3+))))
61
62 (define-public mes
63 (package
64 (name "mes")
65 (version "0.19")
66 (source (origin
67 (method url-fetch)
68 (uri (string-append "mirror://gnu/mes/"
69 "mes-" version ".tar.gz"))
70 (sha256
71 (base32
72 "15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
73 (build-system gnu-build-system)
74 (supported-systems '("i686-linux" "x86_64-linux"))
75 (propagated-inputs
76 `(("mescc-tools" ,mescc-tools)
77 ("nyacc" ,nyacc)))
78 (native-inputs
79 `(("guile" ,guile-2.2)
80 ,@(let ((target-system (or (%current-target-system)
81 (%current-system))))
82 (cond
83 ((string-prefix? "x86_64-linux" target-system)
84 ;; Use cross-compiler rather than #:system "i686-linux" to get
85 ;; MesCC 64 bit .go files installed ready for use with Guile.
86 `(("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
87 ("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))))
88 (else
89 '())))
90 ("graphviz" ,graphviz)
91 ("help2man" ,help2man)
92 ("perl" ,perl) ; build-aux/gitlog-to-changelog
93 ("texinfo" ,texinfo)))
94 (arguments
95 `(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
96 (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
97 (description
98 "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
99 bootstrap to Guix and aims to help create full source bootstrapping for
100 GNU/Linux distributions. It consists of a mutual self-hosting Scheme
101 interpreter in C and a Nyacc-based C compiler in Scheme and is compatible with
102 Guile.")
103 (home-page "https://gnu.org/software/mes")
104 (license gpl3+)))
105
106 (define-public mescc-tools
107 (package
108 (name "mescc-tools")
109 (version "0.5.2")
110 (source (origin
111 (method url-fetch)
112 (uri (string-append
113 "http://git.savannah.nongnu.org/cgit/mescc-tools.git/snapshot/"
114 name "-Release_" version
115 ".tar.gz"))
116 (file-name (string-append name "-" version ".tar.gz"))
117 (sha256
118 (base32
119 "01x7bhmgwyf6mc2g1hcvibhps98nllacqm4f0j5l51b1mbi18pc2"))))
120 (build-system gnu-build-system)
121 (supported-systems '("i686-linux" "x86_64-linux"))
122 (arguments
123 `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
124 #:test-target "test"
125 #:phases (modify-phases %standard-phases
126 (delete 'configure))))
127 (synopsis "Tools for the full source bootstrapping process")
128 (description
129 "Mescc-tools is a collection of tools for use in a full source
130 bootstrapping process. It consists of the M1 macro assembler, the hex2
131 linker, the blood-elf symbol table generator, the kaem shell, exec_enable and
132 get_machine.")
133 (home-page "https://savannah.nongnu.org/projects/mescc-tools")
134 (license gpl3+)))