gnu: Add meson-for-build.
[jackhill/guix/guix.git] / gnu / packages / patches / meson-for-build-rpath.patch
1 This patch removes a part of meson that clears the rpath upon installation.
2 This will only be applied to a special version of meson, used for the
3 meson-build-system.
4
5 Patch by Peter Mikkelsen <petermikkelsen10@gmail.com>
6
7 --- meson-0.42.0/mesonbuild/scripts/meson_install.py.orig 2017-09-09 01:49:39.147374148 +0200
8 +++ meson-0.42.0/mesonbuild/scripts/meson_install.py 2017-09-09 01:51:01.209134717 +0200
9 @@ -345,15 +345,6 @@
10 print("Symlink creation does not work on this platform. "
11 "Skipping all symlinking.")
12 printed_symlink_error = True
13 - if is_elf_platform() and os.path.isfile(outname):
14 - try:
15 - e = depfixer.Elf(outname, False)
16 - e.fix_rpath(install_rpath)
17 - except SystemExit as e:
18 - if isinstance(e.code, int) and e.code == 0:
19 - pass
20 - else:
21 - raise
22
23 def run(args):
24 global install_log_file