gnu: pari-gp: Update to 2.5.4.
[jackhill/guix/guix.git] / gnu / packages / apr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages apr)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages perl)
26 #:use-module (gnu packages autotools))
27
28 (define-public apr
29 (package
30 (name "apr")
31 (version "1.4.8")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://apache/apr/apr-"
35 version ".tar.bz2"))
36 (sha256
37 (base32
38 "0884csfk3f530yscak0jlr6w929s3ys0n7fpwdg3dii1sgwd5f31"))))
39 (build-system gnu-build-system)
40 (arguments
41 `(#:patches (list (assoc-ref %build-inputs
42 "patch/skip-test"))
43 #:patch-flags '("-p0")))
44 (inputs `(("perl" ,perl)
45 ("libtool" ,libtool)
46 ("patch/skip-test"
47 ,(search-patch "apr-skip-getservbyname-test.patch"))))
48 (home-page "http://apr.apache.org/")
49 (synopsis "The Apache Portable Runtime Library")
50 (description
51 "The mission of the Apache Portable Runtime (APR) project is to create and
52 maintain software libraries that provide a predictable and consistent interface
53 to underlying platform-specific implementations. The primary goal is to provide
54 an API to which software developers may code and be assured of predictable if
55 not identical behaviour regardless of the platform on which their software is
56 built, relieving them of the need to code special-case conditions to work
57 around or take advantage of platform-specific deficiencies or features.")
58 (license asl2.0)))
59
60 (define-public apr-util
61 (package
62 (name "apr-util")
63 (version "1.5.2")
64 (source (origin
65 (method url-fetch)
66 (uri (string-append "mirror://apache/apr/apr-util-"
67 version ".tar.bz2"))
68 (sha256
69 (base32
70 "19qjxpckb9p4j9pbk8kcirg6k5vqnjrqhnk9xx2c5m9964p3vkls"))))
71 (build-system gnu-build-system)
72 (inputs
73 `(("apr" ,apr)))
74 (arguments
75 '(#:phases
76 (alist-replace
77 'configure
78 (lambda* (#:key inputs outputs #:allow-other-keys)
79 (let ((out (assoc-ref outputs "out"))
80 (apr (assoc-ref inputs "apr")))
81 (setenv "CONFIG_SHELL" (which "bash"))
82 (zero?
83 (system* "./configure"
84 (string-append "--prefix=" out)
85 (string-append "--with-apr=" apr)))))
86 %standard-phases)))
87 (home-page "http://apr.apache.org/")
88 (synopsis "One of the Apache Portable Runtime Library companions")
89 (description
90 "APR-util provides a number of helpful abstractions on top of APR.")
91 (license asl2.0)))