gnu: Rename module gprolog to prolog.
[jackhill/guix/guix.git] / gnu / packages / prolog.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2013 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages prolog)
22 #:use-module (guix download)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix build-system gnu)
26 #:use-module (srfi srfi-1))
27
28 (define-public gprolog
29 (package
30 (name "gprolog")
31 (version "1.4.5")
32 (source
33 (origin
34 (method url-fetch)
35 ;; Recent versions are not hosted on the GNU mirrors.
36 (uri (list (string-append "http://gprolog.org/gprolog-" version
37 ".tar.gz")
38 (string-append "mirror://gnu/gprolog/gprolog-" version
39 ".tar.gz")))
40 (sha256
41 (base32
42 "0z4cc42n3k6i35b8mr816iwsvrpxshw6d7dgz6s2h1hy0l7g1p5z"))))
43 (build-system gnu-build-system)
44 (arguments
45 `(#:configure-flags
46 (list (string-append
47 "--with-install-dir=" %output "/share/gprolog"))
48 #:phases
49 (modify-phases %standard-phases
50 (add-before 'configure 'change-dir-n-fix-shells
51 (lambda _
52 (chdir "src")
53 (substitute* "configure"
54 (("-/bin/sh") (string-append "-" (which "sh")))
55 (("= /bin/sh") (string-append "= " (which "sh"))))
56 #t)))))
57 (home-page "https://www.gnu.org/software/gprolog/")
58 (synopsis "Prolog compiler")
59 (description
60 "GNU Prolog is a standards-compliant Prolog compiler with constraint
61 solving over finite domains. It accepts Prolog+ constraint programs and
62 produces a compiled, native binary which can function in a stand-alone
63 manner. It also features an interactive interpreter.")
64 (license (list gpl2+ lgpl3+))
65
66 ;; See 'configure' for the list of supported architectures.
67 (supported-systems (fold delete
68 %supported-systems
69 '("armhf-linux" "mips64el-linux")))))