gnu: dealii: Update to 8.5.0.
[jackhill/guix/guix.git] / gnu / packages / calcurse.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages calcurse)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages base)
26 #:use-module (gnu packages ncurses))
27
28 (define-public calcurse
29 (package
30 (name "calcurse")
31 (version "4.2.2")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "http://calcurse.org/files/calcurse-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "0il0y06akdqgy0f9p40m4x6arn66nh7sr1w1i41bszycs7div266"))))
40 (build-system gnu-build-system)
41 (inputs `(("ncurses" ,ncurses)
42 ("tzdata" ,tzdata)))
43 (arguments
44 ;; The ical tests all want to create a ".calcurse" directory, and may
45 ;; fail with "cannot create directory '.calcurse': File exists" if run
46 ;; concurently.
47 '(#:parallel-tests? #f
48 #:phases (modify-phases %standard-phases
49 (add-before 'check 'check-setup
50 (lambda* (#:key inputs #:allow-other-keys)
51 (setenv "TZDIR" ;for test/ical-007.sh
52 (string-append (assoc-ref inputs "tzdata")
53 "/share/zoneinfo")))))))
54 (home-page "http://www.calcurse.org")
55 (synopsis "Text-based calendar and scheduling")
56 (description
57 "Calcurse is a text-based calendar and scheduling application. It helps
58 keep track of events, appointments and everyday tasks. A configurable
59 notification system reminds user of upcoming deadlines, and the curses based
60 interface can be customized to suit user needs. All of the commands are
61 documented within an online help system.")
62 (license bsd-2)))