Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / ftp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages ftp)
24 #:use-module ((guix licenses) #:select (gpl2+ gpl3+ clarified-artistic))
25 #:use-module (guix build-system gnu)
26 #:use-module (guix download)
27 #:use-module (guix packages)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages autotools)
30 #:use-module (gnu packages check)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages databases)
33 #:use-module (gnu packages freedesktop)
34 #:use-module (gnu packages gettext)
35 #:use-module (gnu packages glib)
36 #:use-module (gnu packages gtk)
37 #:use-module (gnu packages libidn)
38 #:use-module (gnu packages ncurses)
39 #:use-module (gnu packages nettle)
40 #:use-module (gnu packages pkg-config)
41 #:use-module (gnu packages readline)
42 #:use-module (gnu packages tls)
43 #:use-module (gnu packages wxwidgets)
44 #:use-module (gnu packages xml))
45
46 (define-public lftp
47 (package
48 (name "lftp")
49 (version "4.8.3")
50 (source (origin
51 (method url-fetch)
52 ;; See https://lftp.tech/get.html for mirrors.
53 (uri (list (string-append "https://lftp.tech/ftp/lftp-"
54 version ".tar.xz")
55 (string-append "https://lftp.tech/ftp/old/lftp-"
56 version ".tar.xz")
57 (string-append "ftp://ftp.st.ryukoku.ac.jp/pub/network/"
58 "ftp/lftp/lftp-" version ".tar.xz")))
59 (sha256
60 (base32
61 "12y77jlfs4x4zvcah92mw2h2sb4j0bvbaxkh3wwsm8gs392ywyny"))))
62 (build-system gnu-build-system)
63 (native-inputs
64 `(("pkg-config" ,pkg-config)))
65 (inputs
66 `(("zlib" ,zlib)
67 ("readline" ,readline)
68 ("gnutls" ,gnutls)))
69 (arguments
70 `(#:phases
71 (modify-phases %standard-phases
72 ;; Disable tests that require network access, which is most of them.
73 (add-before 'check 'disable-impure-tests
74 (lambda _
75 (substitute* "tests/Makefile"
76 (("(ftp-cls-l|ftp-list|http-get)\\$\\(EXEEXT\\)") "")
77 (("lftp-https-get ") "")))))
78 #:configure-flags
79 (list (string-append "--with-readline="
80 (assoc-ref %build-inputs "readline")))))
81 (home-page "https://lftp.tech/")
82 (synopsis "Command-line file transfer program")
83 (description
84 "LFTP is a sophisticated FTP/HTTP client, and a file transfer program
85 supporting a number of network protocols. Like Bash, it has job control and
86 uses the Readline library for input. It has bookmarks, a built-in mirror
87 command, and can transfer several files in parallel. It was designed with
88 reliability in mind.")
89 (license gpl3+)))
90
91 (define-public ncftp
92 (package
93 (name "ncftp")
94 (version "3.2.6")
95 (source (origin
96 (method url-fetch)
97 (uri (string-append "ftp://ftp.ncftp.com/ncftp/ncftp-"
98 version "-src.tar.xz"))
99 (sha256
100 (base32
101 "1389657cwgw5a3kljnqmhvfh4vr2gcr71dwz1mlhf22xq23hc82z"))
102 (modules '((guix build utils)))
103 (snippet
104 '(begin
105 ;; Use the right 'rm' and 'ls'.
106 (substitute* (cons "configure"
107 (find-files "."
108 "^(Makefile\\.in|.*\\.sh)$"))
109 (("/bin/(rm|ls)" _ command)
110 command))
111
112 ;; This is free software, avoid any confusion.
113 (substitute* (find-files "." "\\.c$")
114 (("a freeware program")
115 "free software"))
116 #t))))
117 (build-system gnu-build-system)
118 (arguments
119 '(#:phases
120 (modify-phases %standard-phases
121 (replace 'configure
122 (lambda* (#:key outputs #:allow-other-keys)
123 ;; This is an old 'configure' script that doesn't
124 ;; understand variables passed as arguments.
125 (let ((out (assoc-ref outputs "out")))
126 (setenv "CONFIG_SHELL" (which "sh"))
127 (setenv "SHELL" (which "sh"))
128 (zero? (system* "./configure"
129 (string-append "--prefix=" out)))))))
130 #:tests? #f)) ;there are no tests
131 (inputs `(("ncurses" ,ncurses)))
132 (home-page "http://www.ncftp.com/ncftp/")
133 (synopsis "Command-line File Transfer Protocol (FTP) client")
134 (description
135 "NcFTP Client (or just NcFTP) is a set of command-line programs to access
136 File Transfer Protocol (FTP) servers. This includes 'ncftp', an interactive
137 FTP browser, as well as non-interactive commands such as 'ncftpput' and
138 'ncftpget'.")
139 (license clarified-artistic)))
140
141
142 (define-public weex
143 (package
144 (name "weex")
145 (version "2.8.2")
146 (source
147 (origin
148 (method url-fetch)
149 (uri
150 (string-append "mirror://sourceforge/weex/weex/"
151 "/weex_" version ".tar.gz"))
152 (sha256
153 (base32
154 "1ir761hjncr1bamaqcw9j7x57xi3s9jax3223bxwbq30a0vsw1pd"))))
155 (build-system gnu-build-system)
156 (native-inputs
157 `(("automake" ,automake)
158 ("autoconf" ,autoconf)
159 ("gettext" ,gettext-minimal)))
160 (home-page "http://weex.sourceforge.net/")
161 (synopsis "Non-interactive client for FTP synchronization")
162 (description
163 "Weex is a utility designed to automate the task of remotely
164 maintaining a web page or other FTP archive. It synchronizes a set of
165 local files to a remote server by performing uploads and remote deletes
166 as required.")
167 (license gpl2+)))
168
169 (define-public libfilezilla
170 (package
171 (name "libfilezilla")
172 (version "0.12.2")
173 (source
174 (origin
175 (method url-fetch)
176 (uri (string-append "http://download.filezilla-project.org/"
177 name "/" name "-" version ".tar.bz2"))
178 (sha256
179 (base32
180 "1v461hwdk74whp89s490dj1z18gfqf9bz9140m5f11rsvrpid33p"))))
181 (build-system gnu-build-system)
182 (native-inputs
183 `(("cppunit" ,cppunit)
184 ("pkg-config" ,pkg-config)))
185 (home-page "https://lib.filezilla-project.org")
186 (synopsis "Cross-platform C++ library used by Filezilla client")
187 (description
188 "This package provides some basic functionality to build high-performing,
189 platform-independent programs.
190
191 Some of the highlights include:
192 @itemize
193 @item
194 A type-safe, multi-threaded event system that's simple to use yet efficient.
195 @item
196 Timers for periodic events.
197 @item
198 A @code{datetime} class that not only tracks timestamp but also their accuracy,
199 which simplifies dealing with timestamps originating from different sources.
200 @item
201 Simple process handling for spawning child processes with redirected input and
202 output.
203 @end itemize\n")
204 (license gpl2+)))
205
206 (define-public filezilla
207 (package
208 (name "filezilla")
209 (version "3.31.0")
210 (source
211 (origin
212 (method url-fetch)
213 (uri (string-append "https://sourceforge.net/projects/" name
214 "/files/FileZilla_Client/" version
215 "/FileZilla_" version "_src" ".tar.bz2"))
216 (sha256
217 (base32
218 "1rfysb8dil35a7bzj2kw0mzzkys39d7yn6ipsbk8l6rkwfvnii8l"))))
219 (build-system gnu-build-system)
220 (arguments
221 ;; Don't let filezilla phone home to check for updates.
222 '(#:configure-flags '("--disable-autoupdatecheck")))
223 (native-inputs
224 `(("gettext" ,gettext-minimal)
225 ("pkg-config" ,pkg-config)
226 ("pugixml" ,pugixml)
227 ("xdg-utils" ,xdg-utils)))
228 (inputs
229 `(("dbus" ,dbus)
230 ("gnutls" ,gnutls)
231 ("gtk+" ,gtk+)
232 ("libfilezilla" ,libfilezilla)
233 ("libidn" ,libidn)
234 ("nettle" ,nettle)
235 ("sqlite" ,sqlite)
236 ("wxwidgets" ,wxwidgets)))
237 (home-page "https://filezilla-project.org")
238 (synopsis "Full-featured graphical FTP/FTPS/SFTP client")
239 (description
240 "Filezilla client supports FTP, FTP over SSL/TLS (FTPS),
241 SSH File Transfer Protocol (SFTP), HTTP/1.1, SOCKS5, FTP-Proxy, IPv6
242 and others features such as bookmarks, drag and drop, filename filters,
243 directory comparison and more.")
244 (license gpl2+)
245 (properties '((upstream-name . "FileZilla")))))