gnu: apl: Update to 1.5.
[jackhill/guix/guix.git] / gnu / packages / apl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages apl)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages gettext)
26 #:use-module (gnu packages maths)
27 #:use-module (gnu packages databases)
28 #:use-module (gnu packages readline))
29
30 (define-public apl
31 (package
32 (name "apl")
33 (version "1.5")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz"))
38 (sha256
39 (base32
40 "0h4diq3wfbdwxp5nm0z4b0p1zq13lwip0y7v28r9v0mbbk8xsfh1"))))
41 (build-system gnu-build-system)
42 (home-page "http://www.gnu.org/software/apl/")
43 (inputs
44 `(("gettext" ,gnu-gettext)
45 ("lapack" ,lapack)
46 ("sqlite" ,sqlite)
47 ("readline" ,readline)))
48 (arguments
49 `(#:configure-flags (list (string-append
50 "--with-sqlite3="
51 (assoc-ref %build-inputs "sqlite")))))
52 (synopsis "APL interpreter")
53 (description
54 "GNU APL is a free interpreter for the programming language APL. It is
55 an implementation of the ISO standard 13751.")
56 (license gpl3+)))