gnu: r-quantreg: Update to 5.67.
[jackhill/guix/guix.git] / gnu / packages / onc-rpc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 John Darrington <jmd@gnu.org>
4 ;;; Copyright © 2017, 2018 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
7 ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages onc-rpc)
25 #:use-module (guix licenses)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix git-download)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages autotools)
31 #:use-module (gnu packages gettext)
32 #:use-module (gnu packages kerberos)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (guix build-system gnu)
35 #:use-module (guix utils))
36
37 (define-public libtirpc
38 (package
39 (name "libtirpc")
40 (version "1.2.5")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "mirror://sourceforge/libtirpc/libtirpc/"
44 version "/libtirpc-"
45 version ".tar.bz2"))
46 (sha256
47 (base32
48 "1jl6a5kkw2vrp4gb6pmvf72rqimywvwfb9f7iz2xjg4wgq63bdpk"))))
49 (build-system gnu-build-system)
50 (arguments
51 `(#:configure-flags '("--disable-static")
52 #:phases
53 (modify-phases %standard-phases
54 (add-after 'unpack 'remote-dangling-symlink
55 (lambda _
56 (substitute* '("man/netconfig.5"
57 "man/getnetconfig.3t"
58 "man/getnetpath.3t"
59 "man/rpc.3t"
60 "src/getnetconfig.c"
61 "tirpc/netconfig.h")
62 (("/etc/netconfig") (string-append %output "/etc/netconfig")))
63
64 ;; Remove the dangling symlinks since it breaks the
65 ;; 'patch-source-shebangs' file tree traversal.
66 (delete-file "INSTALL")
67 #t)))))
68 (inputs `(("mit-krb5" ,mit-krb5)))
69 (home-page "https://sourceforge.net/projects/libtirpc/")
70 (synopsis "Transport-independent Sun/ONC RPC implementation")
71 (description
72 "This package provides a library that implements the Sun/ONC RPC (remote
73 procedure calls) protocol in a transport-independent manner. It supports both
74 IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
75 (license bsd-3)))
76
77 (define-public libtirpc/hurd
78 (package
79 (inherit libtirpc)
80 (name "libtirpc-hurd")
81 (source (origin (inherit (package-source libtirpc))
82 (patches (search-patches "libtirpc-hurd.patch"
83 "libtirpc-hurd-client.patch"))))
84 (arguments
85 (substitute-keyword-arguments (package-arguments libtirpc)
86 ((#:configure-flags flags ''())
87 ;; When cross-building the target system's krb5-config should be used.
88 `(list (string-append "ac_cv_prog_KRB5_CONFIG="
89 (assoc-ref %build-inputs "mit-krb5")
90 "/bin/krb5-config")))))))
91
92 (define-public rpcbind
93 (package
94 (name "rpcbind")
95 (version "0.2.4")
96 (source
97 (origin
98 (method url-fetch)
99 (uri (string-append "mirror://sourceforge/" name "/" name "/"
100 version "/"
101 name "-" version ".tar.bz2"))
102 (patches (search-patches "rpcbind-CVE-2017-8779.patch"))
103 (sha256
104 (base32
105 "0rjc867mdacag4yqvs827wqhkh27135rp9asj06ixhf71m9rljh7"))))
106 (build-system gnu-build-system)
107 (arguments
108 `(#:configure-flags
109 `("--with-systemdsystemunitdir=no" "--enable-warmstarts")))
110 (inputs
111 `(("libnsl" ,libnsl)
112 ("libtirpc" ,libtirpc)))
113 (native-inputs
114 `(("pkg-config" ,pkg-config)))
115 (home-page "http://rpcbind.sourceforge.net/")
116 (synopsis "Server to convert RPC program numbers into universal addresses")
117 (description
118 "@command{Rpcbind} is a server that converts RPC program numbers into
119 universal addresses.")
120 (license bsd-3)))
121
122 (define-public rpcsvc-proto
123 (package
124 (name "rpcsvc-proto")
125 (version "1.4")
126 (home-page "https://github.com/thkukuk/rpcsvc-proto")
127 (source (origin
128 (method url-fetch)
129 (uri (string-append home-page "/releases/download/v" version
130 "/rpcsvc-proto-" version ".tar.xz"))
131 (sha256
132 (base32
133 "0i93wbpw5dk2gf5v4a5hq6frh814wzgjydh7saj28wlgbpqdaja1"))))
134 (build-system gnu-build-system)
135 (synopsis "RPCSVC protocol definitions")
136 (description
137 "This package provides @code{rpcsvc} @file{protocol.x} files and headers
138 that are not included with the @code{libtirpc} package. Additionally it
139 contains @command{rpcgen}, which is used to produce header files and sources
140 from the protocol files.")
141 (license bsd-3)))
142
143 (define-public libnsl
144 (package
145 (name "libnsl")
146 (version "1.2.0")
147 (source (origin
148 (method git-fetch)
149 (uri (git-reference
150 (url "https://github.com/thkukuk/libnsl")
151 (commit (string-append "v" version))))
152 (file-name (git-file-name name version))
153 (sha256
154 (base32
155 "1chzqhcgh0yia9js8mh92cmhyka7rh32ql6b3mgdk26n94dqzs8b"))))
156 (build-system gnu-build-system)
157 (arguments
158 `(#:configure-flags '("--disable-static")
159 #:phases (modify-phases %standard-phases
160 (add-before 'bootstrap 'gettextize
161 (lambda _
162 ;; Regenerate the bundled Makefile.in.in to avoid a
163 ;; "gettext infrastructure mismatch" because the
164 ;; existing version was generated by an older gettext.
165 (invoke "gettextize" "-f"))))))
166 (native-inputs
167 `(("autoconf" ,autoconf)
168 ("automake" ,automake)
169 ("gettext" ,gettext-minimal)
170 ("libtool" ,libtool)
171 ("pkg-config" ,pkg-config)))
172 (inputs
173 `(("libtirpc" ,libtirpc)))
174 (synopsis "Public client interface for NIS(YP) and NIS+")
175 (description "Libnsl is the public client interface for the Network
176 Information Service / Yellow Pages (NIS/YP) and NIS+. It includes IPv6 support.
177 This library was part of glibc < 2.26, but is now distributed separately.")
178 (home-page "https://github.com/thkukuk/libnsl")
179 ;; The package is distributed under the LGPL 2.1. Some files in
180 ;; 'src/nisplus/' are LGPL 2.1+, and some files in 'src/rpcsvc/' are BSD-3.
181 (license lgpl2.1)))