gnu: slepc: Set origin file-name.
[jackhill/guix/guix.git] / gnu / packages / jrnl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <address@hidden>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages jrnl)
22 #:use-module (guix packages)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (guix build-system python)
26 #:use-module (gnu packages python))
27
28 (define-public jrnl
29 (package
30 (name "jrnl")
31 (version "1.9.7")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "https://github.com/maebert/jrnl/archive/"
36 version ".tar.gz"))
37 (file-name (string-append name "-" version ".tar.gz"))
38 (sha256
39 (base32
40 "0mfq7hhw5np2dj9jlxpyyk2cg9i0xgz2brb894d928hczszy97bq"))))
41 (build-system python-build-system)
42 (native-inputs
43 `(("behave" ,behave)))
44 (inputs
45 `(("python" ,python)
46 ("python-keyring" ,python-keyring)
47 ("python-pycrypto" ,python-pycrypto)
48 ("python-pytz" ,python-pytz)
49 ("python-tzlocal" ,python-tzlocal)
50 ("python-six" ,python-six)
51 ("python-dateutil" , python-dateutil-2)
52 ("python-parsedatetime" ,python-parsedatetime)))
53 (home-page "http://maebert.github.io/jrnl/")
54 (synopsis "Personal journal application")
55 (description
56 "Jrnl is a command line journal application that stores your journal in a
57 plain text file. Optionally, your journal can be encrypted using 256-bit AES
58 encryption.")
59 (license x11)))