gnu: slepc: Set origin file-name.
[jackhill/guix/guix.git] / gnu / packages / asciidoc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages asciidoc)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (gnu packages python)
24 #:use-module (guix build-system gnu)
25 #:autoload (gnu packages zip) (unzip))
26
27 (define-public asciidoc
28 (package
29 (name "asciidoc")
30 (version "8.6.9")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://sourceforge/asciidoc/asciidoc-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "1w71nk527lq504njmaf0vzr93pgahkgzzxzglrq6bay8cw2rvnvq"))))
38 (build-system gnu-build-system)
39 (arguments '(#:tests? #f)) ; no 'check' target
40 (inputs `(("python" ,python-2)))
41 (home-page "http://www.methods.co.nz/asciidoc/")
42 (synopsis "Text-based document generation system")
43 (description
44 "AsciiDoc is a text document format for writing notes, documentation,
45 articles, books, ebooks, slideshows, web pages, man pages and blogs.
46 AsciiDoc files can be translated to many formats including HTML, PDF,
47 EPUB, man page.
48
49 AsciiDoc is highly configurable: both the AsciiDoc source file syntax and
50 the backend output markups (which can be almost any type of SGML/XML
51 markup) can be customized and extended by the user.")
52 (license gpl2+)))