Merge remote-tracking branch 'origin/master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / rdf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2015, 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages rdf)
23 #:use-module ((guix licenses)
24 #:select (non-copyleft asl2.0 isc gpl2 lgpl2.1 lgpl2.1+ lgpl3+))
25 #:use-module (guix packages)
26 #:use-module (guix git-download)
27 #:use-module (guix download)
28 #:use-module (guix build-system cmake)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix build-system python)
31 #:use-module (guix build-system waf)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages autotools)
34 #:use-module (gnu packages boost)
35 #:use-module (gnu packages check)
36 #:use-module (gnu packages compression)
37 #:use-module (gnu packages curl)
38 #:use-module (gnu packages cyrus-sasl)
39 #:use-module (gnu packages documentation)
40 #:use-module (gnu packages dbm)
41 #:use-module (gnu packages gnupg)
42 #:use-module (gnu packages linux)
43 #:use-module (gnu packages multiprecision)
44 #:use-module (gnu packages pcre)
45 #:use-module (gnu packages perl)
46 #:use-module (gnu packages pkg-config)
47 #:use-module (gnu packages python)
48 #:use-module (gnu packages python-web)
49 #:use-module (gnu packages python-xyz)
50 #:use-module (gnu packages qt)
51 #:use-module (gnu packages time)
52 #:use-module (gnu packages tls)
53 #:use-module (gnu packages xml))
54
55 (define-public raptor2
56 (package
57 (name "raptor2")
58 (version "2.0.15")
59 (source (origin
60 (method url-fetch)
61 (uri (string-append "http://download.librdf.org/source/" name
62 "-" version ".tar.gz"))
63 (patches
64 (search-patches "raptor2-heap-overflow.patch"))
65 (sha256
66 (base32
67 "1vc02im4mpc28zxzgli68k6j0dakh0k3s389bm436yvqajxg19xd"))))
68 (build-system gnu-build-system)
69 (inputs
70 `(("curl" ,curl)
71 ("libxml2" ,libxml2)
72 ("libxslt" ,libxslt)
73 ("zlib" ,zlib)))
74 (arguments
75 `(#:parallel-tests? #f))
76 (home-page "http://librdf.org/raptor/")
77 (synopsis "RDF syntax library")
78 (description "Raptor is a C library providing a set of parsers and
79 serialisers that generate Resource Description Framework (RDF) triples
80 by parsing syntaxes or serialise the triples into a syntax. The supported
81 parsing syntaxes are RDF/XML, N-Quads, N-Triples 1.0 and 1.1, TRiG,
82 Turtle 2008 and 2013, RDFa 1.0 and 1.1, RSS tag soup including all versions
83 of RSS, Atom 1.0 and 0.3, GRDDL and microformats for HTML, XHTML and
84 XML. The serialising syntaxes are RDF/XML (regular, abbreviated, XMP),
85 Turtle 2013, N-Quads, N-Triples 1.1, Atom 1.0, RSS 1.0, GraphViz DOT,
86 HTML and JSON.")
87 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
88
89 (define-public clucene
90 (package
91 (name "clucene")
92 (version "2.3.3.4")
93 (source (origin
94 (method url-fetch)
95 (uri (string-append "mirror://sourceforge/clucene/"
96 "clucene-core-unstable/2.3/clucene-core-"
97 version ".tar.gz"))
98 (sha256
99 (base32
100 "1arffdwivig88kkx685pldr784njm0249k0rb1f1plwavlrw9zfx"))
101 (patches (search-patches "clucene-pkgconfig.patch"
102 "clucene-contribs-lib.patch"))))
103 (build-system cmake-build-system)
104 (inputs
105 `(("boost" ,boost) ; could also use bundled copy
106 ("zlib" ,zlib)))
107 (arguments
108 `(#:test-target "cl_test"
109 #:configure-flags '("-DBUILD_CONTRIBS_LIB=ON")
110 #:tests? #f)) ; Tests do not compile, as TestIndexSearcher.cpp uses
111 ; undeclared usleep. After fixing this, one needs to run
112 ; "make test" in addition to "make cl_test", then
113 ; SimpleTest fails.
114 ; Notice that the library appears to be unmaintained
115 ; with no reaction to bug reports.
116 (home-page "http://clucene.sourceforge.net/")
117 (synopsis "C text indexing and searching library")
118 (description "CLucene is a high-performance, scalable, cross platform,
119 full-featured indexing and searching API. It is a port of the very popular
120 Java Lucene text search engine API to C++.")
121 (license lgpl2.1)))
122
123 (define-public lucene++
124 (package
125 (name "lucene++")
126 (version "3.0.7")
127 (source (origin
128 (method git-fetch)
129 (uri (git-reference
130 (url "https://github.com/luceneplusplus/LucenePlusPlus")
131 (commit (string-append "rel_" version))))
132 (file-name (git-file-name name version))
133 (sha256
134 (base32
135 "06b37fly6l27zc6kbm93f6khfsv61w792j8xihfagpcm9cfz2zi1"))))
136 (build-system cmake-build-system)
137 (arguments
138 `(#:configure-flags
139 ;; CXX_FLAGS suggested in a closed issue on github:
140 ;; https://github.com/luceneplusplus/LucenePlusPlus/issues/100
141 (list "-Wno-dev" "-DCMAKE_CXX_FLAGS=-DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT"
142 ;; Install in lib64 break rpath
143 "-DCMAKE_INSTALL_LIBDIR:PATH=lib")))
144 (native-inputs
145 `(("pkg-config" ,pkg-config)))
146 (inputs
147 `(("boost" ,boost)))
148 (home-page "https://github.com/luceneplusplus/LucenePlusPlus")
149 (synopsis "Text search engine")
150 (description "Lucene++ is an up to date C++ port of the popular Java
151 Lucene library, a high-performance, full-featured text search engine.")
152 (license (list asl2.0 lgpl3+)))); either asl or lgpl.
153
154 (define-public lrdf
155 (package
156 (name "lrdf")
157 (version "0.6.1")
158 (source (origin
159 (method git-fetch)
160 (uri (git-reference
161 (url "https://github.com/swh/LRDF.git")
162 (commit (string-append "v" version))))
163 (file-name (git-file-name name version))
164 (sha256
165 (base32
166 "00wzkfb8y0aqd519ypz067cq099dpc89w69zw8ln39vl6f9x2pd4"))))
167 (build-system gnu-build-system)
168 (arguments
169 '(#:phases
170 (modify-phases %standard-phases
171 (add-after 'unpack 'remove-out-of-tree-references
172 (lambda _
173 ;; remove_test depends on an out-of-tree RDF file
174 (substitute* "examples/Makefile.am"
175 (("instances_test remove_test") "instances_test")
176 (("\\$\\(TESTS\\) remove_test") "$(TESTS)"))
177 #t))
178 ;; The default bootstrap phase executes autogen.sh, which fails.
179 (replace 'bootstrap
180 (lambda _ (invoke "autoreconf" "-vif") #t)))))
181 (inputs
182 `(("raptor" ,raptor2)
183 ("cyrus-sasl" ,cyrus-sasl)
184 ("zlib" ,zlib)))
185 (native-inputs
186 `(("autoconf" ,autoconf)
187 ("automake" ,automake)
188 ("libtool" ,libtool)
189 ("pkg-config" ,pkg-config)))
190 (home-page "https://github.com/swh/LRDF")
191 (synopsis "Lightweight RDF library for accessing LADSPA plugin metadata")
192 (description
193 "LRDF is a library to make it easy to manipulate RDF files describing
194 LADSPA plugins. It can also be used for general RDF manipulation. It can
195 read RDF/XLM and N3 files and export N3 files, and it also has a light
196 taxonomic inference capability.")
197 (license gpl2)))
198
199 (define-public rasqal
200 (package
201 (name "rasqal")
202 (version "0.9.33")
203 (source (origin
204 (method url-fetch)
205 (uri (string-append "http://download.librdf.org/source/" name
206 "-" version ".tar.gz"))
207 (sha256
208 (base32
209 "0z6rrwn4jsagvarg8d5zf0j352kjgi33py39jqd29gbhcnncj939"))))
210 (build-system gnu-build-system)
211 (native-inputs
212 `(("perl" ,perl)
213 ("perl-xml-dom" ,perl-xml-dom) ; for the tests
214 ("pkg-config" ,pkg-config)))
215 (inputs
216 `(("libgcrypt" ,libgcrypt)
217 ("libxml2" ,libxml2)
218 ("mpfr" ,mpfr)
219 ("pcre" ,pcre)
220 ("util-linux" ,util-linux "lib")))
221 (propagated-inputs
222 `(("raptor2" ,raptor2))) ; stipulated by rasqal.pc
223 (arguments
224 `(#:parallel-tests? #f
225 ; test failure reported upstream, see
226 ; http://bugs.librdf.org/mantis/view.php?id=571
227 #:tests? #f))
228 (home-page "http://librdf.org/rasqal/")
229 (synopsis "RDF query library")
230 (description "Rasqal is a C library that handles Resource Description
231 Framework (RDF) query language syntaxes, query construction and execution
232 of queries returning results as bindings, boolean, RDF graphs/triples or
233 syntaxes. The supported query languages are SPARQL Query 1.0,
234 SPARQL Query 1.1, SPARQL Update 1.1 (no executing) and the Experimental
235 SPARQL extensions (LAQRS). Rasqal can write binding query results in the
236 SPARQL XML, SPARQL JSON, CSV, TSV, HTML, ASCII tables, RDF/XML and
237 Turtle/N3 and read them in SPARQL XML, RDF/XML and Turtle/N3.")
238 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
239
240 (define-public redland
241 (package
242 (name "redland")
243 (version "1.0.17")
244 (source (origin
245 (method url-fetch)
246 (uri (string-append "http://download.librdf.org/source/" name
247 "-" version ".tar.gz"))
248 (sha256
249 (base32
250 "109n0kp39p966dpiasad2bb7q66rwbcb9avjvimw28chnpvlf66y"))))
251 (build-system gnu-build-system)
252 (native-inputs
253 `(("perl" ,perl) ; needed for installation
254 ("pkg-config" ,pkg-config)))
255 (propagated-inputs
256 `(("rasqal" ,rasqal))) ; in Requires.private field of .pc
257 (inputs
258 `(("bdb" ,bdb)))
259 (home-page "http://librdf.org/")
260 (synopsis "RDF library")
261 (description "The Redland RDF Library (librdf) provides the RDF API
262 and triple stores.")
263 (license lgpl2.1+))) ; or any choice of gpl2+ or asl2.0
264
265 (define-public serd
266 (package
267 (name "serd")
268 (version "0.30.0")
269 (source (origin
270 (method url-fetch)
271 (uri (string-append "https://download.drobilla.net/serd-"
272 version ".tar.bz2"))
273 (sha256
274 (base32
275 "1yyfyvc6kwagi5w43ljp1bbjdvdpmgpds74lmjxycm91bkx0xyvf"))))
276 (build-system waf-build-system)
277 (arguments
278 `(#:tests? #f ; no check target
279 #:phases
280 (modify-phases %standard-phases
281 (add-before
282 'configure 'set-ldflags
283 (lambda* (#:key outputs #:allow-other-keys)
284 (setenv "LDFLAGS"
285 (string-append "-Wl,-rpath="
286 (assoc-ref outputs "out") "/lib"))
287 #t)))))
288 (home-page "https://drobilla.net/software/serd/")
289 (synopsis "Library for RDF syntax supporting Turtle and NTriples")
290 (description
291 "Serd is a lightweight C library for RDF syntax which supports reading
292 and writing Turtle and NTriples. Serd is not intended to be a swiss-army
293 knife of RDF syntax, but rather is suited to resource limited or performance
294 critical applications (e.g. converting many gigabytes of NTriples to Turtle),
295 or situations where a simple reader/writer with minimal dependencies is
296 ideal (e.g. in LV2 implementations or embedded applications).")
297 (license isc)))
298
299 (define-public sord
300 (package
301 (name "sord")
302 (version "0.16.4")
303 (source (origin
304 (method url-fetch)
305 (uri (string-append "https://download.drobilla.net/sord-"
306 version ".tar.bz2"))
307 (sha256
308 (base32
309 "1mwh4qvp9q4vgrgg5bz9sgjhxscncrylf2b06h0q55ddwzs9hndi"))))
310 (build-system waf-build-system)
311 (arguments
312 `(#:tests? #f ; no check target
313 #:phases
314 (modify-phases %standard-phases
315 (add-before
316 'configure 'set-ldflags
317 (lambda* (#:key outputs #:allow-other-keys)
318 (setenv "LDFLAGS"
319 (string-append "-Wl,-rpath="
320 (assoc-ref outputs "out") "/lib"))
321 #t)))))
322 (native-inputs
323 `(("pkg-config" ,pkg-config)))
324 (propagated-inputs
325 `(("serd" ,serd))) ; required by sord-0.pc
326 (home-page "https://drobilla.net/software/sord/")
327 (synopsis "C library for storing RDF data in memory")
328 (description
329 "Sord is a lightweight C library for storing RDF data in memory.")
330 (license isc)))
331
332 (define-public python-rdflib
333 (package
334 (name "python-rdflib")
335 (version "4.2.2")
336 (source
337 (origin
338 (method url-fetch)
339 (uri (pypi-uri "rdflib" version))
340 (sha256
341 (base32
342 "0398c714znnhaa2x7v51b269hk20iz073knq2mvmqp2ma92z27fs"))))
343 (build-system python-build-system)
344 (arguments
345 '(;; FIXME: Three test failures. Should be fixed next release.
346 #:tests? #f))
347 ;; #:phases
348 ;; (modify-phases %standard-phases
349 ;; (replace 'check
350 ;; (lambda _
351 ;; ;; Run tests from the build directory so python3 only
352 ;; ;; sees the installed 2to3 version.
353 ;; (invoke "nosetests" "--where=./build/src"))))))
354 (native-inputs
355 `(("python-nose" ,python-nose)))
356 (propagated-inputs
357 `(("python-html5lib" ,python-html5lib)
358 ("python-isodate" ,python-isodate)
359 ("python-pyparsing" ,python-pyparsing)))
360 (home-page "https://github.com/RDFLib/rdflib")
361 (synopsis "Python RDF library")
362 (description
363 "RDFLib is a Python library for working with RDF, a simple yet
364 powerful language for representing information.")
365 (license (non-copyleft "file://LICENSE"
366 "See LICENSE in the distribution."))))
367
368 (define-public python2-rdflib
369 (package-with-python2 python-rdflib))