gnu: Add libtmcg.
[jackhill/guix/guix.git] / gnu / packages / openpgp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Justus Winter <justus@sequoia-pgp.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages openpgp)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (gnu packages gnupg)
25 #:use-module (gnu packages multiprecision))
26
27 (define-public libtmcg
28 (package
29 (name "libtmcg")
30 (version "1.3.18")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://savannah/libtmcg/libTMCG-" version
34 ".tar.gz"))
35 (sha256
36 (base32
37 "179b5jx3mqs9hgsj8cfwk6x8qib60kw9szk9fkz6s1gl3v83mnyx"))))
38 (build-system gnu-build-system)
39 (arguments '(#:configure-flags '("--enable-silent-rules")))
40 (inputs `(("gmp" ,gmp)
41 ("libgcrypt" ,libgcrypt)))
42 (synopsis
43 "C++ library for creating secure and fair online card games")
44 (description
45 "The library provides a sort of useful classes, algorithms, and
46 high-level protocols to support an application programmer in writing such
47 software. The most remarkable feature is the absence of a trusted third
48 party (TTP), i.e. neither a central game server nor trusted hardware
49 components are necessary.
50
51 The corresponding cryptographic problem, actually called Mental Poker, has
52 been studied since 1979 (Shamir, Rivest, and Adleman) by many authors.
53 LibTMCG provides the first practical implementation of such protocols.")
54 (home-page "https://www.nongnu.org/libtmcg/")
55 (license license:gpl2+)))