gnu: emacs-ox-pandoc: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / ncurses.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014, 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2016 Nikita <nikita@n0.is>
6 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
8 ;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
9 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages ncurses)
28 #:use-module (gnu packages)
29 #:use-module (guix licenses)
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix build-system perl)
34 #:use-module (gnu packages)
35 #:use-module (gnu packages perl)
36 #:use-module (gnu packages pkg-config)
37 #:use-module (gnu packages swig)
38 #:use-module (gnu packages linux)
39 #:use-module (guix utils))
40
41 (define-public ncurses
42 (package
43 (name "ncurses")
44 (version "6.2")
45 (source (origin
46 (method url-fetch)
47 (uri (string-append "mirror://gnu/ncurses/ncurses-"
48 (car (string-split version #\-))
49 ".tar.gz"))
50 (sha256
51 (base32
52 "17bcm2z1rdx5gmzj5fb8cp7f28aw5b4g2z4qvvqg3yg0fq66wc1h"))))
53 (build-system gnu-build-system)
54 (outputs '("out"
55 "doc")) ;1 MiB of man pages
56 (arguments
57 (let ((patch-makefile-phase
58 '(lambda _
59 (for-each patch-makefile-SHELL
60 (find-files "." "Makefile.in"))
61 #t))
62 (configure-phase
63 ;; The 'configure' script does not understand '--docdir', so we must
64 ;; override that and use '--mandir' instead.
65 '(lambda* (#:key build target outputs configure-flags
66 #:allow-other-keys)
67 (let ((out (assoc-ref outputs "out"))
68 (doc (assoc-ref outputs "doc")))
69 (apply invoke "./configure"
70 (string-append "SHELL=" (which "sh"))
71 (string-append "--build=" build)
72 (string-append "--prefix=" out)
73 (string-append "--mandir=" doc "/share/man")
74 (if target
75 (cons (string-append "--host=" target)
76 configure-flags)
77 configure-flags))
78 #t)))
79 (apply-rollup-patch-phase
80 ;; Ncurses distributes "stable" patchsets to be applied on top
81 ;; of the release tarball. These are only available as shell
82 ;; scripts(!) so we decompress and apply them in a phase.
83 ;; See <https://invisible-mirror.net/archives/ncurses/6.1/README>.
84 '(lambda* (#:key inputs native-inputs #:allow-other-keys)
85 (copy-file (assoc-ref (or native-inputs inputs) "rollup-patch")
86 (string-append (getcwd) "/rollup-patch.sh.bz2"))
87 (invoke "bzip2" "-d" "rollup-patch.sh.bz2")
88 (invoke "sh" "rollup-patch.sh")))
89 (remove-shebang-phase
90 '(lambda _
91 ;; To avoid retaining a reference to the bootstrap Bash via the
92 ;; shebang of the 'ncursesw6-config' script, simply remove that
93 ;; shebang: it'll work just as well without it. Likewise, do not
94 ;; retain a reference to the "doc" output.
95 (substitute* "misc/ncurses-config.in"
96 (("#!@SHELL@")
97 "# No shebang here, use /bin/sh!\n")
98 (("@SHELL@ \\$0")
99 "$0")
100 (("mandir=.*$")
101 "mandir=share/man"))
102 #t))
103 (post-install-phase
104 `(lambda* (#:key outputs #:allow-other-keys)
105 (let ((out (assoc-ref outputs "out")))
106 ;; When building a wide-character (Unicode) build, create backward
107 ;; compatibility links from the the "normal" libraries to the
108 ;; wide-character ones (e.g. libncurses.so to libncursesw.so).
109 ,@(if (target-mingw?)
110 '( ;; TODO: create .la files to link to the .dll?
111 (with-directory-excursion (string-append out "/bin")
112 (for-each
113 (lambda (lib)
114 (define lib.dll
115 (string-append "lib" lib ".dll"))
116 (define libw6.dll
117 (string-append "lib" lib "w6.dll"))
118
119 (when (file-exists? libw6.dll)
120 (format #t "creating symlinks for `lib~a'~%" lib)
121 (symlink libw6.dll lib.dll)))
122 '("curses" "ncurses" "form" "panel" "menu"))))
123 '())
124 (with-directory-excursion (string-append out "/lib")
125 (for-each (lambda (lib)
126 (define libw.a
127 (string-append "lib" lib "w.a"))
128 (define lib.a
129 (string-append "lib" lib ".a"))
130
131 ,@(if (not (target-mingw?))
132 '((define libw.so.x
133 (string-append "lib" lib "w.so.6"))
134 (define lib.so.x
135 (string-append "lib" lib ".so.6"))
136 (define lib.so
137 (string-append "lib" lib ".so"))
138 (define packagew.pc
139 (string-append lib "w.pc"))
140 (define package.pc
141 (string-append lib ".pc")))
142 '())
143
144 (when (file-exists? libw.a)
145 (format #t "creating symlinks for `lib~a'~%" lib)
146 (symlink libw.a lib.a)
147 ,@(if (not (target-mingw?))
148 '((symlink libw.so.x lib.so.x)
149 (false-if-exception (delete-file lib.so))
150 (call-with-output-file lib.so
151 (lambda (p)
152 (format p "INPUT (-l~aw)~%" lib)))
153 (with-directory-excursion "pkgconfig"
154 (format #t "creating symlink for `~a'~%"
155 package.pc)
156 (when (file-exists? packagew.pc)
157 (symlink packagew.pc package.pc))))
158 '())))
159 '("curses" "ncurses" "form" "panel" "menu")))
160 #t))))
161 `(#:configure-flags
162 ,(cons*
163 'quasiquote
164 `(("--with-shared" "--without-debug" "--enable-widec"
165
166 "--enable-pc-files"
167 ,(list 'unquote '(string-append "--with-pkg-config-libdir="
168 (assoc-ref %outputs "out")
169 "/lib/pkgconfig"))
170
171 ;; By default headers land in an `ncursesw' subdir, which is not
172 ;; what users expect.
173 ,(list 'unquote '(string-append "--includedir=" (assoc-ref %outputs "out")
174 "/include"))
175 "--enable-overwrite" ;really honor --includedir
176
177 ;; Make sure programs like 'tic', 'reset', and 'clear' have a
178 ;; correct RUNPATH.
179 ,(list 'unquote '(string-append "LDFLAGS=-Wl,-rpath=" (assoc-ref %outputs "out")
180 "/lib"))
181
182 ;; Starting from ncurses 6.1, "make install" runs "install -s"
183 ;; by default, which doesn't work for cross-compiled binaries
184 ;; because it invokes 'strip' instead of 'TRIPLET-strip'. Work
185 ;; around this.
186 ,@(if (%current-target-system) '("--disable-stripping") '())
187
188 ;; Do not assume a default search path in ld, even if it is only to
189 ;; filter it out in ncurses-config. Mainly because otherwise it ends
190 ;; up using the libdir from binutils, which makes little sense and
191 ;; causes an unnecessary runtime dependency.
192 "cf_cv_ld_searchpath=/no-ld-searchpath"
193
194 ;; MinGW: Use term-driver created for the MinGW port.
195 ,@(if (target-mingw?) '("--enable-term-driver") '()))))
196 #:tests? #f ; no "check" target
197 #:phases (modify-phases %standard-phases
198 (replace 'configure ,configure-phase)
199 (add-after 'install 'post-install
200 ,post-install-phase)
201 (add-before 'configure 'patch-makefile-SHELL
202 ,patch-makefile-phase)
203 (add-before 'patch-source-shebangs 'remove-unneeded-shebang
204 ,remove-shebang-phase)))))
205 (native-inputs
206 `(,@(if (%current-target-system)
207 `(("self" ,this-package)) ;for `tic'
208 '())
209 ("pkg-config" ,pkg-config)))
210 (native-search-paths
211 (list (search-path-specification
212 (variable "TERMINFO_DIRS")
213 (files '("share/terminfo")))))
214 (synopsis "Terminal emulation (termcap, terminfo) library")
215 (description
216 "GNU Ncurses is a library which provides capabilities to write text to
217 a terminal in a terminal-independent manner. It supports pads and color as
218 well as multiple highlights and forms characters. It is typically used to
219 implement user interfaces for command-line applications. The accompanying
220 ncursesw library provides wide character support.")
221 (license x11)
222 (home-page "https://www.gnu.org/software/ncurses/")))
223
224 (define-public ncurses/gpm
225 (package/inherit ncurses
226 (name "ncurses-with-gpm")
227 (arguments
228 (substitute-keyword-arguments (package-arguments ncurses)
229 ((#:configure-flags cf)
230 `(cons (string-append "--with-gpm="
231 (assoc-ref %build-inputs "gpm")
232 "/lib/libgpm.so.2")
233 ,cf))))
234 (inputs
235 `(("gpm" ,gpm)))))
236
237 (define-public dialog
238 (package
239 (name "dialog")
240 (version "1.3-20200228")
241 (source (origin
242 (method url-fetch)
243 (uri (string-append
244 "https://invisible-mirror.net/archives/dialog/dialog-"
245 version ".tgz"))
246 (sha256
247 (base32
248 "1n8zbkigbzxw8gkw7qhzwzdyc7rbc7a0jcfy9z8ib7pf3qfw9y4z"))))
249 (build-system gnu-build-system)
250 (arguments
251 `(#:tests? #f)) ; no test suite
252 (inputs
253 `(("ncurses" ,ncurses)))
254 (synopsis "Curses widgets")
255 (description "Dialog is a script-interpreter which provides a set of
256 curses widgets, such as dialog boxes.")
257 (home-page "https://invisible-island.net/dialog/dialog.html")
258 ;; Includes the gpl3 file "config.sub" from Automake.
259 (license (list lgpl2.1 gpl3))))
260
261 (define-public perl-curses
262 (package
263 (name "perl-curses")
264 (version "1.36")
265 (source
266 (origin
267 (method url-fetch)
268 (uri (string-append "mirror://cpan/authors/id/G/GI/GIRAFFED/"
269 "Curses-" version ".tar.gz"))
270 (sha256
271 (base32
272 "0r6xd9wr0c25rr28zixhqipak575zqsfb7r7f2693i9il1dpj554"))))
273 (build-system perl-build-system)
274 (inputs
275 `(("ncurses" ,ncurses)))
276 (arguments
277 `(#:make-maker-flags (list "PANELS" "MENUS")
278 #:phases
279 (modify-phases %standard-phases
280 (add-before
281 'configure 'set-curses-ldflags
282 (lambda* (#:key inputs #:allow-other-keys)
283 (let* ((ncurses (assoc-ref inputs "ncurses"))
284 (include (string-append ncurses "/include"))
285 (lib (string-append ncurses "/lib")))
286 (setenv "CURSES_LIBTYPE" "ncurses")
287 (setenv "CURSES_CFLAGS" (string-append "-I" include))
288 (setenv "CURSES_PANEL_CFLAGS" (string-append "-I" include))
289 (setenv "CURSES_MENU_CFLAGS" (string-append "-I" include))
290 (setenv "CURSES_FORM_CFLAGS" (string-append "-I" include))
291 (setenv "CURSES_LDFLAGS" (string-append "-L" lib " -lncurses"))
292 (setenv "CURSES_PANEL_LDFLAGS" (string-append "-L" lib " -lpanel"))
293 (setenv "CURSES_MENU_LDFLAGS" (string-append "-L" lib " -lmenu"))
294 (setenv "CURSES_FORM_LDFLAGS" (string-append "-L" lib " -lform"))
295 #t))))))
296 (home-page "https://metacpan.org/release/Curses")
297 (synopsis "Terminal screen handling and optimization")
298 (description
299 "@code{Curses} is the interface between Perl and the curses library
300 of your system.")
301 (license perl-license)))
302
303 (define-public stfl
304 (package
305 (name "stfl")
306 (version "0.24")
307 (source
308 (origin
309 (method url-fetch)
310 (uri (string-append "http://www.clifford.at/stfl/stfl-"
311 version ".tar.gz"))
312 (sha256
313 (base32
314 "1460d5lc780p3q38l3wc9jfr2a7zlyrcra0li65aynj738cam9yl"))))
315 (build-system gnu-build-system)
316 (arguments
317 '(#:tests? #f ; no test target
318 #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out")))
319 #:phases
320 (modify-phases %standard-phases
321 (delete 'configure) ; there is no configure script
322 ;; in our ncurses, the headers are in /include
323 (add-before 'build 'patch-ncursesw
324 (lambda _
325 (substitute* "stfl_internals.h"
326 (("ncursesw/") ""))
327 #t))
328 (add-after 'install 'install-missing-symlink
329 (lambda* (#:key outputs #:allow-other-keys)
330 (let* ((out (assoc-ref outputs "out"))
331 (lib (string-append out "/lib")))
332 ;; Some programs look for libstfl.so.0.
333 (symlink "libstfl.so" (string-append lib "/libstfl.so.0"))))))))
334 (inputs `(("ncurses" ,ncurses)))
335 (native-inputs `(("swig" ,swig)))
336 (home-page "http://www.clifford.at/stfl/")
337 (synopsis "Structured terminal forms library")
338 (description "Stfl is a library which implements a curses-based widget
339 set for text terminals.")
340 (license lgpl3+)))