gnu: openssh: Update to 7.7p1.
[jackhill/guix/guix.git] / gnu / packages / ssh.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
7 ;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
9 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
11 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
12 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages ssh)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages autotools)
32 #:use-module (gnu packages base)
33 #:autoload (gnu packages boost) (boost)
34 #:use-module (gnu packages compression)
35 #:use-module (gnu packages crypto)
36 #:use-module (gnu packages elf)
37 #:use-module (gnu packages gnupg)
38 #:use-module (gnu packages gperf)
39 #:use-module (gnu packages groff)
40 #:use-module (gnu packages guile)
41 #:use-module (gnu packages linux)
42 #:use-module (gnu packages logging)
43 #:use-module (gnu packages m4)
44 #:use-module (gnu packages multiprecision)
45 #:use-module (gnu packages ncurses)
46 #:use-module (gnu packages nettle)
47 #:use-module (gnu packages kerberos)
48 #:use-module (gnu packages perl)
49 #:use-module (gnu packages pkg-config)
50 #:use-module (gnu packages popt)
51 #:autoload (gnu packages protobuf) (protobuf)
52 #:use-module (gnu packages readline)
53 #:use-module (gnu packages texinfo)
54 #:use-module (gnu packages tls)
55 #:use-module (gnu packages xorg)
56 #:use-module (guix build-system cmake)
57 #:use-module (guix build-system gnu)
58 #:use-module (guix download)
59 #:use-module (guix git-download)
60 #:use-module ((guix licenses) #:prefix license:)
61 #:use-module (guix packages)
62 #:use-module (srfi srfi-1))
63
64 (define-public libssh
65 ;; This commit from the 'v0-7' branch contains 7 memory-management-related
66 ;; bug fixes that we'd rather have.
67 (let ((commit "239d0f75b5f909174c2ef7fb08d23bcfa6b20ba0")
68 (revision "0"))
69 (package
70 (name "libssh")
71 (version (git-version "0.7.5" revision commit))
72 (source (origin
73 (method git-fetch)
74 (uri (git-reference
75 (url "https://git.libssh.org/projects/libssh.git")
76 (commit commit)))
77 (sha256
78 (base32
79 "01w72w1jsgs9ilj3n1gp6qkmdxr9n74i5h2nipi3x1vzm7bv8na1"))
80 (patches (search-patches "libssh-hostname-parser-bug.patch"))
81 (file-name (git-file-name name version))))
82 (build-system cmake-build-system)
83 (outputs '("out" "debug"))
84 (arguments
85 '(#:configure-flags '("-DWITH_GCRYPT=ON")
86
87 ;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
88 #:tests? #f))
89 (inputs `(("zlib" ,zlib)
90 ("libgcrypt" ,libgcrypt)))
91 (synopsis "SSH client library")
92 (description
93 "libssh is a C library implementing the SSHv2 and SSHv1 protocol for
94 client and server implementations. With libssh, you can remotely execute
95 programs, transfer files, and use a secure and transparent tunnel for your
96 remote applications.")
97 (home-page "https://www.libssh.org")
98 (license license:lgpl2.1+))))
99
100 (define-public libssh2
101 (package
102 (name "libssh2")
103 (version "1.8.0")
104 (source (origin
105 (method url-fetch)
106 (uri (string-append
107 "https://www.libssh2.org/download/libssh2-"
108 version ".tar.gz"))
109 (sha256
110 (base32
111 "1m3n8spv79qhjq4yi0wgly5s5rc8783jb1pyra9bkx1md0plxwrr"))
112 (patches
113 (search-patches "libssh2-fix-build-failure-with-gcrypt.patch"))))
114 (build-system gnu-build-system)
115 ;; The installed libssh2.pc file does not include paths to libgcrypt and
116 ;; zlib libraries, so we need to propagate the inputs.
117 (propagated-inputs `(("libgcrypt" ,libgcrypt)
118 ("zlib" ,zlib)))
119 (arguments '(#:configure-flags `("--with-libgcrypt")
120 #:phases (modify-phases %standard-phases
121 (add-before 'configure 'autoreconf
122 (lambda _
123 (zero? (system* "autoreconf" "-v")))))))
124 (native-inputs `(("autoconf" ,autoconf)
125 ("automake" ,automake)))
126 (synopsis "Client-side C library implementing the SSH2 protocol")
127 (description
128 "libssh2 is a library intended to allow software developers access to
129 the SSH-2 protocol in an easy-to-use self-contained package. It can be built
130 into an application to perform many different tasks when communicating with
131 a server that supports the SSH-2 protocol.")
132 (license license:bsd-3)
133 (home-page "http://www.libssh2.org/")))
134
135 (define-public openssh
136 (package
137 (name "openssh")
138 (version "7.7p1")
139 (source (origin
140 (method url-fetch)
141 (uri (string-append "mirror://openbsd/OpenSSH/portable/"
142 name "-" version ".tar.gz"))
143 (sha256
144 (base32
145 "13vbbrvj3mmfhj83qyrg5c0ipr6bzw5s65dy4k8gr7p9hkkfffyp"))))
146 (build-system gnu-build-system)
147 (native-inputs `(("groff" ,groff)))
148 (inputs `(("openssl" ,openssl)
149 ("pam" ,linux-pam)
150 ("mit-krb5" ,mit-krb5)
151 ("zlib" ,zlib)
152 ("xauth" ,xauth))) ;for 'ssh -X' and 'ssh -Y'
153 (arguments
154 `(#:test-target "tests"
155 ;; Otherwise, the test scripts try to use a nonexistent directory and
156 ;; fail.
157 #:make-flags '("REGRESSTMP=\"$${BUILDDIR}/regress\"")
158 #:configure-flags `("--sysconfdir=/etc/ssh"
159
160 ;; Default value of 'PATH' used by sshd.
161 "--with-default-path=/run/current-system/profile/bin"
162
163 ;; configure needs to find krb5-config
164 ,(string-append "--with-kerberos5="
165 (assoc-ref %build-inputs "mit-krb5")
166 "/bin")
167
168 ;; Enable PAM support in sshd.
169 "--with-pam")
170
171 #:phases
172 (modify-phases %standard-phases
173 (add-after 'configure 'reset-/var/empty
174 (lambda* (#:key outputs #:allow-other-keys)
175 (let ((out (assoc-ref outputs "out")))
176 (substitute* "Makefile"
177 (("PRIVSEP_PATH=/var/empty")
178 (string-append "PRIVSEP_PATH=" out "/var/empty")))
179 #t)))
180 (add-before 'check 'patch-tests
181 (lambda _
182 ;; remove 't-exec' regress target which requires user 'sshd'
183 (substitute* "regress/Makefile"
184 (("^(REGRESS_TARGETS=.*) t-exec(.*)" all pre post)
185 (string-append pre post)))
186 #t))
187 (replace 'install
188 (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
189 ;; install without host keys and system configuration files
190 (and (zero? (apply system* "make" "install-nosysconf" make-flags))
191 (begin
192 (install-file "contrib/ssh-copy-id"
193 (string-append (assoc-ref outputs "out")
194 "/bin/"))
195 (chmod (string-append (assoc-ref outputs "out")
196 "/bin/ssh-copy-id") #o555)
197 (install-file "contrib/ssh-copy-id.1"
198 (string-append (assoc-ref outputs "out")
199 "/share/man/man1/"))
200 #t)))))))
201 (synopsis "Client and server for the secure shell (ssh) protocol")
202 (description
203 "The SSH2 protocol implemented in OpenSSH is standardised by the
204 IETF secsh working group and is specified in several RFCs and drafts.
205 It is composed of three layered components:
206
207 The transport layer provides algorithm negotiation and a key exchange.
208 The key exchange includes server authentication and results in a
209 cryptographically secured connection: it provides integrity, confidentiality
210 and optional compression.
211
212 The user authentication layer uses the established connection and relies on
213 the services provided by the transport layer. It provides several mechanisms
214 for user authentication. These include traditional password authentication
215 as well as public-key or host-based authentication mechanisms.
216
217 The connection layer multiplexes many different concurrent channels over the
218 authenticated connection and allows tunneling of login sessions and
219 TCP-forwarding. It provides a flow control service for these channels.
220 Additionally, various channel-specific options can be negotiated.")
221 (license (license:non-copyleft "file://LICENSE"
222 "See LICENSE in the distribution."))
223 (home-page "http://www.openssh.org/")))
224
225 (define-public guile-ssh
226 (package
227 (name "guile-ssh")
228 (version "0.11.2")
229 (home-page "https://github.com/artyom-poptsov/guile-ssh")
230 (source (origin
231 ;; ftp://memory-heap.org/software/guile-ssh/guile-ssh-VERSION.tar.gz
232 ;; exists, but the server appears to be too slow and unreliable.
233 ;; Also, using this URL allows the GitHub updater to work.
234 (method url-fetch)
235 (uri (string-append home-page "/archive/v"
236 version ".tar.gz"))
237 (file-name (string-append name "-" version ".tar.gz"))
238 (sha256
239 (base32
240 "1w0k5s09xj5xycb7lbp5b7rm0xncclms3jwl98lwj8fxwngi1s90"))))
241 (build-system gnu-build-system)
242 (outputs '("out" "debug"))
243 (arguments
244 '(#:phases (modify-phases %standard-phases
245 (add-after 'unpack 'autoreconf
246 (lambda* (#:key inputs #:allow-other-keys)
247 (zero? (system* "autoreconf" "-vfi"))))
248 (add-before 'build 'fix-libguile-ssh-file-name
249 (lambda* (#:key outputs #:allow-other-keys)
250 ;; Build and install libguile-ssh.so so that we can use
251 ;; its absolute file name in .scm files, before we build
252 ;; the .go files.
253 (and (zero? (system* "make" "install"
254 "-C" "libguile-ssh"
255 "-j" (number->string
256 (parallel-job-count))))
257 (let* ((out (assoc-ref outputs "out"))
258 (libdir (string-append out "/lib")))
259 (substitute* (find-files "." "\\.scm$")
260 (("\"libguile-ssh\"")
261 (string-append "\"" libdir "/libguile-ssh\"")))
262 #t)))))
263
264 ;; Tests are not parallel-safe.
265 #:parallel-tests? #f))
266 (native-inputs `(("autoconf" ,autoconf)
267 ("automake" ,automake)
268 ("libtool" ,libtool)
269 ("texinfo" ,texinfo)
270 ("pkg-config" ,pkg-config)
271 ("which" ,which)))
272 (inputs `(("guile" ,guile-2.2)
273 ("libssh" ,libssh)
274 ("libgcrypt" ,libgcrypt)))
275 (synopsis "Guile bindings to libssh")
276 (description
277 "Guile-SSH is a library that provides access to the SSH protocol for
278 programs written in GNU Guile interpreter. It is a wrapper to the underlying
279 libssh library.")
280 (license license:gpl3+)))
281
282 (define-public guile2.2-ssh
283 (deprecated-package "guile2.2-ssh" guile-ssh))
284
285 (define-public guile2.0-ssh
286 (package
287 (inherit guile-ssh)
288 (name "guile2.0-ssh")
289 (inputs `(("guile" ,guile-2.0)
290 ,@(alist-delete "guile" (package-inputs guile-ssh))))))
291
292 (define-public corkscrew
293 (package
294 (name "corkscrew")
295 (version "2.0")
296 (source
297 (origin
298 (method url-fetch)
299 ;; The agroman.net domain name expired on 2017-03-23, and the original
300 ;; "http://www.agroman.net/corkscrew/corkscrew-2.0.tar.gz" now returns
301 ;; bogus HTML. Perhaps it will yet return. Until then, use a mirror.
302 (uri (string-append "https://downloads.openwrt.org/sources/"
303 "corkscrew-" version ".tar.gz"))
304 (sha256 (base32
305 "1gmhas4va6gd70i2x2mpxpwpgww6413mji29mg282jms3jscn3qd"))))
306 (build-system gnu-build-system)
307 (arguments
308 ;; Replace configure phase as the ./configure script does not link
309 ;; CONFIG_SHELL and SHELL passed as parameters
310 '(#:phases
311 (modify-phases %standard-phases
312 (replace 'configure
313 (lambda* (#:key outputs inputs system build target
314 #:allow-other-keys #:rest args)
315 (let* ((configure (assoc-ref %standard-phases 'configure))
316 (prefix (assoc-ref outputs "out"))
317 (bash (which "bash"))
318 ;; Set --build and --host flags as the provided config.guess
319 ;; is not able to detect them
320 (flags `(,(string-append "--prefix=" prefix)
321 ,(string-append "--build=" build)
322 ,(string-append "--host=" (or target build)))))
323 (setenv "CONFIG_SHELL" bash)
324 (zero? (apply system* bash
325 (string-append "." "/configure")
326 flags)))))
327 (add-after 'install 'install-documentation
328 (lambda* (#:key outputs #:allow-other-keys)
329 (let* ((out (assoc-ref outputs "out"))
330 (doc (string-append out "/share/doc/corkscrew")))
331 (install-file "README" doc)
332 #t))))))
333 (home-page "http://www.agroman.net/corkscrew")
334 (synopsis "SSH tunneling through HTTP(S) proxies")
335 (description
336 "Corkscrew tunnels SSH connections through most HTTP and HTTPS proxies.
337 Proxy authentication is only supported through the plain-text HTTP basic
338 authentication scheme.")
339 (license license:gpl2+)))
340
341 (define-public mosh
342 (package
343 (name "mosh")
344 (version "1.3.2")
345 (source (origin
346 (method url-fetch)
347 (uri (string-append "https://mosh.org/mosh-" version ".tar.gz"))
348 (sha256
349 (base32
350 "05hjhlp6lk8yjcy59zywpf0r6s0h0b9zxq0lw66dh9x8vxrhaq6s"))))
351 (build-system gnu-build-system)
352 (arguments
353 '(#:phases
354 (modify-phases %standard-phases
355 (add-after 'install 'wrap
356 (lambda* (#:key outputs #:allow-other-keys)
357 ;; Make sure 'mosh' can find 'mosh-client' and
358 ;; 'mosh-server'.
359 (let* ((out (assoc-ref outputs "out"))
360 (bin (string-append out "/bin")))
361 (wrap-program (string-append bin "/mosh")
362 `("PATH" ":" prefix (,bin)))))))))
363 (native-inputs
364 `(("pkg-config" ,pkg-config)))
365 (inputs
366 `(("openssl" ,openssl)
367 ("perl" ,perl)
368 ("perl-io-tty" ,perl-io-tty)
369 ("zlib" ,zlib)
370 ("ncurses" ,ncurses)
371 ("protobuf" ,protobuf)
372 ("boost-headers" ,boost)))
373 (home-page "https://mosh.org/")
374 (synopsis "Remote shell tolerant to intermittent connectivity")
375 (description
376 "Remote terminal application that allows roaming, supports intermittent
377 connectivity, and provides intelligent local echo and line editing of user
378 keystrokes. Mosh is a replacement for SSH. It's more robust and responsive,
379 especially over Wi-Fi, cellular, and long-distance links.")
380 (license license:gpl3+)))
381
382 (define-public et
383 (package
384 (name "et")
385 (version "3.1.0")
386 (source
387 (origin
388 (method url-fetch)
389 (uri (string-append
390 "https://github.com/MisterTea/EternalTCP/archive/et-v"
391 version ".tar.gz"))
392 (sha256
393 (base32 "1n2w2kqbshdmbb0gz4yizyw9gqfls6qm2dnwx1d9c2hz7hmi7521"))))
394 (build-system cmake-build-system)
395 (arguments `(#:tests? #f))
396 (native-inputs
397 `(("pkg-config" ,pkg-config)))
398 (inputs `(("glog" ,glog)
399 ("gflags" ,gflags)
400 ("libsodium" ,libsodium)
401 ("protobuf" ,protobuf)))
402 (synopsis "Remote shell that automatically reconnects")
403 (description
404 "Eternal Terminal (ET) is a remote shell that automatically reconnects
405 without interrupting the session. Unlike SSH sessions, ET sessions will
406 survive even network outages and IP changes. ET uses a custom protocol over
407 TCP, not the SSH protocol.")
408 (home-page "https://mistertea.github.io/EternalTCP/")
409 (license license:asl2.0)))
410
411 (define-public dropbear
412 (package
413 (name "dropbear")
414 (version "2018.76")
415 (source (origin
416 (method url-fetch)
417 (uri (string-append
418 "https://matt.ucc.asn.au/" name "/releases/"
419 name "-" version ".tar.bz2"))
420 (sha256
421 (base32
422 "0rgavbzw7jrs5wslxm0dnwx2m409yzxd9hazd92r7kx8xikr3yzj"))))
423 (build-system gnu-build-system)
424 (arguments `(#:tests? #f)) ; there is no "make check" or anything similar
425 (inputs `(("zlib" ,zlib)))
426 (synopsis "Small SSH server and client")
427 (description "Dropbear is a relatively small SSH server and
428 client. It runs on a variety of POSIX-based platforms. Dropbear is
429 particularly useful for embedded systems, such as wireless routers.")
430 (home-page "https://matt.ucc.asn.au/dropbear/dropbear.html")
431 (license (license:x11-style "" "See file LICENSE."))))
432
433 (define-public liboop
434 (package
435 (name "liboop")
436 (version "1.0")
437 (source
438 (origin
439 (method url-fetch)
440 (uri (string-append "http://download.ofb.net/liboop/liboop-"
441 version ".tar.gz"))
442 (sha256
443 (base32
444 "0z6rlalhvfca64jpvksppc9bdhs7jwhiw4y35g5ibvh91xp3rn1l"))
445 (patches (search-patches "liboop-mips64-deplibs-fix.patch"))))
446 (build-system gnu-build-system)
447 (home-page "http://www.lysator.liu.se/liboop/")
448 (synopsis "Event loop library")
449 (description "Liboop is a low-level event loop management library for
450 POSIX-based operating systems. It supports the development of modular,
451 multiplexed applications which may respond to events from several sources. It
452 replaces the \"select() loop\" and allows the registration of event handlers
453 for file and network I/O, timers and signals. Since processes use these
454 mechanisms for almost all external communication, liboop can be used as the
455 basis for almost any application.")
456 (license license:lgpl2.1+)))
457
458 (define-public lsh
459 (package
460 (name "lsh")
461 (version "2.1")
462 (source (origin
463 (method url-fetch)
464 (uri (string-append "mirror://gnu/lsh/lsh-"
465 version ".tar.gz"))
466 (sha256
467 (base32
468 "1qqjy9zfzgny0rkb27c8c7dfsylvb6n0ld8h3an2r83pmaqr9gwb"))
469 (modules '((guix build utils)))
470 (snippet
471 '(begin
472 (substitute* "src/testsuite/functions.sh"
473 (("localhost")
474 ;; Avoid host name lookups since they don't work in
475 ;; chroot builds.
476 "127.0.0.1")
477 (("set -e")
478 ;; Make tests more verbose.
479 "set -e\nset -x"))
480
481 (substitute* (find-files "src/testsuite" "-test$")
482 (("localhost") "127.0.0.1"))
483
484 (substitute* "src/testsuite/login-auth-test"
485 (("/bin/cat") "cat"))))))
486 (build-system gnu-build-system)
487 (native-inputs
488 `(("m4" ,m4)
489 ("guile" ,guile-2.0)
490 ("gperf" ,gperf)
491 ("psmisc" ,psmisc))) ; for `killall'
492 (inputs
493 `(("nettle" ,nettle-2)
494 ("linux-pam" ,linux-pam)
495
496 ;; 'rl.c' uses the 'CPPFunction' type, which is no longer in
497 ;; Readline 6.3.
498 ("readline" ,readline-6.2)
499
500 ("liboop" ,liboop)
501 ("zlib" ,zlib)
502 ("gmp" ,gmp)
503
504 ;; The server (lshd) invokes xauth when X11 forwarding is requested.
505 ;; This adds 24 MiB (or 27%) to the closure of lsh.
506 ("xauth" ,xauth)))
507 (arguments
508 '(;; Skip the `configure' test that checks whether /dev/ptmx &
509 ;; co. work as expected, because it relies on impurities (for
510 ;; instance, /dev/pts may be unavailable in chroots.)
511 #:configure-flags '("lsh_cv_sys_unix98_ptys=yes"
512
513 ;; Use glibc's argp rather than the bundled one.
514 "--with-system-argp"
515
516 ;; 'lsh_argp.h' checks HAVE_ARGP_PARSE but nothing
517 ;; defines it.
518 "CPPFLAGS=-DHAVE_ARGP_PARSE")
519
520 ;; FIXME: Tests won't run in a chroot, presumably because
521 ;; /etc/profile is missing, and thus clients get an empty $PATH
522 ;; and nothing works.
523 #:tests? #f
524
525 #:phases
526 (modify-phases %standard-phases
527 (add-before 'configure 'pre-configure
528 (lambda* (#:key inputs #:allow-other-keys)
529 (let* ((nettle (assoc-ref inputs "nettle"))
530 (sexp-conv (string-append nettle "/bin/sexp-conv")))
531 ;; Remove argp from the list of sub-directories; we don't want
532 ;; to build it, really.
533 (substitute* "src/Makefile.in"
534 (("^SUBDIRS = argp")
535 "SUBDIRS ="))
536
537 ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place
538 ;; by default.
539 (substitute* "src/environ.h.in"
540 (("^#define PATH_SEXP_CONV.*")
541 (string-append "#define PATH_SEXP_CONV \""
542 sexp-conv "\"\n")))
543
544 ;; Same for the 'lsh-authorize' script.
545 (substitute* "src/lsh-authorize"
546 (("=sexp-conv")
547 (string-append "=" sexp-conv)))
548
549 ;; Tell lshd where 'xauth' lives. Another option would be to
550 ;; hardcode "/run/current-system/profile/bin/xauth", thereby
551 ;; reducing the closure size, but that wouldn't work on foreign
552 ;; distros.
553 (with-fluids ((%default-port-encoding "ISO-8859-1"))
554 (substitute* "src/server_x11.c"
555 (("define XAUTH_PROGRAM.*")
556 (string-append "define XAUTH_PROGRAM \""
557 (assoc-ref inputs "xauth")
558 "/bin/xauth\"\n")))))
559
560 ;; Tests rely on $USER being set.
561 (setenv "USER" "guix"))))))
562 (home-page "http://www.lysator.liu.se/~nisse/lsh/")
563 (synopsis "GNU implementation of the Secure Shell (ssh) protocols")
564 (description
565 "GNU lsh is a free implementation of the SSH version 2 protocol. It is
566 used to create a secure line of communication between two computers,
567 providing shell access to the server system from the client. It provides
568 both the server daemon and the client application, as well as tools for
569 manipulating key files.")
570 (license license:gpl2+)))
571
572 (define-public sshpass
573 (package
574 (name "sshpass")
575 (version "1.06")
576 (synopsis "Non-interactive password authentication with SSH")
577 (home-page "https://sourceforge.net/projects/sshpass/")
578 (source
579 (origin
580 (method url-fetch)
581 (uri (string-append "mirror://sourceforge/sshpass/sshpass/"
582 version "/sshpass-" version ".tar.gz"))
583 (sha256
584 (base32
585 "0q7fblaczb7kwbsz0gdy9267z0sllzgmf0c7z5c9mf88wv74ycn6"))))
586 (build-system gnu-build-system)
587 (description "sshpass is a tool for non-interactivly performing password
588 authentication with SSH's so-called @dfn{interactive keyboard password
589 authentication}.")
590 (license license:gpl2+)))
591
592 (define-public autossh
593 (package
594 (name "autossh")
595 (version "1.4f")
596 (source
597 (origin
598 (method url-fetch)
599 (uri (string-append
600 "http://www.harding.motd.ca/autossh/autossh-"
601 version ".tgz"))
602 (sha256
603 (base32 "1wpqwa2872nqgqbhnb6nnkrlzpdawd5k69gh1qp68354pvhyawh1"))))
604 (build-system gnu-build-system)
605 (arguments `(#:tests? #f)) ; There is no "make check" or anything similar
606 (inputs `(("openssh" ,openssh)))
607 (synopsis "Automatically restart SSH sessions and tunnels")
608 (description "autossh is a program to start a copy of @command{ssh} and
609 monitor it, restarting it as necessary should it die or stop passing traffic.")
610 (home-page "http://www.harding.motd.ca/autossh/")
611 (license
612 ;; Why point to a source file? Well, all the individual files have a
613 ;; copy of this license in their headers, but there's no separate file
614 ;; with that information.
615 (license:non-copyleft "file://autossh.c"))))
616
617 (define-public pdsh
618 (package
619 (name "pdsh")
620 (version "2.33")
621 (source
622 (origin
623 (method url-fetch)
624 (uri (string-append "https://github.com/chaos/pdsh/"
625 "releases/download/pdsh-" version
626 "/pdsh-" version ".tar.gz"))
627 (file-name (string-append name "-" version ".tar.gz"))
628 (sha256
629 (base32 "0bwlkl9inj66iwvafg00pi3sk9n673phdi0kcc59y9nn55s0hs3k"))))
630 (build-system gnu-build-system)
631 (arguments
632 `(#:configure-flags
633 (list "--with-ssh")
634 #:phases
635 (modify-phases %standard-phases
636 (add-after 'unpack 'patch-/bin/sh
637 (lambda _
638 (substitute* '("tests/t0006-pdcp.sh"
639 "tests/t0004-module-loading.sh"
640 "tests/t2001-ssh.sh"
641 "tests/t1003-slurm.sh"
642 "tests/t6036-long-output-lines.sh"
643 "tests/aggregate-results.sh"
644 "tests/t2000-exec.sh"
645 "tests/t0002-internal.sh"
646 "tests/t1002-dshgroup.sh"
647 "tests/t5000-dshbak.sh"
648 "tests/t0001-basic.sh"
649 "tests/t0005-rcmd_type-and-user.sh"
650 "tests/test-lib.sh"
651 "tests/t2002-mrsh.sh"
652 "tests/t0003-wcoll.sh"
653 "tests/test-modules/pcptest.c")
654 (("/bin/sh") (which "bash")))
655 #t))
656 (add-after 'unpack 'patch-tests
657 (lambda _
658 (substitute* "tests/t6036-long-output-lines.sh"
659 (("which") (which "which")))
660 #t)))))
661 (inputs
662 `(("openssh" ,openssh)
663 ("mit-krb5" ,mit-krb5)
664 ("perl" ,perl)))
665 (native-inputs
666 `(("which" ,which)))
667 (home-page "https://github.com/chaos/pdsh")
668 (synopsis "Parallel distributed shell")
669 (description "Pdsh is a an efficient, multithreaded remote shell client
670 which executes commands on multiple remote hosts in parallel. Pdsh implements
671 dynamically loadable modules for extended functionality such as new remote
672 shell services and remote host selection.")
673 (license license:gpl2+)))