gnu: Restore copyright header.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
4 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
5 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages kde)
24 #:use-module (guix build-system cmake)
25 #:use-module (guix download)
26 #:use-module (guix git-download)
27 #:use-module ((guix licenses) #:prefix license:)
28 #:use-module (guix packages)
29 #:use-module (guix utils)
30 #:use-module (gnu packages algebra)
31 #:use-module (gnu packages apr)
32 #:use-module (gnu packages boost)
33 #:use-module (gnu packages compression)
34 #:use-module (gnu packages curl)
35 #:use-module (gnu packages documentation)
36 #:use-module (gnu packages gettext)
37 #:use-module (gnu packages ghostscript)
38 #:use-module (gnu packages gl)
39 #:use-module (gnu packages gnome)
40 #:use-module (gnu packages graphics)
41 #:use-module (gnu packages image)
42 #:use-module (gnu packages kde-frameworks)
43 #:use-module (gnu packages kde-plasma)
44 #:use-module (gnu packages llvm)
45 #:use-module (gnu packages maths)
46 #:use-module (gnu packages pdf)
47 #:use-module (gnu packages perl)
48 #:use-module (gnu packages photo)
49 #:use-module (gnu packages pkg-config)
50 #:use-module (gnu packages tls)
51 #:use-module (gnu packages qt)
52 #:use-module (gnu packages version-control)
53 #:use-module (gnu packages video)
54 #:use-module (gnu packages xorg))
55
56 (define-public kdenlive
57 (let ((version "18.08.1"))
58 (package
59 (name "kdenlive")
60 (version version)
61 (source
62 (origin
63 (method git-fetch)
64 (uri (git-reference
65 (url "git://anongit.kde.org/kdenlive.git")
66 (commit (string-append "v" version))))
67 (file-name (string-append name "-" version "-checkout"))
68 (sha256
69 (base32
70 "0ifnaclsz7w08mc485i3j1kkcpd1m8q5qamckrfwc375ac13xf4g"))))
71 (build-system cmake-build-system)
72 (native-inputs
73 `(("extra-cmake-modules" ,extra-cmake-modules)
74 ("qttools" ,qttools)))
75 (propagated-inputs
76 `(("mlt" ,mlt)))
77 (inputs
78 `(("shared-mime-info" ,shared-mime-info)
79 ("frei0r-plugins" ,frei0r-plugins)
80 ("qtbase" ,qtbase)
81 ("qtscript" ,qtscript)
82 ("qtsvg" ,qtsvg)
83 ("kparts" ,kparts)
84 ("knotifications" ,knotifications)
85 ("karchive" ,karchive)
86 ("kdbusaddons" ,kdbusaddons)
87 ("kcrash" ,kcrash)
88 ("kguiaddons" ,kguiaddons)
89 ("knewstuff" ,knewstuff)
90 ("knotifyconfig" ,knotifyconfig)
91 ("kfilemetadata" ,kfilemetadata)
92 ("kdoctools" ,kdoctools)
93 ("kdeclarative" ,kdeclarative)
94 ("qtdeclarative" ,qtdeclarative)
95 ("qtquickcontrols" ,qtquickcontrols)
96 ("kiconthemes" ,kiconthemes)
97 ("qtgraphicaleffects" ,qtgraphicaleffects)
98 ("kplotting" ,kplotting)))
99 (arguments
100 `(#:phases
101 (modify-phases %standard-phases
102 (add-after 'install 'wrap-executable
103 (lambda* (#:key inputs outputs #:allow-other-keys)
104 (let* ((out (assoc-ref outputs "out"))
105 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
106 (qtbase (assoc-ref inputs "qtbase"))
107 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
108 (frei0r (assoc-ref inputs "frei0r-plugins"))
109 (qml "/lib/qt5/qml"))
110 (wrap-program (string-append out "/bin/kdenlive")
111 `("QT_PLUGIN_PATH" ":" prefix
112 ,(map (lambda (label)
113 (string-append (assoc-ref inputs label)
114 "/lib/qt5/plugins/"))
115 '("qtbase" "qtsvg")))
116 `("FREI0R_PATH" ":" =
117 (,(string-append frei0r "/lib/frei0r-1/")))
118 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
119 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
120 `("QML2_IMPORT_PATH" ":" prefix
121 (,(string-append qtquickcontrols qml)
122 ,(string-append qtdeclarative qml)))))
123 #t)))))
124 (home-page "https://kdenlive.org")
125 (synopsis "Non-linear video editor")
126 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
127
128 Non-linear video editing is much more powerful than beginner's (linear)
129 editors, hence it requires a bit more organization before starting. However,
130 it is not reserved to specialists and can be used for small personal
131 projects.")
132 (license license:gpl2+))))
133
134 (define-public kdevelop
135 (package
136 (name "kdevelop")
137 (version "5.1.2")
138 (source
139 (origin
140 (method url-fetch)
141 (uri (string-append "mirror://kde/stable/kdevelop"
142 "/" version "/src/kdevelop-"
143 version ".tar.xz"))
144 (sha256
145 (base32
146 "1iqaq0ilijjigqb34v5wq9in6bnjs0p9cmgbygjmy53xhh3yhm5g"))))
147 (build-system cmake-build-system)
148 (native-inputs
149 `(("extra-cmake-modules" ,extra-cmake-modules)
150 ("pkg-config" ,pkg-config)
151 ("qttools" ,qttools)))
152 (inputs
153 `(("kdevplatform" ,kdevplatform)
154 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
155 ("qtbase" ,qtbase)
156 ("qtdeclarative" ,qtdeclarative)
157 ("qtquickcontrols" ,qtquickcontrols)
158 ("qtwebkit" ,qtwebkit)
159 ("karchive" ,karchive)
160 ("kcmutils" ,kcmutils)
161 ("kconfig" ,kconfig)
162 ("kdeclarative" ,kdeclarative)
163 ("kdoctools" ,kdoctools)
164 ("kguiaddons" ,kguiaddons)
165 ("ki18n" ,ki18n)
166 ("kio" ,kio)
167 ("kiconthemes" ,kiconthemes)
168 ("kitemmodels" ,kitemmodels)
169 ("kitemviews" ,kitemviews)
170 ("kjobwidgets" ,kjobwidgets)
171 ("knotifyconfig" ,knotifyconfig)
172 ("knotifications" ,knotifications)
173 ("kparts" ,kparts)
174 ("kcrash" ,kcrash)
175 ("knewstuff" ,knewstuff)
176 ("krunner" ,krunner)
177 ("kxmlgui" ,kxmlgui)
178 ("libksysguard" ,libksysguard)
179 ("threadweaver" ,threadweaver)
180 ("ktexteditor" ,ktexteditor)
181 ("kwindowsystem" ,kwindowsystem)
182 ("plasma" ,plasma-framework)
183 ("grantlee" ,grantlee)
184 ("libepoxy" ,libepoxy)
185 ("clang" ,clang)
186 ("shared-mime-info" ,shared-mime-info)))
187 (arguments
188 `(#:phases
189 (modify-phases %standard-phases
190 (delete 'check) ;; there are some issues with the test suite
191 (add-after 'install 'wrap-executable
192 (lambda* (#:key inputs outputs #:allow-other-keys)
193 (let* ((out (assoc-ref outputs "out"))
194 (kdevplatform (assoc-ref inputs "kdevplatform"))
195 (kio (assoc-ref inputs "kio"))
196 (kcmutils (assoc-ref inputs "kcmutils"))
197 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
198 (qtbase (assoc-ref inputs "qtbase"))
199 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
200 (qml "/qml"))
201 (wrap-program (string-append out "/bin/kdevelop")
202 `("XDG_DATA_DIRS" ":" prefix
203 ,(map (lambda (s) (string-append s "/share"))
204 (list out kdevplatform kcmutils)))
205 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
206 (,(string-append qtbase "/plugins/platforms")))
207 `("QT_PLUGIN_PATH" ":" prefix
208 ,(map (lambda (s) (string-append s "/lib/plugins"))
209 (list out kdevplatform kio)))
210 `("QML2_IMPORT_PATH" ":" prefix
211 (,(string-append qtquickcontrols qml)
212 ,(string-append qtdeclarative qml))))))))))
213 (home-page "https://kdevelop.org")
214 (synopsis "IDE for C, C++, Python, Javascript and PHP")
215 (description "The KDevelop IDE provides semantic syntax highlighting, as
216 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
217 JavaScript, Python and PHP. It also integrates with a debugger, different
218 build systems (CMake, QMake, custom Makefiles) and version control
219 software (Git, Subversion, Mercurial, CVS and Bazaar).")
220 (license license:lgpl2.1+)))
221
222 (define-public kdevelop-pg-qt
223 (package
224 (name "kdevelop-pg-qt")
225 (version "2.0.0")
226 (source
227 (origin
228 (method url-fetch)
229 (uri (string-append "https://github.com/KDE/kdevelop-pg-qt/archive/v"
230 version ".tar.gz"))
231 (file-name (string-append name "-" version ".tar.gz"))
232 (sha256
233 (base32 "1av8plqz7hyhrd07avnmn6ryslqlarmxn0pw7swzvb6ddiqp59j4"))))
234 (native-inputs
235 `(("extra-cmake-modules" ,extra-cmake-modules)))
236 (inputs
237 `(("qtbase" ,qtbase)))
238 (build-system cmake-build-system)
239 (home-page "https://kde.org")
240 (synopsis "Parser generator library for KDevplatform")
241 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
242 for some KDevelop language plugins (Ruby, PHP, CSS...).")
243 (license license:lgpl2.0+)))
244
245 (define-public kdevplatform
246 (package
247 (name "kdevplatform")
248 (version "5.1.2")
249 (source (origin
250 (method url-fetch)
251 (uri (string-append "mirror://kde/stable/kdevelop"
252 "/" version "/src/kdevplatform-"
253 version ".tar.xz"))
254 (sha256
255 (base32
256 "0jk6g1kiqpyjy8pca0236b9944gxqnymqv8ny6m8nrraannxs8p6"))))
257 (build-system cmake-build-system)
258 (native-inputs
259 `(("extra-cmake-modules" ,extra-cmake-modules)
260 ("pkg-config" ,pkg-config)))
261 (inputs
262 `(("apr" ,apr)
263 ("apr-util" ,apr-util)
264 ("boost" ,boost)
265 ("karchive" ,karchive)
266 ("kconfigwidgets" ,kconfigwidgets)
267 ("kcmutils" ,kcmutils)
268 ("kiconthemes" ,kiconthemes)
269 ("kdeclarative" ,kdeclarative)
270 ("kdoctools" ,kdoctools)
271 ("kguiaddons" ,kguiaddons)
272 ("kinit" ,kinit)
273 ("kitemmodels" ,kitemmodels)
274 ("knewstuff" ,knewstuff)
275 ("knotifications" ,knotifications)
276 ("knotifyconfig" ,knotifyconfig)
277 ("kwindowsystem" ,kwindowsystem)
278 ("kio" ,kio)
279 ("ki18n" ,ki18n)
280 ("kparts" ,kparts)
281 ("kservice" ,kservice)
282 ("grantlee" ,grantlee)
283 ("libkomparediff2" ,libkomparediff2)
284 ("sonnet" ,sonnet)
285 ("threadweaver" ,threadweaver)
286 ("ktexteditor" ,ktexteditor)
287 ("qtbase" ,qtbase)
288 ("qtdeclarative" ,qtdeclarative)
289 ("qtscript" ,qtscript)
290 ("qtwebkit" ,qtwebkit)
291 ("qtx11extras" ,qtx11extras)
292 ("plasma" ,plasma-framework)
293 ("subversion" ,subversion)
294 ("zlib" ,zlib)))
295 (arguments
296 `(#:phases
297 (modify-phases %standard-phases
298 (delete 'check)
299 (add-after 'install 'check ;; add-after 'install
300 (lambda* (#:key outputs #:allow-other-keys)
301 (let ((out (assoc-ref outputs "out")))
302 (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
303 (setenv "QT_PLUGIN_PATH"
304 (string-append out "/lib/plugins:"
305 (getenv "QT_PLUGIN_PATH")))
306 (setenv "XDG_DATA_DIRS"
307 (string-append out "/share:"
308 (getenv "XDG_DATA_DIRS")))
309 (zero?
310 (system* "ctest" "-R" ;; almost all tests require a display
311 "filteringstrategy|kdevvarlengtharray|kdevhash"))))))))
312 (home-page "https://github.com/KDE/kdevplatform")
313 (synopsis "Framework to build integrated development environments (IDEs)")
314 (description "KDevPlatform is the basis of KDevelop and contains some
315 plugins, as well as code to create plugins, or complete applications.")
316 (license license:gpl3+)))
317
318 (define-public krita
319 (package
320 (name "krita")
321 (version "4.1.7.101")
322 (source (origin
323 (method url-fetch)
324 (uri (string-append
325 "mirror://kde/stable/krita/"
326 (version-prefix version 3)
327 "/" name "-" version ".tar.gz"))
328 (sha256
329 (base32
330 "0pvghb17vj3y19wa1n1zfg3yl5206ir3y45znrgdgdw076m5pjav"))))
331 (build-system cmake-build-system)
332 (arguments
333 `(#:tests? #f
334 #:configure-flags
335 (list "-DBUILD_TESTING=OFF" "-DKDE4_BUILD_TESTS=OFF"
336 (string-append "-DWITH_FFTW3="
337 (assoc-ref %build-inputs "fftw"))
338 (string-append "-DWITH_GSL="
339 (assoc-ref %build-inputs "gsl"))
340 (string-append "-DWITH_LibRaw="
341 (assoc-ref %build-inputs "libraw"))
342 (string-append "-DWITH_TIFF="
343 (assoc-ref %build-inputs "libtiff"))
344 (string-append "-DCMAKE_CXX_FLAGS=-I"
345 (assoc-ref %build-inputs "ilmbase")
346 "/include/OpenEXR"))
347 #:phases
348 (modify-phases %standard-phases
349 ;; Ensure that icons are found at runtime.
350 ;; This works around <https://bugs.gnu.org/22138>.
351 (add-after 'install 'wrap-executable
352 (lambda* (#:key inputs outputs #:allow-other-keys)
353 (let ((out (assoc-ref outputs "out"))
354 (qt '("qtbase" "qtsvg")))
355 (wrap-program (string-append out "/bin/krita")
356 `("QT_PLUGIN_PATH" ":" prefix
357 ,(map (lambda (label)
358 (string-append (assoc-ref inputs label)
359 "/lib/qt5/plugins/"))
360 qt)))
361 #t))))))
362 (native-inputs
363 `(("curl" ,curl)
364 ("eigen" ,eigen)
365 ("extra-cmake-modules" ,extra-cmake-modules)
366 ("gettext-minimal" ,gettext-minimal)
367 ("kitemmodels" ,kitemmodels)
368 ("qwt" ,qwt)
369 ("vc" ,vc)))
370 (inputs
371 `(("qtbase" ,qtbase)
372 ("qtdeclarative" ,qtdeclarative)
373 ("qtmultimedia" ,qtmultimedia)
374 ("qtx11extras" ,qtx11extras)
375 ("qtsvg" ,qtsvg)
376 ("karchive" ,karchive)
377 ("kcompletion" ,kcompletion)
378 ("kconfig" ,kconfig)
379 ("kcoreaddons" ,kcoreaddons)
380 ("kcrash" ,kcrash)
381 ("kguiaddons" ,kguiaddons)
382 ("ki18n" ,ki18n)
383 ("kiconthemes" ,kiconthemes)
384 ("kio" ,kio)
385 ("kitemviews" ,kitemviews)
386 ("kwidgetsaddons" ,kwidgetsaddons)
387 ("kwindowsystem" ,kwindowsystem)
388 ("kxmlgui" ,kxmlgui)
389 ("boost" ,boost)
390 ("exiv2" ,exiv2)
391 ("lcms" ,lcms)
392 ("libpng" ,libpng)
393 ("libjpeg-turbo" ,libjpeg-turbo)
394 ("zlib" ,zlib)
395 ("libx11" ,libx11)
396 ("libxcb" ,libxcb)
397 ("libxi" ,libxi)
398 ("fftw" ,fftw)
399 ("gsl" ,gsl)
400 ("poppler-qt5" ,poppler-qt5)
401 ("libraw" ,libraw-0.18)
402 ("libtiff" ,libtiff)
403 ("perl" ,perl)
404 ("ilmbase" ,ilmbase)
405 ("openexr" ,openexr)))
406 (home-page "https://krita.org")
407 (synopsis "Digital painting application")
408 (description
409 "Krita is a professional painting tool designed for concept artists,
410 illustrators, matte and texture artists, and the VFX industry. Notable
411 features include brush stabilizers, brush engines and wrap-around mode.")
412 (license license:gpl2+)))
413
414 (define-public kholidays
415 (package
416 (name "kholidays")
417 (version "17.12.1")
418 (source
419 (origin
420 (method url-fetch)
421 (uri (string-append
422 "mirror://kde/stable/applications/" version "/src/"
423 name "-" version ".tar.xz"))
424 (sha256
425 (base32 "0595d7wbnz8kyq1bnivdrp20lwdp8ykvdll1fmb0fgm4q24z0cl8"))))
426 (build-system cmake-build-system)
427 (arguments
428 `(#:phases
429 (modify-phases %standard-phases
430 (add-before 'check 'check-setup
431 (lambda _
432 ;; blacklist a failing test function TODO: make it pass
433 (with-output-to-file "autotests/BLACKLIST"
434 (lambda _
435 (display "[testDefaultRegions]\n*\n")))
436 #t)))))
437 (native-inputs
438 `(("extra-cmake-modules" ,extra-cmake-modules)
439 ("qttools" ,qttools)))
440 (inputs
441 `(("qtbase" ,qtbase)
442 ("qtdeclarative" ,qtdeclarative)))
443 (home-page "https://cgit.kde.org/kholidays.git")
444 (synopsis "Library for regional holiday information")
445 (description "This library provides a C++ API that determines holiday and
446 other special events for a geographical region.")
447 (license license:lgpl2.0+)))
448
449 (define-public libkomparediff2
450 (package
451 (name "libkomparediff2")
452 (version "17.12.3")
453 (source
454 (origin
455 (method url-fetch)
456 (uri (string-append "mirror://kde/stable/applications"
457 "/" version "/src/" name "-" version ".tar.xz"))
458 (file-name (string-append name "-" version ".tar.gz"))
459 (sha256
460 (base32
461 "0w6p8lvm2rn7y4qz0x3s87lwh1758xnyhwkkkng55n8v9rpjjw7l"))))
462 (native-inputs
463 `(("extra-cmake-modules" ,extra-cmake-modules)
464 ("pkg-config" ,pkg-config)))
465 (inputs
466 `(("kcodecs" ,kcodecs)
467 ("kconfig" ,kconfig)
468 ("kcoreaddons" ,kcoreaddons)
469 ("ki18n" ,ki18n)
470 ("kio" ,kio)
471 ("kxmlgui" ,kxmlgui)
472 ("qtbase" ,qtbase)))
473 (build-system cmake-build-system)
474 (home-page "https://kde.org")
475 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
476 (description "Libkomparediff2 is a library to work with diffs and patches,
477 used in KDE development tools Kompare and KDevelop.")
478
479 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
480 ;; source archive
481 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
482
483 (define-public qca
484 (package
485 (name "qca")
486 (version "2.1.3")
487 (source
488 (origin
489 (method url-fetch)
490 (uri (string-append "mirror://kde/stable/qca/" version
491 "/src/qca-" version ".tar.xz"))
492 (sha256
493 (base32
494 "0lz3n652z208daxypdcxiybl0a9fnn6ida0q7fh5f42269mdhgq0"))))
495 (build-system cmake-build-system)
496 (native-inputs
497 `(("pkg-config" ,pkg-config)))
498 (inputs
499 `(("openssl" ,openssl)
500 ("qtbase" ,qtbase)))
501 (home-page "https://userbase.kde.org/QCA")
502 (synopsis "Libraries for the Qt Cryptographic Architecture")
503 (description "The Qt Cryptographic Architecture (QCA) provides a
504 straightforward and cross-platform API for a range of cryptographic features,
505 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
506 cards.")
507 (license license:lgpl2.1)))
508
509 (define-public snorenotify
510 (package
511 (name "snorenotify")
512 (version "0.7.0")
513 (source
514 (origin
515 (method url-fetch)
516 (uri (string-append "mirror://kde/stable/snorenotify/"
517 version "/src/snorenotify-" version ".tar.xz"))
518 (sha256
519 (base32
520 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
521 (build-system cmake-build-system)
522 (arguments
523 `(#:tests? #f)) ; both tests fail, require display
524 (inputs
525 `(("extra-cmake-modules" ,extra-cmake-modules)
526 ("qtbase" ,qtbase)
527 ("qttools" ,qttools)))
528 (home-page "https://techbase.kde.org/Projects/Snorenotify")
529 (synopsis "Qt notification framework")
530 (description "Snorenotify is a multi platform Qt notification framework.
531 Using a plugin system it is possible to create notifications with many
532 different notification systems.")
533 (license license:lgpl3)))