gnu: Add r-genomicinteractions.
[jackhill/guix/guix.git] / gnu / packages / bioconductor.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages bioconductor)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system r)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages bioinformatics)
28 #:use-module (gnu packages cran)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages graph)
31 #:use-module (gnu packages statistics))
32
33 (define-public r-bsgenome-dmelanogaster-ucsc-dm6
34 (package
35 (name "r-bsgenome-dmelanogaster-ucsc-dm6")
36 (version "1.4.1")
37 (source (origin
38 (method url-fetch)
39 ;; We cannot use bioconductor-uri here because this tarball is
40 ;; located under "data/annotation/" instead of "bioc/".
41 (uri (string-append "https://www.bioconductor.org/packages/"
42 "release/data/annotation/src/contrib/"
43 "BSgenome.Dmelanogaster.UCSC.dm6_"
44 version ".tar.gz"))
45 (sha256
46 (base32
47 "1bhj0rdgf7lspw4xby9y9mf7v7jxxz8001bc8vw8kf04rjsx6060"))))
48 (properties
49 `((upstream-name . "BSgenome.Dmelanogaster.UCSC.dm6")))
50 (build-system r-build-system)
51 ;; As this package provides little more than a very large data file it
52 ;; doesn't make sense to build substitutes.
53 (arguments `(#:substitutable? #f))
54 (propagated-inputs
55 `(("r-bsgenome" ,r-bsgenome)))
56 (home-page
57 "https://www.bioconductor.org/packages/BSgenome.Dmelanogaster.UCSC.dm6/")
58 (synopsis "Full genome sequences for Fly")
59 (description
60 "This package provides full genome sequences for Drosophila
61 melanogaster (Fly) as provided by UCSC (dm6) and stored in Biostrings
62 objects.")
63 (license license:artistic2.0)))
64
65 (define-public r-bsgenome-dmelanogaster-ucsc-dm3-masked
66 (package
67 (name "r-bsgenome-dmelanogaster-ucsc-dm3-masked")
68 (version "1.3.99")
69 (source (origin
70 (method url-fetch)
71 ;; We cannot use bioconductor-uri here because this tarball is
72 ;; located under "data/annotation/" instead of "bioc/".
73 (uri (string-append "http://www.bioconductor.org/packages/"
74 "release/data/annotation/src/contrib/"
75 "BSgenome.Dmelanogaster.UCSC.dm3.masked_"
76 version ".tar.gz"))
77 (sha256
78 (base32
79 "1756csb09f1br9rj1l3f08qyh4hlymdbd0cfn8x3fq39dn45m5ap"))))
80 (properties
81 `((upstream-name . "BSgenome.Dmelanogaster.UCSC.dm3.masked")))
82 (build-system r-build-system)
83 (propagated-inputs
84 `(("r-bsgenome" ,r-bsgenome)
85 ("r-bsgenome-dmelanogaster-ucsc-dm3"
86 ,r-bsgenome-dmelanogaster-ucsc-dm3)))
87 (home-page "https://www.bioconductor.org/packages/BSgenome.Dmelanogaster.UCSC.dm3.masked/")
88 (synopsis "Full masked genome sequences for Fly")
89 (description
90 "This package provides full masked genome sequences for Drosophila
91 melanogaster (Fly) as provided by UCSC (dm3, April 2006) and stored in
92 Biostrings objects. The sequences are the same as in
93 BSgenome.Dmelanogaster.UCSC.dm3, except that each of them has the 4 following
94 masks on top: (1) the mask of assembly gaps (AGAPS mask), (2) the mask of
95 intra-contig ambiguities (AMB mask), (3) the mask of repeats from
96 RepeatMasker (RM mask), and (4) the mask of repeats from Tandem Repeats
97 Finder (TRF mask). Only the AGAPS and AMB masks are \"active\" by default.")
98 (license license:artistic2.0)))
99
100 (define-public r-bsgenome-hsapiens-ucsc-hg19-masked
101 (package
102 (name "r-bsgenome-hsapiens-ucsc-hg19-masked")
103 (version "1.3.99")
104 (source (origin
105 (method url-fetch)
106 ;; We cannot use bioconductor-uri here because this tarball is
107 ;; located under "data/annotation/" instead of "bioc/".
108 (uri (string-append "http://www.bioconductor.org/packages/"
109 "release/data/annotation/src/contrib/"
110 "BSgenome.Hsapiens.UCSC.hg19.masked_"
111 version ".tar.gz"))
112 (sha256
113 (base32
114 "0452pyah0kv1vsrsjbrqw4k2rm8lc2vc771dzib45gnnfz86qxrr"))))
115 (properties
116 `((upstream-name . "BSgenome.Hsapiens.UCSC.hg19.masked")))
117 (build-system r-build-system)
118 (propagated-inputs
119 `(("r-bsgenome" ,r-bsgenome)
120 ("r-bsgenome-hsapiens-ucsc-hg19"
121 ,r-bsgenome-hsapiens-ucsc-hg19)))
122 (home-page "https://bioconductor.org/packages/BSgenome.Hsapiens.UCSC.hg19.masked/")
123 (synopsis "Full masked genome sequences for Homo sapiens")
124 (description
125 "This package provides full genome sequences for Homo sapiens (Human) as
126 provided by UCSC (hg19, Feb. 2009) and stored in Biostrings objects. The
127 sequences are the same as in BSgenome.Hsapiens.UCSC.hg19, except that each of
128 them has the 4 following masks on top: (1) the mask of assembly gaps (AGAPS
129 mask), (2) the mask of intra-contig ambiguities (AMB mask), (3) the mask of
130 repeats from RepeatMasker (RM mask), and (4) the mask of repeats from Tandem
131 Repeats Finder (TRF mask). Only the AGAPS and AMB masks are \"active\" by
132 default.")
133 (license license:artistic2.0)))
134
135 (define-public r-bsgenome-mmusculus-ucsc-mm9-masked
136 (package
137 (name "r-bsgenome-mmusculus-ucsc-mm9-masked")
138 (version "1.3.99")
139 (source (origin
140 (method url-fetch)
141 ;; We cannot use bioconductor-uri here because this tarball is
142 ;; located under "data/annotation/" instead of "bioc/".
143 (uri (string-append "http://www.bioconductor.org/packages/"
144 "release/data/annotation/src/contrib/"
145 "BSgenome.Mmusculus.UCSC.mm9.masked_"
146 version ".tar.gz"))
147 (sha256
148 (base32
149 "00bpbm3havqcxr4g63zhllsbpd9q6svgihks7qp7x73nm4gvq7fn"))))
150 (properties
151 `((upstream-name . "BSgenome.Mmusculus.UCSC.mm9.masked")))
152 (build-system r-build-system)
153 (propagated-inputs
154 `(("r-bsgenome" ,r-bsgenome)
155 ("r-bsgenome-mmusculus-ucsc-mm9"
156 ,r-bsgenome-mmusculus-ucsc-mm9)))
157 (home-page "http://bioconductor.org/packages/BSgenome.Mmusculus.UCSC.mm9.masked/")
158 (synopsis "Full masked genome sequences for Mouse")
159 (description
160 "This package provides full genome sequences for Mus musculus (Mouse) as
161 provided by UCSC (mm9, Jul. 2007) and stored in Biostrings objects. The
162 sequences are the same as in BSgenome.Mmusculus.UCSC.mm9, except that each of
163 them has the 4 following masks on top: (1) the mask of assembly gaps (AGAPS
164 mask), (2) the mask of intra-contig ambiguities (AMB mask), (3) the mask of
165 repeats from RepeatMasker (RM mask), and (4) the mask of repeats from Tandem
166 Repeats Finder (TRF mask). Only the AGAPS and AMB masks are \"active\" by
167 default." )
168 (license license:artistic2.0)))
169
170 (define-public r-hpar
171 (package
172 (name "r-hpar")
173 (version "1.22.2")
174 (source
175 (origin
176 (method url-fetch)
177 (uri (bioconductor-uri "hpar" version))
178 (sha256
179 (base32
180 "1b72hvzasf6q739gmx6jblbzzyq22l7crrkbbfkihv3v7s94g388"))))
181 (build-system r-build-system)
182 (home-page "https://bioconductor.org/packages/hpar/")
183 (synopsis "Human Protein Atlas in R")
184 (description "This package provides a simple interface to and data from
185 the Human Protein Atlas project.")
186 (license license:artistic2.0)))
187
188 (define-public r-regioner
189 (package
190 (name "r-regioner")
191 (version "1.12.0")
192 (source
193 (origin
194 (method url-fetch)
195 (uri (bioconductor-uri "regioneR" version))
196 (sha256
197 (base32
198 "09bzlaqdgy7wmzly3zc9y2da50d07mlixlnpaxdxpiwdk8qmhxsb"))))
199 (properties `((upstream-name . "regioneR")))
200 (build-system r-build-system)
201 (propagated-inputs
202 `(("r-memoise" ,r-memoise)
203 ("r-genomicranges" ,r-genomicranges)
204 ("r-bsgenome" ,r-bsgenome)
205 ("r-rtracklayer" ,r-rtracklayer)
206 ("r-genomeinfodb" ,r-genomeinfodb)
207 ("r-iranges" ,r-iranges)
208 ("r-s4vectors" ,r-s4vectors)))
209 (home-page "https://bioconductor.org/packages/regioneR/")
210 (synopsis "Association analysis of genomic regions")
211 (description "This package offers a statistical framework based on
212 customizable permutation tests to assess the association between genomic
213 region sets and other genomic features.")
214 (license license:artistic2.0)))
215
216 (define-public r-diffbind
217 (package
218 (name "r-diffbind")
219 (version "2.8.0")
220 (source
221 (origin
222 (method url-fetch)
223 (uri (bioconductor-uri "DiffBind" version))
224 (sha256
225 (base32
226 "1w1hybzd732ccg3q8zhirwfilq8sx3frv1x98zfyj3svzw98fish"))))
227 (properties `((upstream-name . "DiffBind")))
228 (build-system r-build-system)
229 (inputs
230 `(("zlib" ,zlib)))
231 (propagated-inputs
232 `(("r-amap" ,r-amap)
233 ("r-biocparallel" ,r-biocparallel)
234 ("r-deseq2" ,r-deseq2)
235 ("r-dplyr" ,r-dplyr)
236 ("r-edger" ,r-edger)
237 ("r-genomicalignments" ,r-genomicalignments)
238 ("r-genomicranges" ,r-genomicranges)
239 ("r-ggplot2" ,r-ggplot2)
240 ("r-ggrepel" ,r-ggrepel)
241 ("r-gplots" ,r-gplots)
242 ("r-iranges" ,r-iranges)
243 ("r-lattice" ,r-lattice)
244 ("r-limma" ,r-limma)
245 ("r-locfit" ,r-locfit)
246 ("r-rcolorbrewer" , r-rcolorbrewer)
247 ("r-rcpp" ,r-rcpp)
248 ("r-rsamtools" ,r-rsamtools)
249 ("r-s4vectors" ,r-s4vectors)
250 ("r-summarizedexperiment" ,r-summarizedexperiment)
251 ("r-systempiper" ,r-systempiper)
252 ("r-zlibbioc" ,r-zlibbioc)))
253 (home-page "http://bioconductor.org/packages/DiffBind")
254 (synopsis "Differential binding analysis of ChIP-Seq peak data")
255 (description
256 "This package computes differentially bound sites from multiple
257 ChIP-seq experiments using affinity (quantitative) data. Also enables
258 occupancy (overlap) analysis and plotting functions.")
259 (license license:artistic2.0)))
260
261 (define-public r-ripseeker
262 (package
263 (name "r-ripseeker")
264 (version "1.20.0")
265 (source
266 (origin
267 (method url-fetch)
268 (uri (bioconductor-uri "RIPSeeker" version))
269 (sha256
270 (base32
271 "0y9cvzqslfxj3z9mnp47mknff0pky2g5x8x1z1s5yjcx35q89xfi"))))
272 (properties `((upstream-name . "RIPSeeker")))
273 (build-system r-build-system)
274 (propagated-inputs
275 `(("r-s4vectors" ,r-s4vectors)
276 ("r-iranges" ,r-iranges)
277 ("r-genomicranges" ,r-genomicranges)
278 ("r-summarizedexperiment" ,r-summarizedexperiment)
279 ("r-rsamtools" ,r-rsamtools)
280 ("r-genomicalignments" ,r-genomicalignments)
281 ("r-rtracklayer" ,r-rtracklayer)))
282 (home-page "http://bioconductor.org/packages/RIPSeeker")
283 (synopsis
284 "Identifying protein-associated transcripts from RIP-seq experiments")
285 (description
286 "This package infers and discriminates RIP peaks from RIP-seq alignments
287 using two-state HMM with negative binomial emission probability. While
288 RIPSeeker is specifically tailored for RIP-seq data analysis, it also provides
289 a suite of bioinformatics tools integrated within this self-contained software
290 package comprehensively addressing issues ranging from post-alignments
291 processing to visualization and annotation.")
292 (license license:gpl2)))
293
294 (define-public r-multtest
295 (package
296 (name "r-multtest")
297 (version "2.36.0")
298 (source
299 (origin
300 (method url-fetch)
301 (uri (bioconductor-uri "multtest" version))
302 (sha256
303 (base32
304 "11949h2kglw13x8haaj4clg4jim1mwh5n98n9zxp9mmgn01z1lp0"))))
305 (build-system r-build-system)
306 (propagated-inputs
307 `(("r-survival" ,r-survival)
308 ("r-biocgenerics" ,r-biocgenerics)
309 ("r-biobase" ,r-biobase)
310 ("r-mass" ,r-mass)))
311 (home-page "http://bioconductor.org/packages/multtest")
312 (synopsis "Resampling-based multiple hypothesis testing")
313 (description
314 "This package can do non-parametric bootstrap and permutation
315 resampling-based multiple testing procedures (including empirical Bayes
316 methods) for controlling the family-wise error rate (FWER), generalized
317 family-wise error rate (gFWER), tail probability of the proportion of
318 false positives (TPPFP), and false discovery rate (FDR). Several choices
319 of bootstrap-based null distribution are implemented (centered, centered
320 and scaled, quantile-transformed). Single-step and step-wise methods are
321 available. Tests based on a variety of T- and F-statistics (including
322 T-statistics based on regression parameters from linear and survival models
323 as well as those based on correlation parameters) are included. When probing
324 hypotheses with T-statistics, users may also select a potentially faster null
325 distribution which is multivariate normal with mean zero and variance
326 covariance matrix derived from the vector influence function. Results are
327 reported in terms of adjusted P-values, confidence regions and test statistic
328 cutoffs. The procedures are directly applicable to identifying differentially
329 expressed genes in DNA microarray experiments.")
330 (license license:lgpl3)))
331
332 (define-public r-chippeakanno
333 (package
334 (name "r-chippeakanno")
335 (version "3.14.0")
336 (source
337 (origin
338 (method url-fetch)
339 (uri (bioconductor-uri "ChIPpeakAnno" version))
340 (sha256
341 (base32
342 "1kcnc3cnmrhdk1x7q3y6zsz09pgd3xn9xy1hfbxz48cajlb18ad0"))))
343 (properties `((upstream-name . "ChIPpeakAnno")))
344 (build-system r-build-system)
345 (propagated-inputs
346 `(("r-biocgenerics" ,r-biocgenerics)
347 ("r-biostrings" ,r-biostrings)
348 ("r-delayedarray" ,r-delayedarray)
349 ("r-go-db" ,r-go-db)
350 ("r-biomart" ,r-biomart)
351 ("r-bsgenome" ,r-bsgenome)
352 ("r-genomicfeatures" ,r-genomicfeatures)
353 ("r-genomicranges" ,r-genomicranges)
354 ("r-genomeinfodb" ,r-genomeinfodb)
355 ("r-iranges" ,r-iranges)
356 ("r-matrixstats" ,r-matrixstats)
357 ("r-annotationdbi" ,r-annotationdbi)
358 ("r-limma" ,r-limma)
359 ("r-multtest" ,r-multtest)
360 ("r-rbgl" ,r-rbgl)
361 ("r-graph" ,r-graph)
362 ("r-biocinstaller" ,r-biocinstaller)
363 ("r-regioner" ,r-regioner)
364 ("r-dbi" ,r-dbi)
365 ("r-ensembldb" ,r-ensembldb)
366 ("r-biobase" ,r-biobase)
367 ("r-s4vectors" ,r-s4vectors)
368 ("r-seqinr" ,r-seqinr)
369 ("r-idr" ,r-idr)
370 ("r-genomicalignments" ,r-genomicalignments)
371 ("r-summarizedexperiment" ,r-summarizedexperiment)
372 ("r-rsamtools" ,r-rsamtools)
373 ("r-venndiagram" ,r-venndiagram)))
374 (home-page "http://bioconductor.org/packages/ChIPpeakAnno")
375 (synopsis "Peaks annotation from ChIP-seq and ChIP-chip experiments")
376 (description
377 "The package includes functions to retrieve the sequences around the peak,
378 obtain enriched Gene Ontology (GO) terms, find the nearest gene, exon, miRNA or
379 custom features such as most conserved elements and other transcription factor
380 binding sites supplied by users. Starting 2.0.5, new functions have been added
381 for finding the peaks with bi-directional promoters with summary statistics
382 (peaksNearBDP), for summarizing the occurrence of motifs in peaks
383 (summarizePatternInPeaks) and for adding other IDs to annotated peaks or
384 enrichedGO (addGeneIDs).")
385 (license license:gpl2+)))
386
387 (define-public r-marray
388 (package
389 (name "r-marray")
390 (version "1.58.0")
391 (source (origin
392 (method url-fetch)
393 (uri (bioconductor-uri "marray" version))
394 (sha256
395 (base32 "0539flh3y1qy5b1bamkfwbskis765c5s33v1y9j51n33mxb9h08d"))))
396 (build-system r-build-system)
397 (propagated-inputs
398 `(("r-limma" ,r-limma)))
399 (home-page "http://bioconductor.org/packages/marray")
400 (synopsis "Exploratory analysis for two-color spotted microarray data")
401 (description "This package contains class definitions for two-color spotted
402 microarray data. It also includes fuctions for data input, diagnostic plots,
403 normalization and quality checking.")
404 (license license:lgpl2.0+)))
405
406 (define-public r-cghbase
407 (package
408 (name "r-cghbase")
409 (version "1.40.0")
410 (source (origin
411 (method url-fetch)
412 (uri (bioconductor-uri "CGHbase" version))
413 (sha256
414 (base32 "1hf44vma3kgwr61kjbszvfxkava8bjqnam1mdncqvczbypb2xwaq"))))
415 (properties `((upstream-name . "CGHbase")))
416 (build-system r-build-system)
417 (propagated-inputs
418 `(("r-biobase" ,r-biobase)
419 ("r-marray" ,r-marray)))
420 (home-page "http://bioconductor.org/packages/CGHbase")
421 (synopsis "Base functions and classes for arrayCGH data analysis")
422 (description "This package contains functions and classes that are needed by
423 the @code{arrayCGH} packages.")
424 (license license:gpl2+)))
425
426 (define-public r-cghcall
427 (package
428 (name "r-cghcall")
429 (version "2.42.0")
430 (source (origin
431 (method url-fetch)
432 (uri (bioconductor-uri "CGHcall" version))
433 (sha256
434 (base32 "0y71vfxv9x0am3xvv520yr95cb7m7y92dhdx1vkqki80jrmf12dz"))))
435 (properties `((upstream-name . "CGHcall")))
436 (build-system r-build-system)
437 (propagated-inputs
438 `(("r-biobase" ,r-biobase)
439 ("r-cghbase" ,r-cghbase)
440 ("r-impute" ,r-impute)
441 ("r-dnacopy" ,r-dnacopy)
442 ("r-snowfall" ,r-snowfall)))
443 (home-page "http://bioconductor.org/packages/CGHcall")
444 (synopsis "Base functions and classes for arrayCGH data analysis")
445 (description "This package contains functions and classes that are needed by
446 @code{arrayCGH} packages.")
447 (license license:gpl2+)))
448
449 (define-public r-qdnaseq
450 (package
451 (name "r-qdnaseq")
452 (version "1.16.0")
453 (source (origin
454 (method url-fetch)
455 (uri (bioconductor-uri "QDNAseq" version))
456 (sha256
457 (base32 "1pj69mfyxwfd0d7h4kls9xq96sdc55y3rv20qpla50hw9libcwwd"))))
458 (properties `((upstream-name . "QDNAseq")))
459 (build-system r-build-system)
460 (propagated-inputs
461 `(("r-biobase" ,r-biobase)
462 ("r-biocparallel" ,r-biocparallel)
463 ("r-cghbase" ,r-cghbase)
464 ("r-cghcall" ,r-cghcall)
465 ("r-dnacopy" ,r-dnacopy)
466 ("r-genomicranges" ,r-genomicranges)
467 ("r-iranges" ,r-iranges)
468 ("r-matrixstats" ,r-matrixstats)
469 ("r-r-utils" ,r-r-utils)
470 ("r-rsamtools" ,r-rsamtools)))
471 (home-page "http://bioconductor.org/packages/QDNAseq")
472 (synopsis "Quantitative DNA sequencing for chromosomal aberrations")
473 (description "The genome is divided into non-overlapping fixed-sized bins,
474 number of sequence reads in each counted, adjusted with a simultaneous
475 two-dimensional loess correction for sequence mappability and GC content, and
476 filtered to remove spurious regions in the genome. Downstream steps of
477 segmentation and calling are also implemented via packages DNAcopy and CGHcall,
478 respectively.")
479 (license license:gpl2+)))
480
481 (define-public r-bayseq
482 (package
483 (name "r-bayseq")
484 (version "2.14.0")
485 (source
486 (origin
487 (method url-fetch)
488 (uri (bioconductor-uri "baySeq" version))
489 (sha256
490 (base32
491 "0hbmm01a8libara9mbxknpk0wzarwfngnfwlmhpww91a0cmy5klg"))))
492 (properties `((upstream-name . "baySeq")))
493 (build-system r-build-system)
494 (propagated-inputs
495 `(("r-abind" ,r-abind)
496 ("r-edger" ,r-edger)
497 ("r-genomicranges" ,r-genomicranges)))
498 (home-page "https://bioconductor.org/packages/baySeq/")
499 (synopsis "Bayesian analysis of differential expression patterns in count data")
500 (description
501 "This package identifies differential expression in high-throughput count
502 data, such as that derived from next-generation sequencing machines,
503 calculating estimated posterior likelihoods of differential expression (or
504 more complex hypotheses) via empirical Bayesian methods.")
505 (license license:gpl3)))
506
507 (define-public r-chipcomp
508 (package
509 (name "r-chipcomp")
510 (version "1.10.0")
511 (source
512 (origin
513 (method url-fetch)
514 (uri (bioconductor-uri "ChIPComp" version))
515 (sha256
516 (base32
517 "0j9nif7z33qdxf347r9wa62hhz8qs09r2p96x3hg5yz30a10ahqs"))))
518 (properties `((upstream-name . "ChIPComp")))
519 (build-system r-build-system)
520 (propagated-inputs
521 `(("r-biocgenerics" ,r-biocgenerics)
522 ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
523 ("r-bsgenome-mmusculus-ucsc-mm9" ,r-bsgenome-mmusculus-ucsc-mm9)
524 ("r-genomeinfodb" ,r-genomeinfodb)
525 ("r-genomicranges" ,r-genomicranges)
526 ("r-iranges" ,r-iranges)
527 ("r-limma" ,r-limma)
528 ("r-rsamtools" ,r-rsamtools)
529 ("r-rtracklayer" ,r-rtracklayer)
530 ("r-s4vectors" ,r-s4vectors)))
531 (home-page "https://bioconductor.org/packages/ChIPComp")
532 (synopsis "Quantitative comparison of multiple ChIP-seq datasets")
533 (description
534 "ChIPComp implements a statistical method for quantitative comparison of
535 multiple ChIP-seq datasets. It detects differentially bound sharp binding
536 sites across multiple conditions considering matching control in ChIP-seq
537 datasets.")
538 ;; Any version of the GPL.
539 (license license:gpl3+)))
540
541 (define-public r-riboprofiling
542 (package
543 (name "r-riboprofiling")
544 (version "1.10.0")
545 (source
546 (origin
547 (method url-fetch)
548 (uri (bioconductor-uri "RiboProfiling" version))
549 (sha256
550 (base32
551 "04yjklqdjkim7yxyk3cyvf0mmwyxyfvw2mmfzgwaaqbiyg29sli0"))))
552 (properties `((upstream-name . "RiboProfiling")))
553 (build-system r-build-system)
554 (propagated-inputs
555 `(("r-biocgenerics" ,r-biocgenerics)
556 ("r-biostrings" ,r-biostrings)
557 ("r-data-table" ,r-data-table)
558 ("r-genomeinfodb" ,r-genomeinfodb)
559 ("r-genomicalignments" ,r-genomicalignments)
560 ("r-genomicfeatures" ,r-genomicfeatures)
561 ("r-genomicranges" ,r-genomicranges)
562 ("r-ggbio" ,r-ggbio)
563 ("r-ggplot2" ,r-ggplot2)
564 ("r-iranges" ,r-iranges)
565 ("r-plyr" ,r-plyr)
566 ("r-reshape2" ,r-reshape2)
567 ("r-rsamtools" ,r-rsamtools)
568 ("r-rtracklayer" ,r-rtracklayer)
569 ("r-s4vectors" ,r-s4vectors)
570 ("r-sqldf" ,r-sqldf)))
571 (home-page "https://bioconductor.org/packages/RiboProfiling/")
572 (synopsis "Ribosome profiling data analysis")
573 (description "Starting with a BAM file, this package provides the
574 necessary functions for quality assessment, read start position recalibration,
575 the counting of genomic sequence reads on CDS, 3'UTR, and 5'UTR, and plotting
576 of count data: pairs, log fold-change, codon frequency and coverage
577 assessment, principal component analysis on codon coverage.")
578 (license license:gpl3)))
579
580 (define-public r-riboseqr
581 (package
582 (name "r-riboseqr")
583 (version "1.14.0")
584 (source
585 (origin
586 (method url-fetch)
587 (uri (bioconductor-uri "riboSeqR" version))
588 (sha256
589 (base32
590 "0xavd1cdhi8qfjn9a1hjhflyg6jq1ydvv56z12gjz572pwz2knvn"))))
591 (properties `((upstream-name . "riboSeqR")))
592 (build-system r-build-system)
593 (propagated-inputs
594 `(("r-abind" ,r-abind)
595 ("r-bayseq" ,r-bayseq)
596 ("r-genomeinfodb" ,r-genomeinfodb)
597 ("r-genomicranges" ,r-genomicranges)
598 ("r-iranges" ,r-iranges)
599 ("r-rsamtools" ,r-rsamtools)
600 ("r-seqlogo" ,r-seqlogo)))
601 (home-page "https://bioconductor.org/packages/riboSeqR/")
602 (synopsis "Analysis of sequencing data from ribosome profiling experiments")
603 (description
604 "This package provides plotting functions, frameshift detection and
605 parsing of genetic sequencing data from ribosome profiling experiments.")
606 (license license:gpl3)))
607
608 (define-public r-interactionset
609 (package
610 (name "r-interactionset")
611 (version "1.8.0")
612 (source
613 (origin
614 (method url-fetch)
615 (uri (bioconductor-uri "InteractionSet" version))
616 (sha256
617 (base32
618 "0xngraq7ic80jr98i1wqp8bxdgidq6py60m2wfk82n1ixpcdck8n"))))
619 (properties
620 `((upstream-name . "InteractionSet")))
621 (build-system r-build-system)
622 (propagated-inputs
623 `(("r-biocgenerics" ,r-biocgenerics)
624 ("r-genomeinfodb" ,r-genomeinfodb)
625 ("r-genomicranges" ,r-genomicranges)
626 ("r-iranges" ,r-iranges)
627 ("r-matrix" ,r-matrix)
628 ("r-rcpp" ,r-rcpp)
629 ("r-s4vectors" ,r-s4vectors)
630 ("r-summarizedexperiment" ,r-summarizedexperiment)))
631 (home-page "https://bioconductor.org/packages/InteractionSet")
632 (synopsis "Base classes for storing genomic interaction data")
633 (description
634 "This packages provides the @code{GInteractions},
635 @code{InteractionSet} and @code{ContactMatrix} objects and associated methods
636 for storing and manipulating genomic interaction data from Hi-C and ChIA-PET
637 experiments.")
638 (license license:gpl3)))
639
640 (define-public r-genomicinteractions
641 (package
642 (name "r-genomicinteractions")
643 (version "1.14.0")
644 (source
645 (origin
646 (method url-fetch)
647 (uri (bioconductor-uri "GenomicInteractions" version))
648 (sha256
649 (base32
650 "0cnagprxj0b7p6s29iyhqwxj7hgmrh75gj52y4dlil790d1bmq2q"))))
651 (properties
652 `((upstream-name . "GenomicInteractions")))
653 (build-system r-build-system)
654 (propagated-inputs
655 `(("r-biobase" ,r-biobase)
656 ("r-biocgenerics" ,r-biocgenerics)
657 ("r-data-table" ,r-data-table)
658 ("r-dplyr" ,r-dplyr)
659 ("r-genomeinfodb" ,r-genomeinfodb)
660 ("r-genomicranges" ,r-genomicranges)
661 ("r-ggplot2" ,r-ggplot2)
662 ("r-gridextra" ,r-gridextra)
663 ("r-gviz" ,r-gviz)
664 ("r-igraph" ,r-igraph)
665 ("r-interactionset" ,r-interactionset)
666 ("r-iranges" ,r-iranges)
667 ("r-rsamtools" ,r-rsamtools)
668 ("r-rtracklayer" ,r-rtracklayer)
669 ("r-s4vectors" ,r-s4vectors)
670 ("r-stringr" ,r-stringr)))
671 (home-page "https://github.com/ComputationalRegulatoryGenomicsICL/GenomicInteractions/")
672 (synopsis "R package for handling genomic interaction data")
673 (description
674 "This R package provides tools for handling genomic interaction data,
675 such as ChIA-PET/Hi-C, annotating genomic features with interaction
676 information and producing various plots and statistics.")
677 (license license:gpl3)))