gnu: c-ares: Move to adns.scm.
[jackhill/guix/guix.git] / gnu / packages / adns.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages adns)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages pkg-config))
26
27 (define-public adns
28 (package
29 (name "adns")
30 (version "1.5.0")
31 (source (origin
32 (method url-fetch)
33 (uri (list (string-append "mirror://gnu/adns/adns-"
34 version ".tar.gz")
35 (string-append
36 "http://www.chiark.greenend.org.uk/~ian/adns/ftp/adns-"
37 version ".tar.gz")))
38 (sha256
39 (base32
40 "0hg89b5n84zjhzvbzrpvhl0hbm4s6d1z2pzllfis64ai656ypibz"))))
41 (build-system gnu-build-system)
42 (arguments
43 ;; Make sure the programs under bin/ fine libadns.so.
44 '(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath -Wl,"
45 (assoc-ref %outputs "out")
46 "/lib"))
47
48 ;; XXX: Tests expect real name resolution to work.
49 #:tests? #f))
50 (home-page "http://www.gnu.org/software/adns/")
51 (synopsis "Asynchronous DNS client library and utilities")
52 (description
53 "GNU adns is a C library that provides easy-to-use DNS resolution
54 functionality. The library is asynchronous, allowing several concurrent
55 calls. The package also includes several command-line utilities for use in
56 scripts.")
57 (license gpl3+)))
58
59 (define-public c-ares
60 (package
61 (name "c-ares")
62 (version "1.10.0")
63 (source (origin
64 (method url-fetch)
65 (uri (string-append
66 "http://c-ares.haxx.se/download/" name "-" version
67 ".tar.gz"))
68 (sha256
69 (base32
70 "1nyka87yf2jfd0y6sspll0yxwb8zi7kyvajrdbjmh4axc5s1cw1x"))))
71 (build-system gnu-build-system)
72 (native-inputs
73 `(("pkg-config" ,pkg-config)))
74 (home-page "http://c-ares.haxx.se/")
75 (synopsis "C library for asynchronous DNS requests")
76 (description
77 "C-ares is a C library that performs DNS requests and name resolution
78 asynchronously. It is intended for applications which need to perform DNS
79 queries without blocking, or need to perform multiple DNS queries in parallel.
80 The primary examples of such applications are servers which communicate with
81 multiple clients and programs with graphical user interfaces.")
82 (license (x11-style "http://c-ares.haxx.se/license.html"))))