gnu: Move sqlite to separate module.
[jackhill/guix/guix.git] / gnu / packages / dc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages dc)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages compression)
23 #:use-module (gnu packages glib)
24 #:use-module (gnu packages ncurses)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages sqlite)
27 #:use-module (gnu packages tls)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system gnu)
31 #:use-module ((guix licenses) #:prefix license:))
32
33 (define-public ncdc
34 (package
35 (name "ncdc")
36 (version "1.20")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version
41 ".tar.gz"))
42 (sha256 (base32
43 "0ccn7dqbqpqsbglqyalz32c20rjvf1pw0zr88jyvd2b2vxbqi6ca"))))
44 (build-system gnu-build-system)
45 (inputs
46 `(("bzip2" ,bzip2)
47 ("glib" ,glib)
48 ("gnutls" ,gnutls)
49 ("ncurses" ,ncurses)
50 ("sqlite" ,sqlite)
51 ("zlib" ,zlib)))
52 (native-inputs
53 `(("pkg-config" ,pkg-config)))
54 (home-page "https://dev.yorhel.nl/ncdc")
55 (synopsis
56 "Lightweight direct connect client with a friendly ncurses interface")
57 (description
58 "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented
59 using ncurses. It is known for its smaller footprint and ease of use.")
60 (license license:x11)))