gnu: Move sqlite to separate module.
[jackhill/guix/guix.git] / gnu / packages / apl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages apl)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages gettext)
27 #:use-module (gnu packages maths)
28 #:use-module (gnu packages readline)
29 #:use-module (gnu packages sqlite))
30
31 (define-public apl
32 (package
33 (name "apl")
34 (version "1.7")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz"))
39 (sha256
40 (base32
41 "07xq8ddlmz8psvsmwr23gar108ri0lwmw0n6kpxcv8ypas1f5xlg"))))
42 (build-system gnu-build-system)
43 (home-page "https://www.gnu.org/software/apl/")
44 (inputs
45 `(("gettext" ,gettext-minimal)
46 ("lapack" ,lapack)
47 ("sqlite" ,sqlite)
48 ("readline" ,readline)))
49 (arguments
50 `(#:configure-flags (list (string-append
51 "--with-sqlite3="
52 (assoc-ref %build-inputs "sqlite")))))
53 (synopsis "APL interpreter")
54 (description
55 "GNU APL is a free interpreter for the programming language APL. It is
56 an implementation of the ISO standard 13751.")
57 (license gpl3+)))