Merge remote-tracking branch 'origin/master' into staging
[jackhill/guix/guix.git] / gnu / packages / vpn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013, 2016, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
6 ;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
9 ;;; Copyright © 2018, 2020 Pierre Langlois <pierre.langlois@gmx.com>
10 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
11 ;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
12 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
13 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
14 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
15 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
16 ;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
17 ;;; Copyright © 2020 David Dashyan <mail@davie.li>
18 ;;;
19 ;;; This file is part of GNU Guix.
20 ;;;
21 ;;; GNU Guix is free software; you can redistribute it and/or modify it
22 ;;; under the terms of the GNU General Public License as published by
23 ;;; the Free Software Foundation; either version 3 of the License, or (at
24 ;;; your option) any later version.
25 ;;;
26 ;;; GNU Guix is distributed in the hope that it will be useful, but
27 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
28 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29 ;;; GNU General Public License for more details.
30 ;;;
31 ;;; You should have received a copy of the GNU General Public License
32 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
33
34 (define-module (gnu packages vpn)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (guix packages)
37 #:use-module (guix download)
38 #:use-module (guix git-download)
39 #:use-module (guix build-system cmake)
40 #:use-module (guix build-system gnu)
41 #:use-module (guix build-system linux-module)
42 #:use-module (guix build-system python)
43 #:use-module (guix utils)
44 #:use-module (gnu packages)
45 #:use-module (gnu packages admin)
46 #:use-module (gnu packages base)
47 #:use-module (gnu packages bash)
48 #:use-module (gnu packages check)
49 #:use-module (gnu packages dns)
50 #:use-module (gnu packages autotools)
51 #:use-module (gnu packages compression)
52 #:use-module (gnu packages gettext)
53 #:use-module (gnu packages gnupg)
54 #:use-module (gnu packages guile)
55 #:use-module (gnu packages libevent)
56 #:use-module (gnu packages linux)
57 #:use-module (gnu packages ncurses)
58 #:use-module (gnu packages nss)
59 #:use-module (gnu packages perl)
60 #:use-module (gnu packages pkg-config)
61 #:use-module (gnu packages python)
62 #:use-module (gnu packages python-xyz)
63 #:use-module (gnu packages python-web)
64 #:use-module (gnu packages samba)
65 #:use-module (gnu packages tls)
66 #:use-module (gnu packages xml))
67
68 (define-public gvpe
69 (package
70 (name "gvpe")
71 (version "3.1")
72 (source (origin
73 (method url-fetch)
74 (uri (string-append "mirror://gnu/gvpe/gvpe-"
75 version ".tar.gz"))
76 (sha256
77 (base32
78 "1cz8n75ksl0l908zc5l3rnfm1hv7130s2w8710799fr5sxrdbszi"))))
79 (build-system gnu-build-system)
80 (home-page "http://software.schmorp.de/pkg/gvpe.html")
81 (native-inputs `(("pkg-config" ,pkg-config)))
82 (inputs `(("openssl" ,openssl)
83 ("zlib" ,zlib)))
84 (synopsis "Secure VPN among multiple nodes over an untrusted network")
85 (description
86 "The GNU Virtual Private Ethernet creates a virtual network
87 with multiple nodes using a variety of transport protocols. It works
88 by creating encrypted host-to-host tunnels between multiple
89 endpoints.")
90 (license license:gpl3+)))
91
92 (define-public vpnc
93 (package
94 (name "vpnc")
95 (version "0.5.3")
96 (source (origin
97 (method url-fetch)
98 (uri (string-append "https://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-"
99 version ".tar.gz"))
100 (sha256 (base32
101 "1128860lis89g1s21hqxvap2nq426c9j4bvgghncc1zj0ays7kj6"))))
102 (build-system gnu-build-system)
103 (inputs `(("libgcrypt" ,libgcrypt)
104 ("perl" ,perl)
105 ("vpnc-scripts" ,vpnc-scripts)))
106 (arguments
107 `(#:tests? #f ; there is no check target
108 #:phases
109 (modify-phases %standard-phases
110 (add-after 'unpack 'use-store-paths
111 (lambda* (#:key inputs outputs #:allow-other-keys)
112 (let ((out (assoc-ref outputs "out"))
113 (vpnc-scripts (assoc-ref inputs "vpnc-scripts")))
114 (substitute* "config.c"
115 (("/etc/vpnc/vpnc-script")
116 (string-append vpnc-scripts "/etc/vpnc/vpnc-script")))
117 (substitute* "Makefile"
118 (("ETCDIR=.*")
119 (string-append "ETCDIR=" out "/etc/vpnc\n"))
120 (("PREFIX=.*")
121 (string-append "PREFIX=" out "\n")))
122 #t)))
123 (delete 'configure)))) ; no configure script
124 (synopsis "Client for Cisco VPN concentrators")
125 (description
126 "vpnc is a VPN client compatible with Cisco's EasyVPN equipment.
127 It supports IPSec (ESP) with Mode Configuration and Xauth. It supports only
128 shared-secret IPSec authentication with Xauth, AES (256, 192, 128), 3DES,
129 1DES, MD5, SHA1, DH1/2/5 and IP tunneling. It runs entirely in userspace.
130 Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
131 (license license:gpl2+) ; some file are bsd-2, see COPYING
132 (home-page "https://www.unix-ag.uni-kl.de/~massar/vpnc/")))
133
134 (define-public vpnc-scripts
135 (let ((commit "3885f8bbc4ae03fd6da0ada6de12f7223a59595c"))
136 (package
137 (name "vpnc-scripts")
138 (version (string-append "20200925." (string-take commit 7)))
139 (source (origin
140 (method git-fetch)
141 (uri
142 (git-reference
143 (url "git://git.infradead.org/users/dwmw2/vpnc-scripts.git")
144 (commit commit)))
145 (file-name (git-file-name name version))
146 (sha256
147 (base32
148 "1pmi4n58q81pmn9arvfixhvv6vkkf3rpwac3hwnwyl882q5q0ccx"))))
149 (build-system gnu-build-system)
150 (inputs `(("guile" ,guile-3.0) ; for the wrapper scripts
151 ("coreutils" ,coreutils)
152 ("grep" ,grep)
153 ("iproute2" ,iproute) ; for ‘ip’
154 ("net-tools" ,net-tools) ; for ‘ifconfig’, ‘route’
155 ("sed" ,sed)
156 ("which" ,which)))
157 (arguments
158 `(#:phases
159 (modify-phases %standard-phases
160 (add-after 'unpack 'use-relative-paths
161 ;; Patch the scripts to work with and use relative paths.
162 (lambda* _
163 (for-each (lambda (script)
164 (substitute* script
165 (("^PATH=.*") "")
166 (("/usr/s?bin/") "")
167 (("\\[ +-x +([^]]+) +\\]" _ command)
168 (string-append "command -v >/dev/null 2>&1 "
169 command))))
170 (find-files "." "^vpnc-script"))
171 #t))
172 (delete 'configure) ; no configure script
173 (replace 'build
174 (lambda _
175 (invoke "gcc" "-o" "netunshare" "netunshare.c")))
176 (replace 'install
177 ;; There is no Makefile; manually install the relevant files.
178 (lambda* (#:key outputs #:allow-other-keys)
179 (let* ((out (assoc-ref outputs "out"))
180 (etc (string-append out "/etc/vpnc")))
181 (for-each (lambda (file)
182 (install-file file etc))
183 (append (find-files "." "^vpnc-script")
184 (list "netunshare"
185 "xinetd.netns.conf")))
186 #t)))
187 (add-after 'install 'wrap-scripts
188 ;; Wrap scripts with paths to their common hard dependencies.
189 ;; Optional dependencies will need to be installed by the user.
190 (lambda* (#:key inputs outputs #:allow-other-keys)
191 (let ((out (assoc-ref outputs "out")))
192 (for-each
193 (lambda (script)
194 (wrap-script (string-append out "/etc/vpnc/" script)
195 `("PATH" ":" prefix
196 ,(map (lambda (name)
197 (let ((input (assoc-ref inputs name)))
198 (string-append input "/bin:"
199 input "/sbin")))
200 (list "coreutils"
201 "grep"
202 "iproute2"
203 "net-tools"
204 "sed"
205 "which")))))
206 (list "vpnc-script-ptrtd"
207 "vpnc-script-sshd"
208 "vpnc-script"))
209 #t))))
210 #:tests? #f)) ; no tests
211 (home-page "http://git.infradead.org/users/dwmw2/vpnc-scripts.git")
212 (synopsis "Network configuration scripts for Cisco VPN clients")
213 (description
214 "This set of scripts configures routing and name services when invoked
215 by the VPNC or OpenConnect Cisco @dfn{Virtual Private Network} (VPN) clients.
216
217 The default @command{vpnc-script} automatically configures most common
218 connections, and provides hooks for performing custom actions at various stages
219 of the connection or disconnection process.
220
221 Alternative scripts are provided for more complicated set-ups, or to serve as an
222 example for writing your own. For example, @command{vpnc-script-sshd} contains
223 the entire VPN in a network namespace accessible only through SSH.")
224 (license license:gpl2+))))
225
226 (define-public ocproxy
227 (package
228 (name "ocproxy")
229 (version "1.60")
230 (source (origin
231 (method git-fetch)
232 (uri (git-reference
233 (url "https://github.com/cernekee/ocproxy")
234 (commit (string-append "v" version))))
235 (file-name (git-file-name name version))
236 (sha256
237 (base32
238 "03323nnhb4y9nzwva04mq7xg03dvdrgp689g89f69jqc261skcqx"))))
239 (build-system gnu-build-system)
240 (native-inputs
241 `(("autoconf" ,autoconf)
242 ("automake" ,automake)))
243 (inputs
244 `(("libevent" ,libevent)))
245 (home-page "https://github.com/cernekee/ocproxy")
246 (synopsis "OpenConnect proxy")
247 (description
248 "User-level @dfn{SOCKS} and port forwarding proxy for OpenConnect based
249 on LwIP. When using ocproxy, OpenConnect only handles network activity that
250 the user specifically asks to proxy, so the @dfn{VPN} interface no longer
251 \"hijacks\" all network traffic on the host.")
252 (license license:bsd-3)))
253
254 (define-public openconnect
255 (package
256 (name "openconnect")
257 (version "8.10")
258 (source (origin
259 (method url-fetch)
260 (uri (string-append "ftp://ftp.infradead.org/pub/openconnect/"
261 "openconnect-" version ".tar.gz"))
262 (sha256
263 (base32 "1cdsx4nsrwawbsisfkldfc9i4qn60g03vxb13nzppr2br9p4rrih"))))
264 (build-system gnu-build-system)
265 (propagated-inputs
266 `(("libxml2" ,libxml2)
267 ("gnutls" ,gnutls)
268 ("zlib" ,zlib)))
269 (inputs
270 `(("lz4" ,lz4)
271 ("vpnc-scripts" ,vpnc-scripts)))
272 (native-inputs
273 `(("gettext" ,gettext-minimal)
274 ("pkg-config" ,pkg-config)))
275 (arguments
276 `(#:configure-flags
277 `(,(string-append "--with-vpnc-script="
278 (assoc-ref %build-inputs "vpnc-scripts")
279 "/etc/vpnc/vpnc-script"))))
280 (synopsis "Client for Cisco VPN")
281 (description
282 "OpenConnect is a client for Cisco's AnyConnect SSL VPN, which is
283 supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,
284 870, 880, 1800, 2800, 3800, 7200 Series and Cisco 7301 Routers,
285 and probably others.")
286 (license license:lgpl2.1)
287 (home-page "https://www.infradead.org/openconnect/")))
288
289 (define-public openfortivpn
290 (package
291 (name "openfortivpn")
292 (version "1.15.0")
293 (source (origin
294 (method git-fetch)
295 (uri (git-reference
296 (url "https://github.com/adrienverge/openfortivpn")
297 (commit (string-append "v" version))))
298 (file-name (git-file-name name version))
299 (sha256
300 (base32
301 "1qsfgpxg553s8rc9cyrc4k96z0pislxsdxb9wyhp8fdprkak2mw2"))))
302 (build-system gnu-build-system)
303 (native-inputs
304 `(("autoconf" ,autoconf)
305 ("autotools" ,automake)
306 ("pkg-config" ,pkg-config)))
307 (inputs
308 `(("openssl" ,openssl)
309 ("ppp" ,ppp)))
310 (home-page "https://github.com/adrienverge/openfortivpn")
311 (synopsis "Client for PPP+SSL VPN tunnel services")
312 (description "Openfortivpn is a client for PPP+SSL VPN tunnel services. It
313 spawns a pppd process and operates the communication between the gateway and
314 this process. It is compatible with Fortinet VPNs.")
315 (license license:gpl3+)))
316
317 (define-public openvpn
318 (package
319 (name "openvpn")
320 (version "2.4.10")
321 (source (origin
322 (method url-fetch)
323 (uri (string-append
324 "https://swupdate.openvpn.org/community/releases/openvpn-"
325 version ".tar.xz"))
326 (sha256
327 (base32
328 "0xx378ja2rdfaayc257z0z5ddsp8h0jcpqnd1a6bdw3rlsam6a6g"))))
329 (build-system gnu-build-system)
330 (arguments
331 '(#:configure-flags '("--enable-iproute2=yes")))
332 (native-inputs
333 `(("iproute2" ,iproute)))
334 (inputs
335 `(("lz4" ,lz4)
336 ("lzo" ,lzo)
337 ("openssl" ,openssl)
338 ("linux-pam" ,linux-pam)))
339 (home-page "https://openvpn.net/")
340 (synopsis "Virtual private network daemon")
341 (description
342 "OpenVPN implements virtual private network (@dfn{VPN}) techniques
343 for creating secure point-to-point or site-to-site connections in routed or
344 bridged configurations and remote access facilities. It uses a custom
345 security protocol that utilizes SSL/TLS for key exchange. It is capable of
346 traversing network address translators (@dfn{NAT}s) and firewalls.")
347 (license license:gpl2)))
348
349 (define-public protonvpn-cli
350 (package
351 (name "protonvpn-cli")
352 (version "2.2.6")
353 (source
354 (origin
355 ;; PyPI has a ".whl" file but not a proper source release.
356 ;; Thus, fetch code from Git.
357 (method git-fetch)
358 (uri (git-reference
359 (url "https://github.com/ProtonVPN/linux-cli")
360 (commit (string-append "v" version))))
361 (file-name (git-file-name name version))
362 (sha256
363 (base32 "0y7v9ikrmy5dbjlpbpacp08gy838i8z54m8m4ps7ldk1j6kyia3n"))))
364 (build-system python-build-system)
365 (arguments
366 '(#:tests? #f ; no tests in repo
367 #:phases
368 (modify-phases %standard-phases
369 (add-after 'wrap 'wrap-wrapper
370 ;; Wrap entrypoint with paths to its hard dependencies.
371 (lambda* (#:key inputs outputs #:allow-other-keys)
372 (let ((entrypoint (string-append (assoc-ref outputs "out")
373 "/bin/.protonvpn-real")))
374 (wrap-program entrypoint
375 `("PATH" ":" prefix
376 ,(map (lambda (name)
377 (let ((input (assoc-ref inputs name)))
378 (string-append input "/bin:"
379 input "/sbin")))
380 (list "dialog"
381 "iproute2"
382 "iptables"
383 "ncurses"
384 "openvpn"
385 "procps"
386 "which")))))
387 #t)))))
388 (native-inputs
389 `(("python-docopt" ,python-docopt)))
390 (inputs
391 `(("dialog" ,dialog)
392 ("iproute2" ,iproute)
393 ("iptables" ,iptables)
394 ("ncurses" ,ncurses)
395 ("openvpn" ,openvpn)
396 ("procps" ,procps)
397 ("python-jinja2" ,python-jinja2)
398 ("python-pythondialog" ,python-pythondialog)
399 ("python-requests" ,python-requests)
400 ("which" ,which)))
401 (synopsis "Command-line client for ProtonVPN")
402 (description
403 "This is the official command-line interface for ProtonVPN, a secure
404 point-to-point virtual private networking (VPN) service with a gratis tier.
405 It can automatically find and connect to the fastest servers or use Tor over
406 VPN. The gratis tier offers unlimited bandwidth for up to 10 devices.")
407 (home-page "https://github.com/ProtonVPN/linux-cli")
408 (license license:gpl3+)))
409
410 (define-public tinc
411 (package
412 (name "tinc")
413 (version "1.0.36")
414 (source (origin
415 (method url-fetch)
416 (uri (string-append "https://tinc-vpn.org/packages/"
417 "tinc-" version ".tar.gz"))
418 (sha256
419 (base32
420 "021i2sl2mjscbm8g59d7vs74iw3gf0m48wg7w3zhwj6czarkpxs0"))))
421 (build-system gnu-build-system)
422 (arguments
423 '(#:configure-flags
424 '("--sysconfdir=/etc"
425 "--localstatedir=/var")))
426 (inputs `(("zlib" ,zlib)
427 ("lzo" ,lzo)
428 ("openssl" ,openssl)))
429 (home-page "https://tinc-vpn.org")
430 (synopsis "Virtual Private Network (VPN) daemon")
431 (description
432 "Tinc is a VPN that uses tunnelling and encryption to create a secure
433 private network between hosts on the internet.")
434 (license license:gpl2+)))
435
436 (define-public sshuttle
437 (package
438 (name "sshuttle")
439 (version "0.78.5")
440 (source
441 (origin
442 (method url-fetch)
443 (uri (pypi-uri name version))
444 (sha256
445 (base32
446 "0vp13xwrhx4m6zgsyzvai84lkq9mzkaw47j58dk0ll95kaymk2x8"))))
447 (build-system python-build-system)
448 (arguments
449 `(#:phases
450 (modify-phases %standard-phases
451 (add-after 'unpack 'patch-FHS-file-names
452 (lambda _
453 (substitute* "sshuttle/client.py"
454 (("/usr/bin/env") (which "env")))
455 (substitute* "sshuttle/ssh.py"
456 (("/bin/sh") "sh"))
457 #t)))))
458 (native-inputs
459 `(("python-setuptools-scm" ,python-setuptools-scm)
460 ;; For tests only.
461 ("python-flake8" ,python-flake8)
462 ("python-mock" ,python-mock)
463 ("python-pytest-cov" ,python-pytest-cov)
464 ("python-pytest-runner" ,python-pytest-runner)))
465 (home-page "https://github.com/sshuttle/sshuttle")
466 (synopsis "VPN that transparently forwards connections over SSH")
467 (description "sshuttle creates an encrypted virtual private network (VPN)
468 connection to any remote server to which you have secure shell (SSH) access.
469 The only requirement is a suitable version of Python on the server;
470 administrative privileges are required only on the client. Unlike most VPNs,
471 sshuttle forwards entire sessions, not packets, using kernel transparent
472 proxying. This makes it faster and more reliable than SSH's own tunneling and
473 port forwarding features. It can forward both TCP and UDP traffic, including
474 DNS domain name queries.")
475 (license license:lgpl2.0))) ; incorrectly identified as GPL in ‘setup.py’
476
477 (define-public sshoot
478 (package
479 (name "sshoot")
480 (version "1.2.6")
481 (source
482 (origin
483 (method url-fetch)
484 (uri (pypi-uri name version))
485 (sha256
486 (base32
487 "1ccgh0hjyxrwkgy3hnxz3hgbjbs0lmfs25d5l5jam0xbpcpj63h0"))))
488 (build-system python-build-system)
489 (arguments
490 '(#:phases
491 (modify-phases %standard-phases
492 (add-after 'unpack 'patch-paths
493 (lambda _
494 (substitute* "sshoot/tests/test_manager.py"
495 (("/bin/sh") (which "sh")))
496 #t)))))
497 (inputs
498 `(("python-argcomplete" ,python-argcomplete)
499 ("python-prettytable" ,python-prettytable)
500 ("python-pyyaml" ,python-pyyaml)))
501 ;; For tests only.
502 (native-inputs
503 `(("python-fixtures" ,python-fixtures)
504 ("python-pbr" ,python-pbr)
505 ("python-testtools" ,python-testtools)))
506 (home-page "https://github.com/albertodonato/sshoot")
507 (synopsis "sshuttle VPN session manager")
508 (description "sshoot provides a command-line interface to manage multiple
509 @command{sshuttle} virtual private networks. It supports flexible profiles
510 with configuration options for most of @command{sshuttle}’s features.")
511 (license license:gpl3+)))
512
513 (define-public badvpn
514 (package
515 (name "badvpn")
516 (version "1.999.130")
517 (source
518 (origin
519 (method git-fetch)
520 (uri (git-reference
521 (url "https://github.com/ambrop72/badvpn")
522 (commit version)))
523 (file-name (git-file-name name version))
524 (sha256
525 (base32 "0rm67xhi7bh3yph1vh07imv5y1pwyldvw3wa5bz471g8mnkc7d3c"))))
526 (build-system cmake-build-system)
527 (arguments
528 '(#:tests? #f)) ; no tests
529 (inputs
530 `(("nspr" ,nspr)
531 ("nss" ,nss)
532 ("openssl" ,openssl)))
533 (native-inputs
534 `(("pkg-config" ,pkg-config)))
535 (home-page "https://github.com/ambrop72/badvpn")
536 (synopsis "Peer-to-peer virtual private network (VPN)")
537 (description "@code{BadVPN} is a collection of virtual private
538 network (VPN) tools. It includes:
539
540 @enumerate
541 @item NCD programming language.\n
542 NCD (Network Configuration Daemon) is a daemon and programming/scripting
543 language for configuration of network interfaces and other aspects of the
544 operating system.
545 @item Tun2socks network-layer proxifier.\n
546 The tun2socks program socksifes TCP connections at the network layer. It
547 implements a TUN device which accepts all incoming TCP connections (regardless
548 of destination IP), and forwards the connections through a SOCKS server.
549 @item Peer-to-peer VPN.\n
550 The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
551 (VPN nodes).
552 @end enumerate")
553 ;; This project contains a bundled lwIP. lwIP is also released under the
554 ;; 3-clause BSD license.
555 (license license:bsd-3)))
556
557 (define-public wireguard-linux-compat
558 (package
559 (name "wireguard-linux-compat")
560 (version "1.0.20201112")
561 (source (origin
562 (method url-fetch)
563 (uri (string-append "https://git.zx2c4.com/wireguard-linux-compat/"
564 "snapshot/wireguard-linux-compat-" version
565 ".tar.xz"))
566 (sha256
567 (base32
568 "1qcpg1rcmy4h529a0spjm50qgxjgjy20j29fpbrqsv5xq3qfgsl9"))))
569 (build-system linux-module-build-system)
570 (outputs '("out"
571 "kernel-patch"))
572 (arguments
573 `(#:linux ,linux-libre-5.4 ; mustn't have WG built-in
574 #:tests? #f ; no test suite
575 #:modules ((guix build linux-module-build-system)
576 (guix build utils)
577 (ice-9 popen)
578 (ice-9 textual-ports))
579 #:phases
580 (modify-phases %standard-phases
581 (add-before 'build 'change-directory
582 (lambda _
583 (chdir "./src")
584 #t))
585 (add-after 'build 'build-patch
586 (lambda* (#:key outputs #:allow-other-keys)
587 (let* ((patch-builder "../kernel-tree-scripts/create-patch.sh")
588 (port (open-input-pipe patch-builder))
589 (str (get-string-all port)))
590 (close-pipe port)
591 (call-with-output-file "wireguard.patch"
592 (lambda (port)
593 (format port "~a" str))))
594 #t))
595 (add-after 'install 'install-patch
596 (lambda* (#:key outputs #:allow-other-keys)
597 (install-file "wireguard.patch"
598 (assoc-ref %outputs "kernel-patch"))
599 #t))
600 ;; So that 'install-license-files' works...
601 (add-before 'install-license-files 'reset-cwd
602 (lambda _
603 (chdir "..")
604 #t)))))
605 (home-page "https://git.zx2c4.com/wireguard-linux-compat/")
606 (synopsis "WireGuard kernel module for Linux 3.10 through 5.5")
607 (description "This package contains an out-of-tree kernel patch and
608 a loadable module adding WireGuard to Linux kernel versions 3.10 through 5.5.
609 WireGuard was added to Linux 5.6.")
610 (license license:gpl2)))
611
612 (define-public wireguard-tools
613 (package
614 (name "wireguard-tools")
615 (version "1.0.20200827")
616 (source
617 (origin
618 (method git-fetch)
619 (uri (git-reference
620 (url "https://git.zx2c4.com/wireguard-tools.git")
621 (commit (string-append "v" version))))
622 (file-name (git-file-name name version))
623 (sha256
624 (base32 "1h351hn531z6z85sx9ya27xjz1jszgn1pkwibacjj49mds15f7gn"))))
625 (build-system gnu-build-system)
626 (arguments
627 `(#:make-flags
628 (list ,(string-append "CC=" (cc-for-target))
629 "--directory=src"
630 "WITH_BASHCOMPLETION=yes"
631 ;; Install the ‘simple and dirty’ helper script wg-quick(8).
632 "WITH_WGQUICK=yes"
633 (string-append "PREFIX=" (assoc-ref %outputs "out"))
634 ;; Currently used only to create an empty /etc/wireguard directory.
635 (string-append "SYSCONFDIR=no-thanks"))
636 ;; The test suite is meant to be run interactively. It runs Clang's
637 ;; scan-build static analyzer and then starts a web server to display the
638 ;; results.
639 #:tests? #f
640 #:phases
641 (modify-phases %standard-phases
642 ;; No configure script
643 (delete 'configure)
644 (add-after 'install 'install-contrib-docs
645 (lambda* (#:key outputs #:allow-other-keys)
646 (let ((out (assoc-ref outputs "out")))
647 (copy-recursively "contrib/"
648 (string-append out "/share/doc/wireguard-tools"))
649 #t)))
650 (add-after 'install 'wrap-wg-quick
651 (lambda* (#:key inputs outputs #:allow-other-keys)
652 (let* ((out (assoc-ref outputs "out"))
653 (inputs-sbin (map (lambda (input)
654 (string-append (assoc-ref inputs input) "/sbin"))
655 (list "resolvconf" "iproute" "procps"
656 "iptables")))
657 (coreutils (string-append (assoc-ref inputs "coreutils")
658 "/bin")))
659 (wrap-program (string-append out "/bin/wg-quick")
660 `("PATH" ":" prefix ,(append inputs-sbin
661 (list coreutils))))
662 #t))))))
663 (inputs
664 `(("resolvconf" ,openresolv)
665 ("coreutils" ,coreutils)
666 ("bash" ,bash) ; for scripts using /dev/tcp
667 ("procps" ,procps)
668 ("iproute" ,iproute)
669 ("iptables" ,iptables)))
670 (home-page "https://www.wireguard.com/")
671 (synopsis "Tools for configuring WireGuard tunnels")
672 (description
673 "This package provides the user-space command-line tools for using and
674 configuring WireGuard tunnels.
675
676 WireGuard is a simple and fast general-purpose @acronym{VPN, Virtual Private
677 Network} that securely encapsulates IP packets over UDP. It aims to be as easy
678 to configure and deploy as SSH. VPN connections are made simply by exchanging
679 public keys and can roam across IP addresses.")
680 (license
681 (list license:lgpl2.1+ ; src/netlink.h & contrib/embeddable-wg-library
682 license:gpl2)))) ; everything else
683
684 (define-public wireguard
685 (deprecated-package "wireguard" wireguard-tools))
686
687 (define-public xl2tpd
688 (package
689 (name "xl2tpd")
690 (version "1.3.16")
691 (source (origin
692 (method git-fetch)
693 (uri (git-reference
694 (url "https://github.com/xelerance/xl2tpd")
695 (commit (string-append "v" version))))
696 (file-name (git-file-name name version))
697 (sha256
698 (base32
699 "0is5ccrvijz0pfm45pfrlbb9y8231yz3c4zqs8mkgakl9rxajy6l"))))
700 (build-system gnu-build-system)
701 (arguments
702 `(#:make-flags (list (string-append "PREFIX=" %output)
703 "CC=gcc")
704 #:phases (modify-phases %standard-phases
705 (delete 'configure) ;no configure script
706 (add-before 'build 'setup-environment
707 (lambda* (#:key inputs #:allow-other-keys)
708 (substitute* "l2tp.h"
709 (("/usr/sbin/pppd")
710 (string-append (assoc-ref inputs "ppp")
711 "/sbin/pppd")))
712 (setenv "KERNELSRC"
713 (assoc-ref inputs "linux-libre-headers"))
714 #t)))
715 #:tests? #f)) ; no tests provided
716 (inputs `(("libpcap" ,libpcap)
717 ("linux-libre-headers" ,linux-libre-headers)
718 ("ppp" ,ppp)))
719 (home-page "https://www.xelerance.com/software/xl2tpd/")
720 (synopsis "Layer 2 Tunnelling Protocol Daemon (RFC 2661)")
721 (description
722 "xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
723 L2TP allows you to tunnel PPP over UDP.")
724 (license license:gpl2)))