gnu: Move crypto packages from python to python-crypto.
[jackhill/guix/guix.git] / gnu / packages / jrnl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <address@hidden>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages jrnl)
22 #:use-module (guix packages)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (guix build-system python)
26 #:use-module (gnu packages python)
27 #:use-module (gnu packages python-crypto))
28
29 (define-public jrnl
30 (package
31 (name "jrnl")
32 (version "1.9.7")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "https://github.com/maebert/jrnl/archive/"
37 version ".tar.gz"))
38 (file-name (string-append name "-" version ".tar.gz"))
39 (sha256
40 (base32
41 "0mfq7hhw5np2dj9jlxpyyk2cg9i0xgz2brb894d928hczszy97bq"))))
42 (build-system python-build-system)
43 (native-inputs
44 `(("behave" ,behave)))
45 (inputs
46 `(("python" ,python)
47 ("python-keyring" ,python-keyring)
48 ("python-pycrypto" ,python-pycrypto)
49 ("python-pytz" ,python-pytz)
50 ("python-tzlocal" ,python-tzlocal)
51 ("python-six" ,python-six)
52 ("python-dateutil" ,python-dateutil)
53 ("python-parsedatetime" ,python-parsedatetime)))
54 (home-page "http://maebert.github.io/jrnl/")
55 (synopsis "Personal journal application")
56 (description
57 "Jrnl is a command line journal application that stores your journal in a
58 plain text file. Optionally, your journal can be encrypted using 256-bit AES
59 encryption.")
60 (license x11)))