gnu: polkit-qt: Add $libdir to RUNPATH.
[jackhill/guix/guix.git] / gnu / packages / polkit.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages polkit)
20 #:use-module ((guix licenses) #:select (lgpl2.0+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system cmake)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages glib)
27 #:use-module (gnu packages gnuzilla)
28 #:use-module (gnu packages linux)
29 #:use-module (gnu packages perl)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages python)
32 #:use-module (gnu packages qt)
33 #:use-module (gnu packages xml))
34
35 (define-public polkit
36 (package
37 (name "polkit")
38 (version "0.112")
39 (source (origin
40 (method url-fetch)
41 (uri (string-append
42 "http://www.freedesktop.org/software/polkit/releases/"
43 name "-" version ".tar.gz"))
44 (sha256
45 (base32
46 "1xkary7yirdcjdva950nqyhmsz48qhrdsr78zciahj27p8yg95fn"))
47 (patches (list (search-patch "polkit-drop-test.patch")))))
48 (build-system gnu-build-system)
49 (inputs
50 `(("expat" ,expat)
51 ("glib:bin" ,glib "bin") ; for glib-mkenums
52 ("intltool" ,intltool)
53 ("linux-pam" ,linux-pam)
54 ("mozjs" ,mozjs)
55 ("nspr" ,nspr)))
56 (propagated-inputs
57 `(("glib" ,glib))) ; required by polkit-gobject-1.pc
58 (native-inputs
59 `(("pkg-config", pkg-config)))
60 (home-page "http://www.freedesktop.org/wiki/Software/polkit/")
61 (synopsis "Authorization API for privilege management")
62 (description "Polkit is an application-level toolkit for defining and
63 handling the policy that allows unprivileged processes to speak to
64 privileged processes. It is a framework for centralizing the decision
65 making process with respect to granting access to privileged operations
66 for unprivileged applications.")
67 (license lgpl2.0+)))
68
69 (define-public polkit-qt
70 (package
71 (name "polkit-qt")
72 (version "1-0.112.0")
73 (source (origin
74 (method url-fetch)
75 (uri (string-append
76 "http://download.kde.org/stable/apps/KDE4.x/admin/"
77 name "-" version ".tar.bz2"))
78 (sha256
79 (base32
80 "1ip78x20hjqvm08kxhp6gb8hf6k5n6sxyx6kk2yvvq53djzh7yv7"))))
81 (build-system cmake-build-system)
82 (inputs
83 `(("polkit" ,polkit)))
84 (propagated-inputs
85 `(("qt" ,qt-4))) ; according to the pkg-config files
86 (native-inputs
87 `(("pkg-config", pkg-config)))
88 (arguments
89 `(#:configure-flags (list (string-append "-DCMAKE_INSTALL_RPATH="
90 (assoc-ref %outputs "out")
91 "/lib:"
92 (assoc-ref %outputs "out")
93 "/lib64"))
94 #:tests? #f)) ; there is a test subdirectory, but no test target
95 (home-page "http://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/")
96 (synopsis "Qt frontend to the polkit library")
97 (description "Polkit-qt is a library that lets developers use the
98 PolicyKit API through a Qt-styled API. It is mainly a wrapper around
99 QAction and QAbstractButton that lets you integrate those two component
100 easily with PolicyKit.")
101 (license lgpl2.0+)))