Re-export `%current-system' from (guix packages).
[jackhill/guix/guix.git] / gnu / packages / pkg-config.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages pkg-config)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public pkg-config
26 (package
27 (name "pkg-config")
28 (version "0.27.1")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append
32 "http://pkgconfig.freedesktop.org/releases/pkg-config-"
33 version ".tar.gz"))
34 (sha256
35 (base32
36 "05wc5nwkqz7saj2v33ydmz1y6jdg659dll4jjh91n41m63gx0qsg"))))
37 (build-system gnu-build-system)
38 (arguments `(#:configure-flags '("--with-internal-glib")))
39 (home-page "http://www.freedesktop.org/wiki/Software/pkg-config")
40 (license gpl2+)
41 (synopsis "a helper tool used when compiling applications and
42 libraries")
43 (description
44 "pkg-config is a helper tool used when compiling applications and
45 libraries. It helps you insert the correct compiler options on the
46 command line so an application can use gcc -o test test.c `pkg-config
47 --libs --cflags glib-2.0` for instance, rather than hard-coding values
48 on where to find glib (or other libraries). It is language-agnostic, so
49 it can be used for defining the location of documentation tools, for
50 instance.")))