Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / django.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
5 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages django)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system python)
27 #:use-module (gnu packages)
28 #:use-module (gnu packages base)
29 #:use-module (gnu packages databases)
30 #:use-module (gnu packages python))
31
32 (define-public python-django
33 (package
34 (name "python-django")
35 (version "1.10.8")
36 (source (origin
37 (method url-fetch)
38 (uri (pypi-uri "Django" version))
39 (sha256
40 (base32
41 "1fwqqh2zbcy9dy0lnvk338s11llnnfz2k56bf84w0wv56ayq7vyl"))))
42 (build-system python-build-system)
43 (arguments
44 '(#:phases
45 (modify-phases %standard-phases
46 (add-before 'check 'set-tzdir
47 (lambda* (#:key inputs #:allow-other-keys)
48 ;; The test-suite tests timezone-dependent functions, thus tzdata
49 ;; needs to be available.
50 (setenv "TZDIR"
51 (string-append (assoc-ref inputs "tzdata")
52 "/share/zoneinfo"))
53 #t))
54 (replace 'check
55 (lambda _
56 (setenv "PYTHONPATH"
57 (string-append ".:" (getenv "PYTHONPATH")))
58 (zero? (system* "python" "tests/runtests.py")))))))
59 ;; TODO: Install extras/django_bash_completion.
60 (native-inputs
61 `(("tzdata", tzdata)
62 ;; bcrypt and argon2-cffi are extra requirements not yet in guix
63 ;;("python-argon2-cffi" ,python-argon2-cffi) ; >= 16.1.0
64 ;;("python-bcrypt" ,python-bcrypt) ; not py-bcrypt!
65 ;; Remaining packages are test requirements taken from
66 ;; tests/requirements/py3.txt
67 ("python-docutils" ,python-docutils)
68 ;; optional for tests: ("python-geoip2" ,python-geoip2)
69 ("python-jinja2" ,python-jinja2) ; >= 2.7
70 ;; optional for tests: ("python-memcached" ,python-memcached)
71 ("python-numpy" ,python-numpy)
72 ("python-pillow" ,python-pillow)
73 ("python-pyyaml" ,python-pyyaml)
74 ("python-pytz" ,python-pytz)
75 ;; optional for tests: ("python-selenium" ,python-selenium)
76 ("python-sqlparse" ,python-sqlparse)
77 ("python-tblib" ,python-tblib)))
78 (home-page "http://www.djangoproject.com/")
79 (synopsis "High-level Python Web framework")
80 (description
81 "Django is a high-level Python Web framework that encourages rapid
82 development and clean, pragmatic design. It provides many tools for building
83 any Web site. Django focuses on automating as much as possible and adhering
84 to the @dfn{don't repeat yourself} (DRY) principle.")
85 (license license:bsd-3)
86 (properties `((python2-variant . ,(delay python2-django))
87 (cpe-name . "django")))))
88
89 (define-public python2-django
90 (let ((base (package-with-python2 (strip-python2-variant python-django))))
91 (package
92 (inherit base)
93 (native-inputs
94 `(;; Test requirements for Python 2 taken from
95 ;; tests/requirements/py3.txt: enum34 and mock.
96 ("python2-enum34" ,python2-enum34)
97 ("python2-mock" ,python2-mock)
98 ;; When adding memcached mind: for Python 2 memcached <= 1.53 is
99 ;; required.
100 ,@(package-native-inputs base))))))
101
102 (define-public python-django-simple-math-captcha
103 (package
104 (name "python-django-simple-math-captcha")
105 (version "1.0.7")
106 (source (origin
107 (method url-fetch)
108 (uri (pypi-uri "django-simple-math-captcha" version))
109 (sha256
110 (base32
111 "0906hms6y6znjhpd0g4wmzv9vcla4brkdpsm4zha9zdj8g5vq2hd"))))
112 (build-system python-build-system)
113 (arguments
114 ;; FIXME: Upstream uses a 'runtests.py' script that is not
115 ;; present in the pypi tarball.
116 '(#:tests? #f))
117 (propagated-inputs
118 `(("python-django" ,python-django)))
119 (home-page "https://github.com/alsoicode/django-simple-math-captcha")
120 (synopsis "Easy-to-use math field/widget captcha for Django forms")
121 (description
122 "A multi-value-field that presents a human answerable question,
123 with no settings.py configuration necessary, but instead can be configured
124 with arguments to the field constructor.")
125 (license license:asl2.0)))
126
127 (define-public python2-django-simple-math-captcha
128 (package-with-python2 python-django-simple-math-captcha))
129
130 (define-public python-pytest-django
131 (package
132 (name "python-pytest-django")
133 (version "3.1.2")
134 (source (origin
135 (method url-fetch)
136 (uri (pypi-uri "pytest-django" version))
137 (sha256
138 (base32
139 "02932m2sr8x22m4az8syr8g835g4ak77varrnw71n6xakmdcr303"))))
140 (build-system python-build-system)
141 (arguments
142 `(#:tests? #f ; FIXME: How to run tests?
143 #:phases
144 (modify-phases %standard-phases
145 (add-after 'unpack 'patch-setuppy
146 (lambda _
147 (substitute* "setup.py"
148 (("setuptools_scm==1.11.1") "setuptools_scm"))
149 #t)))))
150 (native-inputs
151 `(("python-django" ,python-django)
152 ("python-setuptools-scm" ,python-setuptools-scm)))
153 (propagated-inputs
154 `(("python-pytest" ,python-pytest-3.0)))
155 (home-page "http://pytest-django.readthedocs.org/")
156 (synopsis "Django plugin for py.test")
157 (description "Pytest-django is a plugin for py.test that provides a set of
158 useful tools for testing Django applications and projects.")
159 (license license:bsd-3)))
160
161 (define-public python2-pytest-django
162 (package-with-python2 python-pytest-django))
163
164 (define-public python-django-filter
165 (package
166 (name "python-django-filter")
167 (version "0.14.0")
168 (source (origin
169 (method url-fetch)
170 (uri (pypi-uri "django-filter" version))
171 (sha256
172 (base32
173 "0f78hmk8c903zwfzlsiw7ivgag81ymmb5hi73rzxbhnlg2v0l3fx"))))
174 (build-system python-build-system)
175 (arguments
176 '(#:phases
177 (modify-phases %standard-phases
178 (replace 'check
179 (lambda _
180 (zero? (system* "python" "runtests.py")))))))
181 (native-inputs
182 `(("python-django" ,python-django)
183 ("python-mock" ,python-mock)))
184 (home-page "https://django-filter.readthedocs.io/en/latest/")
185 (synopsis "Reusable Django application to filter querysets dynamically")
186 (description
187 "Django-filter is a generic, reusable application to alleviate writing
188 some of the more mundane bits of view code. Specifically, it allows users to
189 filter down a queryset based on a model’s fields, displaying the form to let
190 them do this.")
191 (license license:bsd-3)))
192
193 (define-public python2-django-filter
194 (package-with-python2 python-django-filter))
195
196 (define-public python-django-allauth
197 (package
198 (name "python-django-allauth")
199 (version "0.30.0")
200 (source
201 (origin
202 (method url-fetch)
203 (uri (pypi-uri "django-allauth" version))
204 (sha256
205 (base32
206 "1fslqc5qqb0b66yscvkyjwfv8cnbfx5nlkpnwimyb3pf1nc1w7r3"))))
207 (build-system python-build-system)
208 (propagated-inputs
209 `(("python-openid" ,python-openid)
210 ("python-requests" ,python-requests)
211 ("python-requests-oauthlib" ,python-requests-oauthlib)))
212 (native-inputs
213 `(("python-mock" ,python-mock)))
214 (inputs
215 `(("python-django" ,python-django)))
216 (home-page "https://github.com/pennersr/django-allauth")
217 (synopsis "Set of Django applications addressing authentication")
218 (description
219 "Integrated set of Django applications addressing authentication,
220 registration, account management as well as 3rd party (social)
221 account authentication.")
222 (license license:expat)))
223
224 (define-public python2-django-allauth
225 (package-with-python2 python-django-allauth))
226
227 (define-public python-django-gravatar2
228 (package
229 (name "python-django-gravatar2")
230 (version "1.4.0")
231 (source
232 (origin
233 (method url-fetch)
234 (uri (pypi-uri "django-gravatar2" version))
235 (sha256
236 (base32
237 "1v4qyj6kms321yw0z2g1kch6b2dskmv6fjd6sfxzwr4xshq9mccl"))))
238 (build-system python-build-system)
239 (inputs
240 `(("python-django" ,python-django)))
241 (home-page "https://github.com/twaddington/django-gravatar")
242 (synopsis "Gravatar support for Django, improved version")
243 (description
244 "Essential Gravatar support for Django. Features helper methods,
245 templatetags and a full test suite.")
246 (license license:expat)))
247
248 (define-public python2-django-gravatar2
249 (package-with-python2 python-django-gravatar2))
250
251 (define-public python-django-assets
252 (package
253 (name "python-django-assets")
254 (version "0.12")
255 (source (origin
256 (method url-fetch)
257 (uri (pypi-uri "django-assets" version))
258 (sha256
259 (base32
260 "0y0007fvkn1rdlj2g0y6k1cnkx53kxab3g8i85i0rd58k335p365"))))
261 (build-system python-build-system)
262 (arguments
263 `(#:phases
264 (modify-phases %standard-phases
265 (add-before 'check 'fix-tests
266 (lambda _
267 (begin
268 ;; https://github.com/miracle2k/django-assets/issues/87
269 (substitute* "tests/__init__.py"
270 (("settings.configure.*")
271 (string-append
272 "settings.configure(\n"
273 "INSTALLED_APPS=['django_assets', "
274 "'django.contrib.staticfiles'],\n"
275 "TEMPLATES=[{'BACKEND': "
276 "'django.template.backends.django.DjangoTemplates'}],\n"
277 ")\n")))
278 ;; These tests fail
279 (substitute* "tests/test_django.py"
280 (("TestLoader") "NoTestLoader"))))))))
281 (native-inputs
282 `(("python-nose" ,python-nose)))
283 (propagated-inputs
284 `(("python-django" ,python-django)
285 ("python-webassets" ,python-webassets)))
286 (home-page "https://github.com/miracle2k/django-assets")
287 (synopsis "Asset management for Django")
288 (description
289 "Asset management for Django, to compress and merge CSS and Javascript
290 files. Integrates the webassets library with Django, adding support for
291 merging, minifying and compiling CSS and Javascript files.")
292 (license license:bsd-2)))
293
294 (define-public python2-django-assets
295 (package-with-python2 python-django-assets))
296
297 (define-public python-django-jsonfield
298 (package
299 (name "python-django-jsonfield")
300 (version "1.0.3")
301 (source (origin
302 (method url-fetch)
303 (uri (pypi-uri "jsonfield" version))
304 (sha256
305 (base32
306 "19x4lak0hg9c20r7mvf27w7i8r6i4sg2g0ypmlmp2665fnk76zvy"))))
307 (build-system python-build-system)
308 (arguments
309 `(#:phases
310 (modify-phases %standard-phases
311 (add-before 'check 'fix-tests
312 (lambda _
313 (substitute* "jsonfield/tests.py"
314 (("django.forms.util") "django.forms.utils")))))))
315 (propagated-inputs
316 `(("python-django" ,python-django)))
317 (home-page "https://github.com/bradjasper/django-jsonfield")
318 (synopsis "Store validated JSON in your model")
319 (description
320 "Django-jsonfield is a reusable Django field that allows you to store
321 validated JSON in your model. It silently takes care of serialization. To
322 use, simply add the field to one of your models.")
323 (license license:expat)))
324
325 (define-public python2-django-jsonfield
326 (package-with-python2 python-django-jsonfield))
327
328 (define-public python-dj-database-url
329 (package
330 (name "python-dj-database-url")
331 (version "0.4.2")
332 (source (origin
333 (method url-fetch)
334 (uri (pypi-uri "dj-database-url" version))
335 (sha256
336 (base32
337 "024zbkc5rli4hia9lz9g8kf1zxhb2gwawj5abf67i7gf8n22v0x6"))))
338 (build-system python-build-system)
339 (home-page "https://github.com/kennethreitz/dj-database-url")
340 (synopsis "Use Database URLs in your Django Application")
341 (description
342 "This simple Django utility allows you to utilize the 12factor inspired
343 DATABASE_URL environment variable to configure your Django application.
344
345 The dj_database_url.config method returns a Django database connection
346 dictionary, populated with all the data specified in your URL. There is also a
347 conn_max_age argument to easily enable Django’s connection pool.")
348 (license license:bsd-2)))
349
350 (define-public python2-dj-database-url
351 (package-with-python2 python-dj-database-url))
352
353 (define-public python-django-bulk-update
354 (package
355 (name "python-django-bulk-update")
356 (version "1.1.10")
357 (source (origin
358 (method url-fetch)
359 (uri (pypi-uri "django-bulk-update" version))
360 (sha256
361 (base32
362 "0mbng9m7swfc0dnidipbzlxfhlfjrv755dlnha5s4m9mgdxb1fhc"))))
363 (build-system python-build-system)
364 (arguments
365 ;; tests don't support django 1.10, but the module seems to work.
366 `(#:tests? #f))
367 (native-inputs
368 `(("six" ,python-six)
369 ("jsonfield" ,python-django-jsonfield)
370 ("python-dj-database-url" ,python-dj-database-url)))
371 (propagated-inputs
372 `(("python-django" ,python-django)))
373 (home-page "https://github.com/aykut/django-bulk-update")
374 (synopsis "Simple bulk update over Django ORM or with helper function")
375 (description
376 "Simple bulk update over Django ORM or with helper function. This
377 project aims to bulk update given objects using one query over Django ORM.")
378 (license license:expat)))
379
380 (define-public python2-django-bulk-update
381 (package-with-python2 python-django-bulk-update))
382
383 (define-public python-django-contact-form
384 (package
385 (name "python-django-contact-form")
386 (version "1.3")
387 (source (origin
388 (method url-fetch)
389 (uri (pypi-uri "django-contact-form" version))
390 (sha256
391 (base32
392 "0az590y56k5ahv4sixrkn54d3a8ig2q2z9pl6s3m4f533mx2gj17"))))
393 (build-system python-build-system)
394 (arguments
395 `(#:phases
396 (modify-phases %standard-phases
397 (replace 'check
398 (lambda _
399 ;; the next version will need "make test"
400 (and (zero? (system* "flake8" "contact_form"))
401 (zero? (system* "coverage" "run" "contact_form/runtests.py"))
402 (zero? (system* "coverage" "report" "-m" "--fail-under" "0"))))))))
403 (native-inputs
404 `(("python-coverage" ,python-coverage)
405 ("python-flake8" ,python-flake8)))
406 (propagated-inputs
407 `(("python-django" ,python-django)))
408 (home-page "https://github.com/ubernostrum/django-contact-form")
409 (synopsis "Contact form for Django")
410 (description
411 "This application provides simple, extensible contact-form functionality
412 for Django sites.")
413 (license license:bsd-3)))
414
415 (define-public python2-django-contact-form
416 (package-with-python2 python-django-contact-form))
417
418 (define-public python-django-contrib-comments
419 (package
420 (name "python-django-contrib-comments")
421 (version "1.8.0")
422 (source (origin
423 (method url-fetch)
424 (uri (pypi-uri "django-contrib-comments" version))
425 (sha256
426 (base32
427 "0bxsgw8jrkhg6r5s0z6ksfi4w8yknaqb1s9acmxd9pm3pnsnp5kx"))))
428 (build-system python-build-system)
429 (propagated-inputs
430 `(("python-django" ,python-django)))
431 (home-page "https://github.com/django/django-contrib-comments")
432 (synopsis "Comments framework")
433 (description
434 "Django used to include a comments framework; since Django 1.6 it's been
435 separated to a separate project. This is that project. This framework can be
436 used to attach comments to any model, so you can use it for comments on blog
437 entries, photos, book chapters, or anything else.")
438 (license license:bsd-3)))
439
440 (define-public python2-django-contrib-comments
441 (package-with-python2 python-django-contrib-comments))
442
443 (define-public python-django-overextends
444 (package
445 (name "python-django-overextends")
446 (version "0.4.3")
447 (source (origin
448 (method url-fetch)
449 (uri (pypi-uri "django-overextends" version))
450 (sha256
451 (base32
452 "0qc2pcf3i56pmfxh2jw7k3pgljd8xzficmkl2541n7bkcbngqfzm"))))
453 (build-system python-build-system)
454 (arguments
455 `(#:phases
456 (modify-phases %standard-phases
457 (replace 'check
458 (lambda _
459 (zero? (system* "./test_project/manage.py" "test")))))))
460 (propagated-inputs
461 `(("python-django" ,python-django)))
462 (native-inputs
463 `(("sphinx-me" ,python-sphinx-me)))
464 (home-page "https://github.com/stephenmcd/django-overextends")
465 (synopsis "Circular template inheritance")
466 (description
467 "A Django reusable app providing the overextends template tag, a drop-in
468 replacement for Django's extends tag, which allows you to use circular template
469 inheritance. The primary use-case for overextends is to simultaneously
470 override and extend templates from other reusable apps, in your own Django
471 project.")
472 (license license:bsd-2)))
473
474 (define-public python2-django-overextends
475 (package-with-python2 python-django-overextends))
476
477 (define-public python-django-redis
478 (package
479 (name "python-django-redis")
480 (version "4.7.0")
481 (source (origin
482 (method url-fetch)
483 (uri (pypi-uri "django-redis" version))
484 (sha256
485 (base32
486 "0yyyxv8n9l9dhs893jsqwg2cxqkkc79g719n9dzzzqgkzialv1c1"))))
487 (build-system python-build-system)
488 (arguments
489 `(#:phases
490 (modify-phases %standard-phases
491 (replace 'check
492 (lambda _
493 (and (zero? (system* "redis-server" "--daemonize" "yes"))
494 (with-directory-excursion "tests"
495 (zero? (system* "python" "runtests.py")))))))))
496 (native-inputs
497 `(("python-fakeredis" ,python-fakeredis)
498 ("python-hiredis" ,python-hiredis)
499 ("python-mock" ,python-mock)
500 ("python-msgpack" ,python-msgpack)
501 ("redis" ,redis)))
502 (propagated-inputs
503 `(("python-django" ,python-django)
504 ("python-redis" ,python-redis)))
505 (home-page "https://github.com/niwibe/django-redis")
506 (synopsis "Full featured redis cache backend for Django")
507 (description
508 "Full featured redis cache backend for Django.")
509 (license license:bsd-3)))
510
511 (define-public python2-django-redis
512 (package-with-python2 python-django-redis))
513
514 (define-public python-django-rq
515 (package
516 (name "python-django-rq")
517 (version "0.9.4")
518 (source (origin
519 (method url-fetch)
520 (uri (pypi-uri "django-rq" version))
521 (sha256
522 (base32
523 "04v8ilfdp10bk31fxgh4cn083gsn5m06342cnpm5d10nd8hc0vky"))))
524 (build-system python-build-system)
525 (arguments
526 `(#:phases
527 (modify-phases %standard-phases
528 (replace 'check
529 (lambda _
530 (and (zero? (system* "redis-server" "--daemonize" "yes"))
531 (zero? (system* "django-admin.py" "test" "django_rq"
532 "--settings=django_rq.test_settings"
533 "--pythonpath="))))))))
534 (native-inputs
535 `(("redis" ,redis)))
536 (propagated-inputs
537 `(("python-django" ,python-django)
538 ("python-rq" ,python-rq)))
539 (home-page "https://github.com/ui/django-rq")
540 (synopsis "Django integration with RQ")
541 (description
542 "Django integration with RQ, a Redis based Python queuing library.
543 Django-RQ is a simple app that allows you to configure your queues in django's
544 settings.py and easily use them in your project.")
545 (license license:expat)))
546
547 (define-public python2-django-rq
548 (package-with-python2 python-django-rq))
549
550 (define-public python-django-sortedm2m
551 (package
552 (name "python-django-sortedm2m")
553 (version "1.3.3")
554 (source (origin
555 (method url-fetch)
556 (uri (pypi-uri "django-sortedm2m" version))
557 (sha256
558 (base32
559 "0axf765i7b3c2s83nlph47asi8s071dhq8l7y382v1pw785s22vi"))))
560 (build-system python-build-system)
561 (arguments
562 ;; no tests.
563 `(#:tests? #f))
564 (propagated-inputs
565 `(("python-django" ,python-django)))
566 (home-page "https://github.com/gregmuellegger/django-sortedm2m")
567 (synopsis "Drop-in replacement for django's own ManyToManyField")
568 (description
569 "Sortedm2m is a drop-in replacement for django's own ManyToManyField.
570 The provided SortedManyToManyField behaves like the original one but remembers
571 the order of added relations.")
572 (license license:bsd-3)))
573
574 (define-public python2-django-sortedm2m
575 (package-with-python2 python-django-sortedm2m))
576
577 (define-public python-django-appconf
578 (package
579 (name "python-django-appconf")
580 (version "1.0.2")
581 (source (origin
582 (method url-fetch)
583 (uri (pypi-uri "django-appconf" version))
584 (sha256
585 (base32
586 "0qdjdx35g66xjsc50v0c5h3kg6njs8df33mbjx6j4k1vd3m9lkba"))))
587 (build-system python-build-system)
588 (propagated-inputs
589 `(("python-django" ,python-django)))
590 (home-page "https://github.com/django-compressor/django-appconf")
591 (synopsis "Handle configuration defaults of packaged Django apps")
592 (description
593 "This app precedes Django's own AppConfig classes that act as \"objects
594 [to] store metadata for an application\" inside Django's app loading mechanism.
595 In other words, they solve a related but different use case than
596 django-appconf and can't easily be used as a replacement. The similarity in
597 name is purely coincidental.")
598 (license license:bsd-3)))
599
600 (define-public python2-django-appconf
601 (package-with-python2 python-django-appconf))
602
603 (define-public python-django-statici18n
604 (package
605 (name "python-django-statici18n")
606 (version "1.3.0")
607 (source (origin
608 (method url-fetch)
609 (uri (pypi-uri "django-statici18n" version))
610 (sha256
611 (base32
612 "0alcf4g1nv69njhq5k3qw4mfl2k6dc18bik5nk0g1mnp3m8zyz7k"))))
613 (build-system python-build-system)
614 (propagated-inputs
615 `(("python-django" ,python-django)
616 ("django-appconf" ,python-django-appconf)))
617 (home-page "https://github.com/zyegfryed/django-statici18n")
618 (synopsis "Generate JavaScript catalog to static files")
619 (description
620 "A Django app that provides helper for generating JavaScript catalog to
621 static files.")
622 (license license:bsd-3)))
623
624 (define-public python2-django-statici18n
625 (package-with-python2 python-django-statici18n))
626
627 (define-public pootle
628 (package
629 (name "pootle")
630 (version "2.8.0rc5")
631 (source
632 (origin
633 (method url-fetch)
634 (uri (pypi-uri "Pootle" version ".tar.bz2"))
635 (sha256
636 (base32
637 "0m6qcpkcy22dk3ad5y2k8851kqg2w6vrkywgy4vabwbacd7r1mvn"))))
638 (build-system python-build-system)
639 (arguments
640 `(; pootle supports only python2.
641 #:python ,python-2
642 ;; tests are not run and fail with "pytest_pootle/data/po/.tmp: No such
643 ;; file or directory". If we create this directory,
644 ;; pytest_pootle/data/po/terminology.po is missing.
645 #:tests? #f
646 #:phases
647 (modify-phases %standard-phases
648 (add-before 'build 'fix-requirements
649 (lambda _
650 (substitute* "Pootle.egg-info/requires.txt"
651 (("1.7.3") "1.8.0")
652 (("2.0.0") "2.1.0"))
653 (substitute* "requirements/tests.txt"
654 (("==3.0.6") ">=3.0.6"))
655 (substitute* "requirements/base.txt"
656 (("1.7.3") "1.8.0")
657 (("2.0.0") "2.1.0")))))))
658 (propagated-inputs
659 `(("django-allauth" ,python2-django-allauth)
660 ("django-assets" ,python2-django-assets)
661 ("django-bulk-update" ,python2-django-bulk-update)
662 ("django-contact-form" ,python2-django-contact-form)
663 ("django-contrib-comments" ,python2-django-contrib-comments)
664 ("django-overextends" ,python2-django-overextends)
665 ("django-redis" ,python2-django-redis)
666 ("django-rq" ,python2-django-rq)
667 ("django-sortedm2m" ,python2-django-sortedm2m)
668 ("django-statici18n" ,python2-django-statici18n)
669 ("babel" ,python2-babel)
670 ("cssmin" ,python2-cssmin)
671 ("diff-match-patch" ,python2-diff-match-patch)
672 ("dirsync" ,python2-dirsync)
673 ("elasticsearch" ,python2-elasticsearch)
674 ("jsonfield" ,python2-django-jsonfield)
675 ("lxml" ,python2-lxml)
676 ("dateutil" ,python2-dateutil)
677 ("levenshtein" ,python2-levenshtein)
678 ("mysqlclient" ,python2-mysqlclient)
679 ("psycopg2" ,python2-psycopg2)
680 ("pytz" ,python2-pytz)
681 ("rq" ,python2-rq)
682 ("scandir" ,python2-scandir)
683 ("stemming" ,python2-stemming)
684 ("translate-toolkit" ,python2-translate-toolkit)))
685 (native-inputs
686 `(("python2-pytest-warnings" ,python2-pytest-warnings)
687 ("python2-pytest-django" ,python2-pytest-django)
688 ("python2-pytest-catchlog" ,python2-pytest-catchlog)
689 ("python2-pytest-cov" ,python2-pytest-cov)
690 ("python2-factory-boy" ,python2-factory-boy)))
691 (home-page "http://pootle.translatehouse.org/")
692 (synopsis "Community localization server")
693 (description
694 "Pootle is an online translation and localization tool. It works to
695 lower the barrier of entry, providing tools to enable teams to work towards
696 higher quality while welcoming newcomers.")
697 (license license:gpl3+)))