Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / libidn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages libidn)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages compression)
24 #:use-module (gnu packages libunistring)
25 #:use-module (guix licenses)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu))
29
30 (define-public libidn
31 (package
32 (name "libidn")
33 (version "1.33")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/libidn/libidn-" version
37 ".tar.gz"))
38 (sha256
39 (base32
40 "068fjg2arlppjqqpzd714n1lf6gxkpac9v5yyvp1qwmv6nvam9s4"))))
41 (build-system gnu-build-system)
42 ;; FIXME: No Java and C# libraries are currently built.
43 (synopsis "Internationalized string processing library")
44 (description
45 "libidn is a library implementing of the Stringprep, Punycode and IDNA
46 specifications. These are used to encode and decode internationalized domain
47 names according to the IDNA2003 specifications. It includes native C, C# and
48 Java libraries.")
49 ;; The C code is dual-licensed gpl2+ lgpl3+, the manual is fdl1.3+,
50 ;; the command line tool is gpl3+.
51 (license (list gpl2+ gpl3+ lgpl3+ fdl1.3+))
52 (home-page "https://www.gnu.org/software/libidn/")))
53
54 (define-public libidn2
55 (package
56 (name "libidn2")
57 (version "2.0.2")
58 (source (origin
59 (method url-fetch)
60 (uri (string-append "mirror://gnu/libidn/" name "-" version
61 ".tar.lz"))
62 (sha256
63 (base32
64 "0pqaj8d01aj4i110669fincqs10kgynyqcrmq2q7pss8v9dcd1jq"))))
65 (native-inputs
66 `(("lzip" ,lzip)))
67 (inputs
68 `(("libunistring" ,libunistring)))
69 (build-system gnu-build-system)
70 (synopsis "Internationalized domain name library for IDNA2008")
71 (description "Libidn2 is an internationalized domain library implementing
72 the IDNA2008 specifications. Libidn2 is believed to be a complete IDNA2008
73 implementation, but has yet to be as extensively used as the original Libidn
74 library.")
75 (home-page "https://www.gnu.org/software/libidn/#libidn2")
76 ;; The command-line tool 'idn2' is GPL3+, while the library is dual-licensed
77 ;; GPL2+ or LGPL3+.
78 (license (list gpl2+ gpl3+ lgpl3+))))