Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / freeipmi.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages freeipmi)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages gnupg))
26
27 (define-public freeipmi
28 (package
29 (name "freeipmi")
30 (version "1.5.6")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/freeipmi/freeipmi-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "0p3cl32wwxhyc5vkd9spmmckb78797snkmplgh0ybc7zap2bs6ib"))))
38 (build-system gnu-build-system)
39 (inputs
40 `(("libgcrypt" ,libgcrypt)))
41 (home-page "https://www.gnu.org/software/freeipmi/")
42 (synopsis "Platform management, including sensor and power monitoring")
43 (description
44 "GNU FreeIPMI is a collection of in-band and out-of-band IPMI software
45 in accordance with the IPMI v1.5/2.0 specification. These programs provide a
46 set of interfaces for platform management. Common functionality includes
47 sensor monitoring, system event monitoring, power control and
48 serial-over-LAN.")
49 (license gpl3+)))