gnu: Add libedit.
[jackhill/guix/guix.git] / gnu / packages / libedit.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages libedit)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages ncurses))
25
26 (define-public libedit
27 (package
28 (name "libedit")
29 (version "20141030-3.1")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "http://thrysoee.dk/editline"
34 "/" name "-" version ".tar.gz"))
35 (sha256
36 (base32
37 "0h2svwfcdldpbg0fy7fnkld706r2a9k9h1mm0yj7z3zvf1jy20cp"))))
38 (build-system gnu-build-system)
39 (inputs
40 `(("ncurses" ,ncurses)))
41 (home-page "http://thrysoee.dk/editline/")
42 (synopsis "NetBSD Editline library")
43 (description
44 "This is an autotool- and libtoolized port of the NetBSD Editline
45 library (libedit). This Berkeley-style licensed command line editor library
46 provides generic line editing, history, and tokenization functions, similar to
47 those found in GNU Readline.")
48 (license bsd-3)))
49
50 ;;; libedit.scm ends here