gnu: Add Pfff.
[jackhill/guix/guix.git] / gnu / packages / tor.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages tor)
21 #:use-module ((guix licenses) #:select (bsd-3 gpl2+ gpl2))
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages libevent)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages pcre)
30 #:use-module (gnu packages perl)
31 #:use-module (gnu packages python)
32 #:use-module (gnu packages autotools)
33 #:use-module (gnu packages tls)
34 #:use-module (gnu packages w3m))
35
36 (define-public tor
37 (package
38 (name "tor")
39 (version "0.2.7.5")
40 (source (origin
41 (method url-fetch)
42 (uri (string-append "https://www.torproject.org/dist/tor-"
43 version ".tar.gz"))
44 (sha256
45 (base32
46 "0pxayvcab4cb107ynbpzx4g0qyr1mjfba2an76wdx6dxn56rwakx"))))
47 (build-system gnu-build-system)
48 (native-inputs
49 `(("python" ,python-2))) ; for tests
50 (inputs
51 `(("zlib" ,zlib)
52 ("openssl" ,openssl)
53 ("libevent" ,libevent)))
54
55 ;; TODO: Recommend `torsocks' since `torify' needs it.
56
57 (home-page "http://www.torproject.org/")
58 (synopsis "Anonymous network router to improve privacy on the Internet")
59 (description
60 "Tor protects you by bouncing your communications around a distributed
61 network of relays run by volunteers all around the world: it prevents
62 somebody watching your Internet connection from learning what sites you
63 visit, and it prevents the sites you visit from learning your physical
64 location. Tor works with many of your existing applications, including
65 web browsers, instant messaging clients, remote login, and other
66 applications based on the TCP protocol.")
67 (license bsd-3)))
68
69 (define-public torsocks
70 (package
71 (name "torsocks")
72 (version "2.0.0")
73 (source (origin
74 (method git-fetch)
75 (uri (git-reference
76 (url "https://git.torproject.org/torsocks.git")
77 (commit (string-append "v" version))))
78 (sha256
79 (base32
80 "0an2q5ail9z414riyjbkjkm29504hy778j914baz2gn5hlv2cfak"))
81 (file-name (string-append name "-" version "-checkout"))
82 (patches (list (search-patch "torsocks-dns-test.patch")))))
83 (build-system gnu-build-system)
84 (arguments
85 '(#:phases (modify-phases %standard-phases
86 (add-before 'configure 'bootstrap
87 (lambda _
88 (system* "autoreconf" "-vfi"))))))
89 (native-inputs `(("autoconf" ,(autoconf-wrapper))
90 ("automake" ,automake)
91 ("libtool" ,libtool)
92 ("perl-test-harness" ,perl-test-harness)))
93 (home-page "http://www.torproject.org/")
94 (synopsis "Use socks-friendly applications with Tor")
95 (description
96 "Torsocks allows you to use most socks-friendly applications in a safe
97 way with Tor. It ensures that DNS requests are handled safely and explicitly
98 rejects UDP traffic from the application you're using.")
99
100 ;; All the files explicitly say "version 2 only".
101 (license gpl2)))
102
103 (define-public privoxy
104 (package
105 (name "privoxy")
106 (version "3.0.21")
107 (source (origin
108 (method url-fetch)
109 (uri (string-append "mirror://sourceforge/ijbswa/Sources/"
110 version "%20%28stable%29/privoxy-"
111 version "-stable-src.tar.gz"))
112 (sha256
113 (base32
114 "1f6xb7aa47p90c26vqaw74y6drs9gpnhxsgby3mx0awdjh0ydisy"))))
115 (build-system gnu-build-system)
116 (arguments
117 '(;; The default 'sysconfdir' is $out/etc; change that to
118 ;; $out/etc/privoxy.
119 #:configure-flags (list (string-append "--sysconfdir="
120 (assoc-ref %outputs "out")
121 "/etc/privoxy"))
122 #:phases (alist-cons-after
123 'unpack 'autoconf
124 (lambda _
125 ;; Unfortunately, this is not a tarball produced by
126 ;; "make dist".
127 (zero? (system* "autoreconf" "-vfi")))
128 %standard-phases)
129 #:tests? #f))
130 (inputs
131 `(("w3m" ,w3m)
132 ("pcre" ,pcre)
133 ("zlib" ,zlib)
134 ("autoconf" ,autoconf)
135 ("automake" ,automake)))
136 (home-page "http://www.privoxy.org")
137 (synopsis "Web proxy with advanced filtering capabilities for enhancing privacy")
138 (description
139 "Privoxy is a non-caching web proxy with advanced filtering capabilities
140 for enhancing privacy, modifying web page data and HTTP headers, controlling
141 access, and removing ads and other obnoxious Internet junk. Privoxy has a
142 flexible configuration and can be customized to suit individual needs and
143 tastes. It has application for both stand-alone systems and multi-user
144 networks.")
145 (license gpl2+)))