gnu: Add Pfff.
[jackhill/guix/guix.git] / gnu / packages / screen.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages screen)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages ncurses)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages python)
30 #:use-module (gnu packages slang)
31 #:use-module (gnu packages texinfo))
32
33 (define-public screen
34 (package
35 (name "screen")
36 (version "4.3.1")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "mirror://gnu/screen/screen-"
40 version ".tar.gz"))
41 (sha256
42 (base32 "0qwxd4axkgvxjigz9xs0kcv6qpfkrzr2gm43w9idx0z2mvw4jh7s"))))
43 (build-system gnu-build-system)
44 (native-inputs
45 `(("makeinfo" ,texinfo)))
46 (inputs
47 `(("ncurses", ncurses)
48 ("perl" ,perl)))
49 (arguments
50 `(#:configure-flags
51 ;; By default, man and info pages are put in PREFIX/{man,info},
52 ;; but we want them in PREFIX/share/{man,info}.
53 (let ((out (assoc-ref %outputs "out")))
54 (list (string-append "--mandir=" out "/share/man")
55 (string-append "--infodir=" out "/share/info")))))
56 (home-page "http://www.gnu.org/software/screen/")
57 (synopsis "Full-screen window manager providing multiple terminals")
58 (description
59 "GNU Screen is a terminal window manager that multiplexes a single
60 terminal between several processes. The virtual terminals each provide
61 features such as a scroll-back buffer and a copy-and-paste mechanism. Screen
62 then manages the different virtual terminals, allowing you to easily switch
63 between them, to detach them from the current session, or even splitting the
64 view to show two terminals at once.")
65 (license gpl2+)))
66
67 (define-public dtach
68 (package
69 (name "dtach")
70 (version "0.8")
71 (source (origin
72 (method url-fetch)
73 (uri (string-append "mirror://sourceforge/dtach/dtach-"
74 version ".tar.gz"))
75 (sha256
76 (base32
77 "1agjp08zxxxfni62sqx9qsd9526yqwlz7ry07lfq3clavyylwq8n"))))
78 (build-system gnu-build-system)
79 (arguments
80 ;; No install target.
81 '(#:phases (alist-replace
82 'install
83 (lambda* (#:key outputs #:allow-other-keys)
84 (let ((out (assoc-ref outputs "out")))
85 (install-file "dtach" (string-append out "/bin"))))
86 %standard-phases)
87 ;; No check target.
88 #:tests? #f))
89 (home-page "http://dtach.sourceforge.net/")
90 (synopsis "Emulates the detach feature of screen")
91 (description
92 "dtach is a tiny program that emulates the detach feature of screen,
93 allowing you to run a program in an environment that is protected from the
94 controlling terminal and attach to it later.")
95 (license gpl2+)))
96
97 (define-public byobu
98 (package
99 (name "byobu")
100 (version "5.98")
101 (source
102 (origin
103 (method url-fetch)
104 (uri (string-append "https://launchpad.net/byobu/trunk/"
105 version "/+download/byobu_"
106 version ".orig.tar.gz"))
107 (sha256
108 (base32
109 "1s8nh4wbds1nh52i0d1hy1b308jjf4siwpq92lna1zh9ll4x71j5"))
110 (patches (list (search-patch "byobu-writable-status.patch")))))
111 (build-system gnu-build-system)
112 (inputs
113 `(("python" ,python-wrapper) ;for config and session GUIs
114 ("python-newt" ,newt "python")))
115 (arguments
116 `(#:phases
117 (modify-phases %standard-phases
118 (add-before
119 'configure 'provide-locale
120 (lambda* (#:key inputs #:allow-other-keys)
121 (let ((libc (assoc-ref inputs "libc"))) ;implicit input
122 (substitute* "usr/bin/byobu.in"
123 (("locale") (string-append libc "/bin/locale"))))))
124 (add-after
125 'install 'wrap-python-scripts
126 (lambda* (#:key inputs outputs #:allow-other-keys)
127 (let* ((python (string-append (assoc-ref inputs "python")
128 "/bin/python"))
129 (out (assoc-ref outputs "out"))
130 (config (string-append out "/bin/byobu-config"))
131 (select (string-append out "/bin/byobu-select-session")))
132 (wrap-program config
133 `("BYOBU_PYTHON" = (,python))
134 `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH"))))
135 (wrap-program select
136 `("BYOBU_PYTHON" = (,python)))
137 #t))))))
138 (home-page "http://byobu.co/index.html")
139 (synopsis "Text-based window manager and terminal multiplexer")
140 (description
141 "Byobu is a Japanese term for decorative, multi-panel screens that serve
142 as folding room dividers. The Byobu software includes an enhanced profile,
143 configuration utilities, and system status notifications for the GNU Screen
144 window manager as well as the Tmux terminal multiplexer.")
145 (license gpl3+)))