gnu: Add Pfff.
[jackhill/guix/guix.git] / gnu / packages / password-utils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
3 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages password-utils)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix build-system cmake)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix download)
26 #:use-module (guix packages)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages gnupg)
29 #:use-module (gnu packages guile)
30 #:use-module (gnu packages ncurses)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages tls)
33 #:use-module (gnu packages qt)
34 #:use-module (gnu packages xdisorg)
35 #:use-module (gnu packages xorg))
36
37 (define-public pwgen
38 (package
39 (name "pwgen")
40 (version "2.07")
41 (source
42 (origin
43 (method url-fetch)
44 (uri (string-append "mirror://sourceforge/pwgen/pwgen-"
45 version ".tar.gz"))
46 (sha256
47 (base32 "0mhmw700kkh238fzivcwnwi94bj9f3h36yfh3k3j2v19b0zmjx7b"))))
48 (build-system gnu-build-system)
49 (arguments
50 `(#:tests? #f)) ; no test suite
51 (home-page "http://pwgen.sourceforge.net/")
52 (synopsis "Password generator")
53 (description "Pwgen generates passwords which can be easily memorized by a
54 human.")
55 (license license:gpl2)))
56
57 (define-public keepassx
58 (package
59 (name "keepassx")
60 (version "2.0")
61 (source
62 (origin
63 (method url-fetch)
64 (uri (string-append "https://www.keepassx.org/releases/" version
65 "/keepassx-" version ".tar.gz"))
66 (sha256
67 (base32 "1ri2r1sldc62hbg74m4pmci0nrjwvv38rqhyzhyjin247an0zd0f"))))
68 (build-system cmake-build-system)
69 (inputs
70 `(("libgcrypt" ,libgcrypt)
71 ("libxtst" ,libxtst)
72 ("qt" ,qt-4)))
73 (native-inputs
74 `(("zlib" ,zlib)))
75 (home-page "https://www.keepassx.org")
76 (synopsis "Password manager")
77 (description "KeePassX is a password manager or safe which helps you to
78 manage your passwords in a secure way. You can put all your passwords in one
79 database, which is locked with one master key or a key-file which can be stored
80 on an external storage device. The databases are encrypted using the
81 algorithms AES or Twofish.")
82 ;; Non functional parts use various licences.
83 (license license:gpl3)))
84
85 (define-public shroud
86 (package
87 (name "shroud")
88 (version "0.1.1")
89 (source (origin
90 (method url-fetch)
91 (uri (string-append "http://files.dthompson.us/shroud/shroud-"
92 version ".tar.gz"))
93 (sha256
94 (base32
95 "1y43yhgy2zbrk5bqj3qyx9rkcz2bma9sinlrg7dip3jqms9gq4lr"))))
96 (build-system gnu-build-system)
97 (inputs
98 `(("guile" ,guile-2.0)
99 ("gnupg" ,gnupg)
100 ("xclip" ,xclip)))
101 (synopsis "GnuPG-based secret manager")
102 (description "Shroud is a simple secret manager with a command line
103 interface. The password database is stored as a Scheme s-expression and
104 encrypted with a GnuPG key. Secrets consist of an arbitrary number of
105 key/value pairs, making Shroud suitable for more than just password storage.
106 For copying and pasting secrets into web browsers and other graphical
107 applications, there is xclip integration." )
108 (home-page "http://dthompson.us/pages/software/shroud.html")
109 (license license:gpl3+)))
110
111 (define-public yapet
112 (package
113 (name "yapet")
114 (version "1.0")
115 (source (origin
116 (method url-fetch)
117 (uri (string-append "http://www.guengel.ch/myapps/yapet/downloads/yapet-"
118 version
119 ".tar.bz2"))
120 (sha256
121 (base32
122 "0ydbnqw6icdh07pnv2w6dhvq501bdfvrklv4xmyr8znca9d753if"))))
123 (build-system gnu-build-system)
124 (inputs
125 `(("ncurses" ,ncurses)
126 ("openssl" ,openssl)))
127 (native-inputs
128 `(("pkg-config" ,pkg-config)))
129 (synopsis "Yet Another Password Encryption Tool")
130 (description "YAPET is a text based password manager using the Blowfish
131 encryption algorithm. Because of its small footprint and very few library
132 dependencies, it is suited for installing on desktop and server systems alike.
133 The text based user interface allows you to run YAPET easily in a Secure Shell
134 session. Two companion utilities enable users to convert CSV files to YAPET
135 and vice versa.")
136 (home-page "http://www.guengel.ch/myapps/yapet/")
137 (license license:gpl3+)))
138
139 (define-public cracklib
140 (package
141 (name "cracklib")
142 (version "2.9.6")
143 (source (origin
144 (method url-fetch)
145 (uri (string-append "https://github.com/cracklib/cracklib/"
146 "releases/download/" name "-" version "/"
147 name "-" version ".tar.gz"))
148 (sha256
149 (base32
150 "0hrkb0prf7n92w6rxgq0ilzkk6rkhpys2cfqkrbzswp27na7dkqp"))))
151 (build-system gnu-build-system)
152 (synopsis "Password checking library")
153 (home-page "https://github.com/cracklib/cracklib")
154 (description
155 "CrackLib is a library containing a C function which may be used in a
156 passwd like program. The idea is simple: try to prevent users from choosing
157 passwords that could be guessed by crack by filtering them out, at source.")
158 (license license:lgpl2.1)))
159
160 (define-public libpwquality
161 (package
162 (name "libpwquality")
163 (version "1.3.0")
164 (source (origin
165 (method url-fetch)
166 (uri (list
167 (string-append "https://fedorahosted.org/releases/l/i/"
168 name "/" name "-" version ".tar.bz2")
169 (string-append "https://launchpad.net/libpwquality/trunk/"
170 version "/+download/"
171 name "-" version ".tar.bz2")))
172 (sha256
173 (base32
174 "0aidriag6h0syfm33nzdfdsqgrnsgihwjv3a5lgkqch3w68fmlkl"))))
175 (build-system gnu-build-system)
176 (arguments
177 ;; XXX: have RUNPATH issue.
178 '(#:configure-flags '("--disable-python-bindings")))
179 (inputs
180 `(("cracklib" ,cracklib)))
181 (synopsis "Password quality checker")
182 (home-page "https://fedorahosted.org/libpwquality/")
183 (description
184 "Libpwquality is a library for password quality checking and generation of
185 random passwords that pass the checks.")
186 (license license:gpl2+)))