gnu: Add Pfff.
[jackhill/guix/guix.git] / gnu / packages / kde-frameworks.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages kde-frameworks)
20 #:use-module (guix build-system cmake)
21 #:use-module (guix download)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix utils)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages qt)
27 #:use-module (gnu packages xorg))
28
29 (define kde-frameworks-version "5.12.0")
30
31 (define-public extra-cmake-modules
32 (package
33 (name "extra-cmake-modules")
34 (version kde-frameworks-version)
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "http://download.kde.org/stable/frameworks/"
39 (version-major+minor version) "/"
40 name "-" version ".tar.xz"))
41 (sha256
42 (base32 "14n77sn493m8kzr42wv13mdgxpnbx7x64bvw37ircrx8wmf4002i"))))
43 ;; The package looks for Qt5LinguistTools provided by Qt, but apparently
44 ;; compiles without it; it might be needed for building the
45 ;; documentation, which requires the additional Sphinx package.
46 ;; To save space, we do not add these inputs.
47 (build-system cmake-build-system)
48 (home-page "https://community.kde.org/Frameworks")
49 (synopsis "CMake module files for common software used by KDE")
50 (description "The Extra CMake Modules package, or ECM, adds to the
51 modules provided by CMake to find common software. In addition, it provides
52 common build settings used in software produced by the KDE community.")
53 (license license:bsd-3)))
54
55 (define-public kwindowsystem
56 (package
57 (name "kwindowsystem")
58 (version kde-frameworks-version)
59 (source
60 (origin
61 (method url-fetch)
62 (uri (string-append "http://download.kde.org/stable/frameworks/"
63 (version-major+minor version) "/"
64 name "-" version ".tar.xz"))
65 (sha256
66 (base32 "0fjxhf07r186cmp0mjvinrwxg4z90zlyvycqhy0n18fdp67szckl"))))
67 (build-system cmake-build-system)
68 (native-inputs
69 `(("pkg-config" ,pkg-config)
70 ("xorg-server" ,xorg-server))) ; for the tests
71 (inputs
72 `(("extra-cmake-modules" ,extra-cmake-modules)
73 ("libxrender" ,libxrender)
74 ("qt" ,qt)
75 ("xcb-utils-keysyms" ,xcb-util-keysyms)))
76 (arguments
77 `(#:tests? #f)) ; FIXME: The first seven tests fail with "Exception".
78 (home-page "https://community.kde.org/Frameworks")
79 (synopsis "KDE access to the windowing system")
80 (description "KWindowSystem provides information about and allows
81 interaction with the windowing system. It provides a high level API, which
82 is windowing system independent and has platform specific
83 implementations. This API is inspired by X11 and thus not all functionality
84 is available on all windowing systems.
85
86 In addition to the high level API, this framework also provides several
87 lower level classes for interaction with the X Windowing System.")
88 ;; Some source files mention lgpl2.0+, but the included license is
89 ;; the lgpl2.1. Some source files are under non-copyleft licenses.
90 (license license:lgpl2.1+)))