gnu: Add Pfff.
[jackhill/guix/guix.git] / gnu / packages / fvwm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages fvwm)
20 #:use-module ((guix licenses) #:select (gpl2+))
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages fribidi)
25 #:use-module (gnu packages gnome)
26 #:use-module (gnu packages image)
27 #:use-module (gnu packages perl)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages readline)
30 #:use-module (gnu packages xml)
31 #:use-module (gnu packages xorg))
32
33 (define-public fvwm
34 (package
35 (name "fvwm")
36 (version "2.6.5")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append
40 "ftp://ftp.fvwm.org/pub/fvwm/version-2/fvwm-"
41 version ".tar.bz2"))
42 (sha256
43 (base32
44 "1ks8igvmzm0m0sra05k8xzc8vkqy3gv1qskl6davw1irqnarjm11"))))
45 (build-system gnu-build-system)
46 (native-inputs
47 `(("perl" ,perl)
48 ("pkg-config" ,pkg-config)
49 ("xsltproc" ,libxslt)))
50 (inputs
51 `(("fribidi" ,fribidi)
52 ("libpng" ,libpng)
53 ("librsvg" ,librsvg)
54 ("libxcursor" ,libxcursor)
55 ("libxext" ,libxext)
56 ("libxft" ,libxft)
57 ("libxinerama" ,libxinerama)
58 ("libxpm" ,libxpm)
59 ("libxt" ,libxt)
60 ("readline" ,readline)))
61 (synopsis "Virtual window manager for X11")
62 (description
63 "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
64 window manager for the X Window system.")
65 (home-page "http://www.fvwm.org/")
66 (license gpl2+)))