gnu: Add Pfff.
[jackhill/guix/guix.git] / gnu / packages / crypto.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 David Thompson <davet@gnu.org>
3 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages crypto)
21 #:use-module (gnu packages)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public libsodium
28 (package
29 (name "libsodium")
30 (version "1.0.0")
31 (source (origin
32 (method url-fetch)
33 (uri (list (string-append
34 "http://download.libsodium.org/libsodium/"
35 "releases/libsodium-" version ".tar.gz")
36 (string-append
37 "https://download.libsodium.org/libsodium/"
38 "releases/old/libsodium-" version ".tar.gz")))
39 (sha256
40 (base32
41 "19f9vf0shfp4rc4l791r6xjg06z4i8psj1zkjkm3z5b640yzxlff"))))
42 (build-system gnu-build-system)
43 (synopsis "Portable NaCl-based crypto library")
44 (description
45 "Sodium is a new easy-to-use high-speed software library for network
46 communication, encryption, decryption, signatures, etc.")
47 (license isc)
48 (home-page "http://libsodium.org")))